Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,763,936

members

53

online now

1,919,255

discussions

Back to Top

Poor reliability from Arris TG1682G?

Contributor

Poor reliability from Arris TG1682G?

Has anyone else had reliability issues with the TG1682G? The reason I ask is that I've been with Xfinity for 4 years, and the unit seems to last 12-16 months before needing to be replaced. It looks like I am going down that road yet again - for the third or fourth time (I've lost count, frankly). My symptom is quite the doozy - my netbook is the only thing that can connect to the net. I have numerous other devices (including an Internet Radio, Fire TV Stick, Xfinity's own Home service, 2 TP Link Smart Plugs and an Amazon Echo Dot) that were working fine yesterday, but now are inoperative because they can't connect to the net.

 

At first I thought an electrical surge took out stuff, but a surge doesn't explain why numerous discrete devices were all impacted in precisely the same way at the same time. That could be what damaged the router - but that doesn't explain why my netbook can connect, but nothing else can. 

 

Darn wierd!   

Problem Solver

Re: Poor reliability from Arris TG1682G?

Hi Mike:

 

I have had my Arris TG1682G for over a year now and it seems to be working great. Have you tried a full factory reset and reset your system from scratch. I think that all Comcast gateways will only let you use a maximum of 12-15 devices with your gateway, that includes wired and wifi in the totals. 

 

Let us know if the factory reset works and repost your results we would love to help you if we can,