Xfinity plant
Xfinity globe
Community Forum

Poor WIFI speeds with xfinity blast, Orbi and Arris SB8200 Cable Modem

New Poster

Poor WIFI speeds with xfinity blast, Orbi and Arris SB8200 Cable Modem

Hi,

 

I have a very unique and frustrating issue which I am hoping to resolve. I don’t believe that I am the only one facing this issue so I hope my post will help others also.

 

My current problem is; my WIFI is very slow or significantly slower than the service plan I have subscribed to. I am posting the following problem on the xfinity board, Netgear Orbi support and Arris SB8200 support board. I’m hoping that we can isolate the root cause of my slow WIFI / internet speed and be able to leverage the full amount I am paying every month.

 

Background information

I currently have 7 devices around the house consisting of; iPhones, ipads, smart TV, XBOX, personal and work computers.

 

I currently have subscribed to the xfinity internet service with the Blast. This plan outlines internet speeds of 250 MBPS download and 10 MBPS upload. I have the Arris SB8200 cable modem, and the Orbi AC3000 (RBR50 router and 2 RBS50 Satellites). The Orbi Router is connected to the SB8200 Cable Modem.

 

Performance statistics

When I connect my MacBook Pro computer (via hard RJ45 Cat5e cable) to the SB8200 cable modem, I am able to achieve internet speeds of 250+ MBPS download and 10+ MBPS uploads. This is the perfect world.

 

When I connect my MacBook Pro computer (via RJ45 Cat5e cable) to the Orbi router, I am only able to achieve internet speeds of 35 MBPS download and 10-11 MBPS upload. This is not the perfect world.

 

When I connect my MacBook pro computer via WIFI I am only able to achieve internet speeds of 35 MBPS download and 10-11 MBPS upload. This is not the perfect world.

 

It appears that all these devices are not working well together. Is there something that I can adjust to help me achieve the 250 MBPS speed that I am paying for on a monthly basis?

 

I am happy to provide any supporting information to work through this issue.

 

Any help or advise anybody can provide would be greatly appreciated.

 

Yours truly,

Frustrated user


Accepted Solutions
Expert

Re: Poor WIFI speeds with xfinity blast, Orbi and Arris SB8200 Cable Modem

Yes, I agree with @scottbeamer. If you are seeing full speeds connected directly to the modem via ethernet, then it's not a Comcast issue, but rather a home networking problem. Probably the Orb/Netgear folks would be best equipped to help you. 


All Replies
Contributor

Re: Poor WIFI speeds with xfinity blast, Orbi and Arris SB8200 Cable Modem

Sounds to me like the router is your problem, I'd get in touch with Netgear.
Expert

Re: Poor WIFI speeds with xfinity blast, Orbi and Arris SB8200 Cable Modem

Yes, I agree with @scottbeamer. If you are seeing full speeds connected directly to the modem via ethernet, then it's not a Comcast issue, but rather a home networking problem. Probably the Orb/Netgear folks would be best equipped to help you. 

Expert

Re: Poor WIFI speeds with xfinity blast, Orbi and Arris SB8200 Cable Modem

I have the XB6 gateway, an Orbi and two Orbi satellites.  My gateway has its wifi turned off and the Orbi is in AP Mode.  As I sit here next to the Orbi in my "computer room", I am getting 300 down wifi with a 250 speed tier with the Orbi SSID for my iPhone7.

 

Just an FYI.