Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,727,795

members

49

online now

1,889,583

discussions

Back to Top

Motorola SB6121 and Linksys E3200 = SLOW

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 9
3,368 Views

My first post - I am using a 6121 and E3200...All is well when using an ethernet cable (50+Mbs), but wireless and I am down to 15-20...What kind of drop should I expect when I go wireless - 50% seems extreme.  BTW - I have tried resetting the router, changing channels, and limiting it to 2.4 Ghz.

 

Thanks in advance.

8 REPLIES
Posted by
Connection Expert

Message 2 of 9
3,339 Views

I don't know the specs on your router, but I think a 2.4gig Wireless G maxes out at 54mbs and most dont come close to that.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 9
3,293 Views

Thanks - Its an "N" - but slow...I'll be replacing it tomorrow.

Posted by
Connection Expert

Message 4 of 9
3,269 Views

Good luck with iit.  Please post back and let us know how it works out.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Contributor

Message 5 of 9
3,243 Views

I replaced my Linksys E3200 with a Netgear WNDR3700 where you can make the max speed at 300mb on both 2.4 and 5ghz and the performance blew my mind.  The SB6121 is a great modem. I always went with Cisco routers thinking that they'd be a no-brainer when it comes to routers. But lately, I went from a E1200, to E2500, to E3200, to the heck with it, let's try a Netgear router and presto. My Wifi gripes have ceased

Posted by
Connection Expert

Message 6 of 9
3,241 Views

VESPA5 wrote:

 

The SB6121 is a great modem.


FWIW, I would have to generally disagree with that after seeing the boatloads of posts here over the last year about performance and firmware issues with it. Also, even though it is DOCSIS 3 capable, it on offers only 4 multiple bonded downstream channels. The Motorola SB6141 and the Zoom 5341J (note the J) both offer 8 bonded downstream channels. Having a fatter pipe technically would offer better / more consistant performance especially during times of peak internet usage on possibly overcrowded cable segments. IMHO the Zoom 5341J is a GREAT modem.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 7 of 9
2,975 Views

I have a similar problem.  I subscribe to the "Blast" service tier, and I was using the Comcast SMC D3GNV wireless gateway.  I had 2 computers conected to this gateway.  One connected with an ethernet cable and one connected with wireless-N.  On both computers I would consistently get download speeds of 48 to 51 Mbps, and upload speeds of 10 to 11 Mbps.

 

I decided to purchase my own equipment, rather than rent from Comcast.  I purchased a Motorola SB6141 modem and a Linksys E3200 router.  Once the new equipments was set up, I noticed that my wireless download speeds had dropped considerably.  On the computer connected to the E3200 with the ethernet cable, I still get 50/10 speeds.  However, on the computer connected to the E3200 using wireless-N, I have much lower download speeds.  Using the 2.4 GHz band, my speeds are 23/10 and when I use the 5 GHz band I get 28/10 speeds.

 

I am assuming that this is an issue with the router, since I get my full 50/10 speeds when the router is connected to the modem with an ethernet cable.  With the Comcast SMC gateway I was able to get 50/10 speeds on both ethernet and wireless-N.

 

Any suggestions?

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 8 of 9
1,544 Views

10/4/2014

 

Note, I did the same test with Comcast's new Docsis 3.0 wireless router/modem and achieved the same bandwidth results. The Cisco E3200 is just slower regardless of the settings!  I've spent plenty of time testing and I concur, it's bad on thruput, good at keeping a connection at distance though.

 

I have a Dlink N router that get twice the speed but I'm having trouble with it dropping (another issue, another thread).

Posted by
Connection Expert

Message 9 of 9
1,533 Views

Year old thread now being closed.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon