Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,707,504

members

16

online now

1,871,349

discussions

Back to Top

Keep losing internet connection

Posted by
New Poster
  • Congrats on Posting your first topic!

Message 1 of 4
1,265 Views

So i have the comcast internet and i ordered the free router that comcast provides, I assembled it and i set the wireless and everything runs fine.. Until a few hours later the internet connection from the router to the modem gets lost.. thats what i prosume.. There still is wireless connection but not internet feed, i had to shut off my router and turn it back on; then it works. Is there any way to fix this?

3 REPLIES
Posted by
Connection Expert

Message 2 of 4
1,227 Views
Can you provide a list of the lights on the modem and their status at the time of failure? (Off,On or Flashing )? What make and model is your modem?



Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 4
1,177 Views

I had a similar problem at one time, where I'd have service and then it would cut out for just a moment and come back on. If that is it, its a loose coax cable somewhere in the house or the connection to the pole outside.

 

Do not climb the pole in an attempt to tighten it, if you checked your entire house. Contact your local Comcast office and have a professional do it.

 

But if it is not it may be a local problem as some worker in Richlands cut a fiber optic cable killing everyone's service in a similar way you are describing.

 

If it persists attempt to contact customer service.

Posted by
Connection Expert

Message 4 of 4
1,159 Views

WOW....




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon