Xfinity plant
Xfinity globe
Community Forum

Issue connecting to Xfinity Wifi Hotspot "Another device on the network is using your computer's IP"

New Poster

Issue connecting to Xfinity Wifi Hotspot "Another device on the network is using your computer's IP"

I am not able to get a consistent connection using an xfinity wifi hotspot, several times a day I'll get a pop-up that says "Another device on the network is using your computer's IP address". I've tried changing the ip address on my macbook, manually and having it choose one automatically. The only way I've found to get back on is to login to my comcast account, navigate to settings -> internet -> manage devices and remove the laptop I'm using from the list of devices using a hotspot. It can take up to a couple hours before it starts working again, and usually just a few hours before I get the error again.

 

Screen Shot 2018-01-07 at 6.23.08 AM.png

New Poster

Re: Issue connecting to Xfinity Wifi Hotspot "Another device on the network is using your compu

Get this resolved?  Macbook you say?  I am having the same issue with my 2011 macbook pro running Yosemite which is notorious for garbage wifi performance.    It was driving me nuts.  For the time being I've got an inelegant stop gap...a shell script running  w/  root privileges that does a dns lookup every 3 seconds and bounces en1 if it fails.  ridiculous that it works but it does.  

New Poster

Re: Issue connecting to Xfinity Wifi Hotspot "Another device on the network is using your compu

I started having the same issue about a week ago on MacBook. I tried renewing and releasing the IPaddress. I tried making a new IP address. Nothing worked.

 

My other devices do not pop up an error message, but the hotspot wifi just stops working.

Expert

Re: Issue connecting to Xfinity Wifi Hotspot "Another device on the network is using your compu

 A google on that phrase came up with quite a few hits.