Xfinity plant
Xfinity globe
Community Forum

Internet not working on work laptops- is Airport Extreme the issue? Help!

New Poster

Internet not working on work laptops- is Airport Extreme the issue? Help!

The internet had been slow/ inconsistent to so we replaced our old Apple Airport with the Airport Extreme.  It seemed faster.  A few weeks later we realized we couldn't get online with our work laptops with our network.  It also offered xfinity (unsecure) to connect instead.  Weird.  I could sort of get this to work but it would kick me off the network frequently.  My company has extra security stuff on our laptops.  I have tried my work laptop at a bar and at the airport, no problem.  My home laptop connects to the network. 

 

We have a comcast modem.  Do we even need the airport extreme?  I'm wondering if the airport is an extra layer of complication.  I've tried turning power on and off for the airport, it's still blinking yellow. 

 

Help!

Expert

Re: Internet not working on work laptops- is Airport Extreme the issue? Help!

If you are going to hang the Airport Extreme off of the Comcast gateway device, and the gateway is not in *bridge mode*, you are cascading 2 routing devices which results in an undesirable "double NAT" condition on your home network.

Google "double NAT" for info about it's potential pitfalls.

You really should put it in to bridge mode. Here's how;

https://www.xfinity.com/support/articles/wireless-gateway-enable-disable-bridge-mode 


http://forums.comcast.com/t5/Home-Networking-Router-WiFi/Gateways-and-Bridge-Mode/td-p/2419143