Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,622,904

members

52

online now

1,802,952

discussions

Back to Top

IPv6 prefix delegation

SOLVED
Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 48
7,738 Views

How do I go about requesting an IPv6 delegated prefix?  All of my equipment is configured and ready to go. My gateway device has an address, but there is not prefix delegated, so no other device on my network has an address.

47 REPLIES
Posted by
Networking Expert

Message 2 of 48
8,688 Views
Solution

What is the first portion of the address you are getting? Is it a 6to4tunnel address (starts with 2002), or a Comcast address. If it is a 6to4 address, you may not be in an area that is IPv6 ready yet.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

I don't work for Comcast...


Help us to help you!!
- respond to requests for info
- post back if your issue is resolved
- mark appropriate posts as solutions


Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 48
7,618 Views

My aplogies.  I've been out of town.  The currently assigned address is 2002:47c6:7f8::1.

 

I tried using tunnelling, but turned it off several months ago, due to poor performance and intermittantly not being able to communicate with IPv4 devices on my home network.

Posted by
Authorized Vendor

Message 4 of 48
7,541 Views

JerelW wrote:

My aplogies.  I've been out of town.  The currently assigned address is 2002:47c6:7f8::1.

 

I tried using tunnelling, but turned it off several months ago, due to poor performance and intermittantly not being able to communicate with IPv4 devices on my home network.


Why are you tunneling?  Your on a CMTS that supports dual-stack, I would go that route myself..

 

The CMTS that services your area supports IPv6 and the DHCP server is currently handing out leases.  As long as your modem supports IPv6 CPE look here: http://mydeviceinfo.comcast.net/?s=i&so=1&e=0&d3=0&tier=-1&sc=401 and your router supports DHCPv6-PD.  Then you should be good to go.

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
Posted by
Networking Expert

Message 5 of 48
7,525 Views

ComcastTuska wrote:

JerelW wrote:

My aplogies.  I've been out of town.  The currently assigned address is 2002:47c6:7f8::1.

 

I tried using tunnelling, but turned it off several months ago, due to poor performance and intermittantly not being able to communicate with IPv4 devices on my home network.


Why are you tunneling?  Your on a CMTS that supports dual-stack, I would go that route myself..

 

The CMTS that services your area supports IPv6 and the DHCP server is currently handing out leases.  As long as your modem supports IPv6 CPE look here: http://mydeviceinfo.comcast.net/?s=i&so=1&e=0&d3=0&tier=-1&sc=401 and your router supports DHCPv6-PD.  Then you should be good to go.


If you are on aCMTS that supports Native IPv6, try setting your router IPv6 config to DHCP...

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

I don't work for Comcast...


Help us to help you!!
- respond to requests for info
- post back if your issue is resolved
- mark appropriate posts as solutions


Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 48
7,004 Views

ComcastTuska -  I currently have a /128 delegation. 

Can I get something realistic? a /60 or /64?

 

Portland, Oregon IPv4 addr currently 24.20.195.155 

Posted by
Authorized Vendor

Message 7 of 48
7,000 Views

Sure you need to setup your DHCP client to recieve a Prefix Deligation..  What is your router?

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 8 of 48
6,995 Views

Buffalo N600 with OpenWRT installed.

(and WOW that was fast ...)

Posted by
Authorized Vendor

Message 9 of 48
6,984 Views

I am not sure about OpenWRT if it has DHCPv6 support.  You need to request a PD, and if you want a /60 make sure the IA_PD has /60 in it to request a /60 or you will get a /64..

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 10 of 48
6,979 Views

Thank you, I'll dig through.

There is IPv6 support. At least with the verion on my device.

 

And to make sure I'm understanding - /60 is available. It is the client's responsiblity to make the prefix delegation request. 

 

Update:  Everything is sorted out now.  Thanks for the help.

Posted by
Contributor

Message 11 of 48
6,946 Views

I'll chime in here. OpenWRT does have DHCPv6 support with prefix hinting available. It is not working in the current "Atttitude Adjustment" release though. You will need to upgrade to a snapshot development release "Barrier Breaker". I've been running OpenWRT Barrier Breaker on a few differerent routers for about 6 months now without any problems and with /60 prefix delegation from Comcast working just fine.

Posted by
Authorized Vendor

Message 12 of 48
6,940 Views

MichaelRpdx wrote:

And to make sure I'm understanding - /60 is available. It is the client's responsiblity to make the prefix delegation request. 



Yes the client needs to make the request..

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
Posted by
Contributor

Message 13 of 48
6,932 Views

Here's an example snipped from a working OpenWRT Barrier Breaker router /etc/config/network file:

----------------------------

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '172.20.5.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option ip6hint '0'
        list ip6class 'wan6'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'
        option reqprefix '60'
        option reqaddress 'force'

 

config interface 'guest'
        option _orig_ifname 'wlan0-1'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '10.62.16.1'
        option netmask '255.255.255.0'
        option type 'bridge'
        option ip6assign '64'
        option ip6hint '1'
        list ip6class 'wan6'
----------------------------

 

Notice the reqprefix 60 on the wan6 interface and the ip6assign 64 on the lan and guest interfaces and the ip6hint of 0 on the lan and ip6hint of 1 on the guest (which assign subnet 0 and subnet 1 of the /60 to the two /64 networks).

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 14 of 48
6,829 Views

I've got an Asus RT-N16 running OpenWrt Barrier Breaker with essentially the same /etc/config/network file as BFranske but I can't get a /60 delegation.

 

Here is my /etc/config/network:

--------------------------------

config switch 'eth0'

option name 'switch0'

option reset '1'

option enable_vlan '1'

 

config switch_vlan 'eth0_1'

option device 'switch0'

option vlan '1'

option ports '1 2 3 4 8t'

 

config switch_vlan 'eth0_2'

option device 'switch0'

option vlan '2'

option ports '0 8t'

 

config interface 'loopback'

option ifname 'lo'

option proto 'static'

option ipaddr '127.0.0.1'

option netmask '255.0.0.0'

 

config interface 'lan'

option ifname 'eth0.1'

option type 'bridge'

option proto 'static'

option ipaddr '192.168.1.1'

option netmask '255.255.255.0'

option ip6assign '64'

option ip6hint '0'

list ip6class 'wan6'

 

config interface 'wan'

option ifname 'eth0.2'

option proto 'dhcp'

 

config interface 'wan6'

option ifname '@wan'

option proto 'dhcpv6'

option reqprefix '60'

option reqaddress 'force'

--------------------------------

 

I've not yet setup my guest wireless network or anything other than the 'lan' to use other subnets, but other than that it is the same.

 

but when I get ifconfig I only have 2 Scope:Global inet6 addresses:

 

inet6 addr: 2601:1:xxxx:xxxx::1/64 Scope:Global

inet6 addr: 2001:558:xxxx:xxxx:xxxx:xxxx:xxxx:e203/128 Scope:Global

 

what could be wrong?

 

 

Posted by
Contributor

Message 15 of 48
6,822 Views

What interfaces are your IPv6 addresses assigned to? I'm guessing one is on the WAN (the /128) and one on the LAN (the /64) which would be exactly what I would expect. Your router is getting a /60 and assigning the first /64 inside of it to your LAN interface. In order to see the other addresses you will need to create more interfaces and use the ipv6assign and ipv6hint options to give them addresses out of your /60.

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 16 of 48
6,815 Views

you are exactly right.  the /128 is on the wan interface and the /64 is on the lan interface.

 

based on your suggestion, I created a DMZ out of 2 of the switch ports using another vlan and assigned it an ipv4 address and told it to get an ipv6 using ip6hint.  

 

here is my new /etc/config/network:

 

config switch 'eth0'
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan 'eth0_1'
	option device 'switch0'
	option vlan '1'
	option ports '1 2 8t'

config switch_vlan 'eth0_2'
	option device 'switch0'
	option vlan '2'
	option ports '0 8t'

config switch_vlan 'eth0_3'
	option device 'switch0'
	option vlan '3'
	option ports '3 4 8t'
                        
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'eth0.1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ip6hint '0'
	list ip6class 'wan6'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'
	option reqprefix '60'
	option reqaddress 'force'

config interface 'DMZ'
	option proto 'static'
	option ifname 'eth0.3'
	option ipaddr '10.0.0.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ip6hint '1'
	list ip6class 'wan6'

but when I /etc/init.d/network reload, I get this in my log:

 

Mon Mar 17 17:17:10 2014 daemon.warn netifd: Failed to assign requested subprefix of size 64 for DMZ, trying other
Mon Mar 17 17:17:10 2014 daemon.warn netifd: Failed to assign subprefix of size 65 for DMZ

that would suggest I'm not getting a /60 from comcast, only a /64...

 

Posted by
Contributor

Message 17 of 48
6,810 Views

It's possible, but I'd say it's more likely that something is broken on the OpenWRT side, we are talking about running trunk software here... One other possibility is that you ARE still being assinged a /64 because your router never released the /64 it was assigned (and it hasn't expired yet). You will not be able to get a /60 until your /64 is returned to the pool.

 

Unfortunately the tools in OpenWRT for troubleshooting WAN IPv6 DHCP issues are, errr, lacking. Try running an 'ifstatus wan6' command on your router. You should get something that includes sections like:

 

        "ipv6-address": [
                {
                        "address": "2001:558:6014:a:6598:8e1b:16ca:b528",
                        "mask": 128,
                        "preferred": 272549,
                        "valid": 272549
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2601:2:4500:ca0::",
                        "mask": 60,
                        "preferred": 272549,
                        "valid": 272549,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "2601:2:4500:ca0::",
                                        "mask": 64
                                },
                                "guest": {
                                        "address": "2601:2:4500:ca1::",
                                        "mask": 64
                                }
                        }
                }

 

Check to see if you have a ipv6-prefix section and what the mask is. Otherwise you'll likely need to sniff the traffic on the WAN interface to figure out what's going on.

Posted by
Authorized Vendor

Message 18 of 48
6,802 Views

charlie001 wrote:

 

Mon Mar 17 17:17:10 2014 daemon.warn netifd: Failed to assign requested subprefix of size 64 for DMZ, trying other
Mon Mar 17 17:17:10 2014 daemon.warn netifd: Failed to assign subprefix of size 65 for DMZ

that would suggest I'm not getting a /60 from comcast, only a /64...

 


Send me your CM-MAC and I can see if we have assigned a /64 and if we did I can have it dsiabled for you so you do receive a /60

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 19 of 48
6,790 Views

doing 'ifstatus wan6' outputs:

 

"ipv6-address": [
		{
			"address": "2001:558:6040:b:ac9b:d6ea:f41:e203",
			"mask": 128,
			"preferred": 340304,
			"valid": 340304
		}
	],
	"ipv6-prefix": [
		{
			"address": "2601:1:a640:38::",
			"mask": 64,
			"preferred": 340304,
			"valid": 340304,
			"class": "wan6",
			"assigned": {
				"lan": {
					"address": "2601:1:a640:38::",
					"mask": 64
				}
			}
		}
	],

 so right now my router is just getting a /64.  I just sent a message to ComcastTuska so he can check my cable modem for me.  Hopefully it'll be good news!

Posted by
Contributor

Message 20 of 48
6,779 Views

Yep, my guess is that your router didn't release the /64 before requesting the /60. It's a reasonably common problem.

Posted by
Authorized Vendor

Message 21 of 48
6,799 Views

BFranske wrote:

Yep, my guess is that your router didn't release the /64 before requesting the /60. It's a reasonably common problem.


Yep, right now feel free to send me your CM-MAC, DUID, Prefix assigned..  I will ask for that prefix to be taken care of.

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 22 of 48
6,739 Views

I just checked my router this morning and running 'ifstatus wan6' gives this output:

 

{
	"up": true,
	"pending": false,
	"available": true,
	"autostart": true,
	"uptime": 39867,
	"l3_device": "eth0.2",
	"proto": "dhcpv6",
	"device": "eth0.2",
	"metric": 0,
	"delegation": true,
	"ipv4-address": [
		
	],
	"ipv6-address": [
		{
			"address": "2001:558:6040:b:2849:2aac:10b9:xxxx",
			"mask": 128,
			"preferred": 305733,
			"valid": 305733
		}
	],
	"ipv6-prefix": [
		{
			"address": "2601:1:xxxx:960::",
			"mask": 60,
			"preferred": 305733,
			"valid": 305733,
			"class": "wan6",
			"assigned": {
				"lan": {
					"address": "2601:1:xxxx:960::",
					"mask": 64
				},
				"DMZ": {
					"address": "2601:1:xxxx:961::",
					"mask": 64
				}
			}
		}
	],
	"ipv6-prefix-assignment": [
		
	],
	"route": [
		{
			"target": "::",
			"mask": 0,
			"nexthop": "fe80::201:5cff:fe63:c646",
			"metric": 1024,
			"valid": 1798,
			"source": "2601:1:xxxx:960::\/60"
		},
		{
			"target": "::",
			"mask": 0,
			"nexthop": "fe80::201:5cff:fe63:c646",
			"metric": 1024,
			"valid": 1798,
			"source": "::\/128"
		},
		{
			"target": "::",
			"mask": 0,
			"nexthop": "fe80::201:5cff:fe63:c646",
			"metric": 1024,
			"valid": 1798,
			"source": "2001:558:6040:b:2849:2aac:10b9:xxxx\/128"
		}
	],
	"dns-server": [
		"2001:558:feed::2",
		"2001:558:feed::1"
	],
	"dns-search": [
		
	],
	"inactive": {
		"ipv4-address": [
			
		],
		"ipv6-address": [
			
		],
		"route": [
			
		],
		"dns-server": [
			
		],
		"dns-search": [
			
		]
	},
	"data": {
		
	}
}

 So looks like everything is sorted and I've got the /60.  I didn't have to release the /64 or do anything proactively.  Thanks ComcastTuska!

Posted by
Authorized Vendor

Message 23 of 48
6,731 Views

charlie001 wrote:

 So looks like everything is sorted and I've got the /60.  I didn't have to release the /64 or do anything proactively.  Thanks ComcastTuska!


Glad to hear it, I was just getting ready to ping that team and see if they took care of it..

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 24 of 48
6,707 Views
Same problem wihy sbg6580 I sent a pm. Hope to get resolved soon the kids home school and art internet access dependent. I'm sure they would love no school but I can't have that lol. Feel free to Call any time.
Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 25 of 48
6,107 Views

I'm seeing the same problem, but no amount of router and cable modem restarts will get me a /60.

Posted by
Authorized Vendor

Message 26 of 48
6,093 Views

zedinosaur wrote:

I'm seeing the same problem, but no amount of router and cable modem restarts will get me a /60.


Are you recieving a /64?  If you are you will keep recieving that /64, you will need to send me that /64 and I will have that lease de-activated so that you will recieve a /60..

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 27 of 48
6,076 Views

Yes I'm getting a /64. I'm getting **REMOVED** as my prefix. 

 

I appreciate your help. Is there a more official/automatic way of making this happen for the next person? 

Posted by
Authorized Vendor

Message 28 of 48
6,067 Views

I should have said to PM it..  you shouldnt put private info on a public forum..

 

This has been submitted to be disabled, make sure your /60 hint is in place..

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 29 of 48
6,020 Views

Thank you! How long should I expect it to take? I just tried restarting my modem and router and I'm still just getting a /64. I basically have the same configuration as charlie001 above.

Posted by
Authorized Vendor

Message 30 of 48
6,004 Views

zedinosaur wrote:

Thank you! How long should I expect it to take? I just tried restarting my modem and router and I'm still just getting a /64. I basically have the same configuration as charlie001 above.


I would say it will get taken care of on Monday when the team comes in the office..

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 31 of 48
5,963 Views

Hello again. I'm still just receiving a /64. Anything else I should be doing differently?

Posted by
Official Employee

Message 32 of 48
5,614 Views

Are you still having issues with the size of your delegated prefix?




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 33 of 48
5,510 Views

I followed the directions in the this thread but can only get a 64 bit prefix. Please help. Thanks.

 

update1:

 

Strange could not get a /60 when the router boots up, using openwrt. However, after the router boots

and typing the following commands everything works great and got a /60 prefix.

 

ifdown wan6

ifup wan6

 

update2:

 

Now rebooting gives me a /60 prefix.

 

I guess I needed a new lease.

 

Thanks for this thread.

Posted by
Official Employee

Message 34 of 48
5,492 Views

From your message you seem to be getting a /60 now, yes?


okrahere wrote:

I followed the directions in the this thread but can only get a 64 bit prefix. Please help. Thanks.

 

update1:

 

Strange could not get a /60 when the router boots up, using openwrt. However, after the router boots

and typing the following commands everything works great and got a /60 prefix.

 

ifdown wan6

ifup wan6

 

update2:

 

Now rebooting gives me a /60 prefix.

 

I guess I needed a new lease.

 

Thanks for this thread.


 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 35 of 48
5,445 Views

ifstatus wan6 give the following for ipv6-prefix. I assume this mask 60 means that I am getting /60. Anyway both subnets are working well.

 

    "ipv6-prefix": [
        {
            "address": "2601:5:1fc1:10::",
            "mask": 60,
            "preferred": 217505,
            "valid": 217505,
            "class": "wan6",
            "assigned": {
                "dmz": {
                    "address": "2601:5:1fc1:10::",
                    "mask": 64
                },
                "lan": {
                    "address": "2601:5:1fc1:11::",
                    "mask": 64
                }
            }
        }
    ],

 

Interesting that the IP address for this website is IP Address (IPv6) 2620:6a:8000:4::11 so ipv6 is working great here on both subnets.

 

Thanks for this thread.

Posted by
Authorized Vendor

Message 36 of 48
5,428 Views

okrahere wrote:

ifstatus wan6 give the following for ipv6-prefix. I assume this mask 60 means that I am getting /60. Anyway both subnets are working well.


 

Interesting that the IP address for this website is IP Address (IPv6) 2620:6a:8000:4::11 so ipv6 is working great here on both subnets.

 

Thanks for this thread.


Sweet Glad it is working for you..

 

Tuska

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 37 of 48
5,188 Views

Yes I still haven't been able to get a /60 despite several reboot cycles of the modem and router. Is there anything else I should try?

Posted by
Frequent Visitor

Message 38 of 48
5,143 Views

PM sent NetDogTuska.  No one on call in support even knows what I am talking about.  I have switched my router to draw a /60 address but now since /64 is locked to my modem I have no IPv6 addresses available to my devices. 

Posted by
Connection Expert

Message 39 of 48
5,133 Views

FWIW, Chris Tuska is no longer employed by them.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Official Employee

Message 40 of 48
5,100 Views

LanceMoreland wrote:

PM sent NetDogTuska.  No one on call in support even knows what I am talking about.  I have switched my router to draw a /60 address but now since /64 is locked to my modem I have no IPv6 addresses available to my devices. 


LanceMoreland PM me, I will help you out.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Connection Expert

Message 41 of 48
5,100 Views

Should we refer posters with IPv6 issues to you now John ?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Highlighted
Posted by
Official Employee

Message 42 of 48
5,097 Views

Yes direct people to PM me please.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Connection Expert

Message 43 of 48
5,093 Views

Will do. Thanks for replying.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 44 of 48
4,482 Views

Hello ComcastJohn,

 

I too am having a problem getting a /60. All I can get is a /64, even after trying all the things suggested in the various threads in the Home Networking / Router/ And WiFi Gateway Help sub-topic. I sent you a PM two or three days ago with details. I hope you can find the time help me.

 

Thanks very much!

 

 

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 45 of 48
4,313 Views

Hi ComcastJohn,


I'm also still having problems and private messaged you about 2 weeks ago. Would still love to get a /60.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 46 of 48
3,915 Views

ComcastJohn,

 

I am away from home so I haven't had a chance to even try this, but is it possible to get anything larger than a /60?  At my company we are planning to issue managed routers to employees who occasionally work from home, and since we use role-based addressing for ACLs throughout our VPN, having only 16 subnets to work with is going to effectively force us to adopt ULA and either NPT66 or, worse yet, NAT66 - something we'd really like to avoid.

 

We currently have around 70 classifications defined for devices throughout our enterprise, so having only 16 subnets to work with for each residential router is going to create some serious ACL management headaches, as not every home will have the same set of device classes.  I urge Comcast to embrace the abundance that is IPv6 and to avoid making assumptions about customer network architecture, even in the case of residential users.  Why not accomodate typical VPN use cases and allow delegation of /48s, or at the very least, /56s?  (/48 would be preferred, of course, as it would provide enough bits for both easy ACL management and easy L3 routing within the home.)

 

The architecture of typical contemporary LANs is primarily a product of IPv4 address scarcity, rather than engineering best practice, so as we roll out IPv6 it's important that we don't make assumptions about address space allocation that are rooted in current thinking, even for residential customers.

 

Thanks!

- Aaron

 

Ps. Kudos to Comcast for its leadership in IPv6 deployment.

Posted by
Contributor

Message 47 of 48
3,897 Views

Aaron,

I'm going to ask a stupid question... If you're using a VPN couldn't you just assign addresses to the devices out of your corporate IPv6 pool? There's no reason to care what other addresses might be assigned. You're not planning to put all of those residential IPs into your corporate routing tables and point that out your VPN are you? It seems like it would make much more sense to get a block of addresses at the office and then assign them out to devices on the other end of the VPN. Unless I'm missing something I don't see an advantage, and actually lots of disadvantages to trying to use the Comcast provided addresses.

 

-Ben

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 48 of 48
3,870 Views

 

Hi Ben,

 

Thanks for the feedback.  Yours is not a stupid question.  To be honest this project is still in the planning stages, but it basically comes down to the fact that we don't want to unnecessarily route the employee's non-corporate communications through the VPN, for reasons of latency, availability, and throughput.  With this objective in mind, whether we number each site using the Comcast-provided prefix directly, or indirectly, via translation to a corporate prefix, the length of the Comcast prefix remains the limiting factor in our intra-site numbering scheme. (there is obviously no such thing as oversubscription when doing prefix translation)

 

I am, of course, open to any practical ideas people have for workarounds to this constraint, but given: a.) the abundance of address space we have with IPv6; b.) the official recommendations of the IETF/RIRs, and  c.) the corporate numbering schemes recommended by every book that you will be able to find on the subject, it seems that the path that is most elegant and of least resistance would be for all ISPs to simply allocate a full /48 to any customer that requests one.  With roughly 280 trillion possible /48s on the IPv6 Internet, scarcity is not exactly a concern. Thoughts?

 

Thanks,

- Aaron