Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,873,373

members

1,073

online

28,950

topics

Top

Gigabit switch not working

ANSWERED
Highlighted
New Poster

Gigabit switch not working

Got XFINITY service installed yesterday. Have one major issue - network cable runs from the back of Xfinity Router cable modem to basement where I wanted to use Gigabit switch (trendnet 8 ports unmanaged) but am not getting any lights - tried connecting all 8 ports. This very same setup worked with FIOS service. Tried all four ports on cable modem - no lights. 

 

- I am getting connection fine if I plug in network cable directly to a device like printer in the basement (not working if plugged into gigabit switch). This tells me at least that cable is good.

 

- I did a quick test of the switch which seems to work if plugged in close to Xfinity cable modem. Could distance be an issue? It was not with FIOS.

 

Wonder if I need to try to get a different switch or even different Comcast router. As I said, this very same switch worked fine on very same distance with FIOS cable modem.

 

Any advice is greatly appreciated. Thanks.

 

 

 

 

Accepted Solution

Re: Gigabit switch not working

Using different switch worked. Thanks a lot.

View answer in context
Authorized Vendor

Re: Gigabit switch not working

Sounds like one of the ends doesnt support Auto MDI-X, I would try a crossover cable..

-------------------------------------
Network Engineer, IP Engineer, Docsis..; the views expressed on this post are mine and do not necessarily reflect the views of my employer..

Gamer.. Living the dream one catastrophe at a time Smiley Happy ..
New Poster

Re: Gigabit switch not working

If this very same cable worked with FIOS modem, does it mean could be Comact modem issue (or lack of support for Auto MDI-X?).

 

What I find interesting is that I am able to use this switch if I bring it close to the Comcast router (with shorter network cable).

 

I know the cable going to the basement is not damaged as I get connectivity if I plug it straight to any of my devices.

 

Any suggestions?

 

Two routes I can think of:

1. get different switch and try

2. go through hassle and try different cable modem

 

 

Service Expert

Re: Gigabit switch not working


@vw4motion wrote:

If this very same cable worked with FIOS modem, does it mean could be Comact modem issue (or lack of support for Auto MDI-X?).

 

What I find interesting is that I am able to use this switch if I bring it close to the Comcast router (with shorter network cable).

 

I know the cable going to the basement is not damaged as I get connectivity if I plug it straight to any of my devices.

 

Any suggestions?

 

Two routes I can think of:

1. get different switch and try

2. go through hassle and try different cable modem

 

 


You didn't say anything about what the ethernet cable is - cat5, cat6, etc.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

New Poster

Re: Gigabit switch not working

I think cable it CAT6

"Network patch cable 6 4PR-ETL 23AWG TIA/EIA-568B"

Problem Solver

Re: Gigabit switch not working

Pretty much any modern fast ethernet or gigabit switch has auto sensing ports though. I'd try a different switch.

 

I've had one of these for a couple years and it's been fantastic - currently hooked up to my ASUS AC-68P with a 25 ft Cat 6 cable and it's doing great.....plus you can't go wrong for $21: 

 

https://www.amazon.com/NETGEAR-Ethernet-Unmanaged-Internet-Protection/dp/B00KFD0SEA



<<<< "Sometimes the best way to learn something is by doing it wrong and looking at what you did." - Neil Gaiman >>>>
New Poster

Re: Gigabit switch not working

Using different switch worked. Thanks a lot.

Special Events
FIFA World Cup 2018 on Xfinity See More
Discussion stats
  • 6 replies
  • 652 views
  • 0 kudos
  • 4 in conversation