Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,873,957

members

688

online

29,060

topics

Top

Experiencing Poor XB6 WiFi Performance and I Have Some Network Questions

Frequent Visitor

Experiencing Poor XB6 WiFi Performance and I Have Some Network Questions

I posted the following questions on the Xfinity Help and Support forum, but was informed that they belonged here (Home Network forum) THANKS RobertWy! Here are my questions:

 

I recently upgraded my internet service to 400Mbps. This involved setting up one of your
new XB6 Modem/Router and it's WiFi.

I have some questions about managing my network and it's devices using the XFI Admin
functionality (accessed by visiting IP address 10.0.0.1). I have been a Software Evaluation
Engineer for 30+ years so please don't think bad of me for my offer of comments. They are
offered in the spirit of improving your great new XFI/XB6 device.

Questions:
1) Where is the XB6 (Wireless Gateway model CGM4140COM) User Guide? I have not been able to
find any documentation on your web site. It makes it tough to manage the Modem/Router without
documentation. There are links for 'Wireless Gateway 1', 'Wireless Gateway 2' and 'Wireless
Gateway 3' but none of them provide information on the XB6.

2) Why can't Host Names be edited for my connected devices? When I click the 'EDIT' button all
I can do is enter or edit a comment. This functionality is a bit helpful, but even after you add
a device descriptive comment, you still have click the device's link in the 'Connected Devices'
list to see it.

3) The only way I see to edit Host Names is to add or replace Devices using the 'Add device
with Reserved IP' button but there is no associated documentation or guidelines. I have noticed
that when I send my devices page to the printer the device links are all expanded. THANK YOU
THIS REALLY HELPS!!!

4) Another Host Name issue is that their enumerations can change on their own. Why do they
change? For example, I have a TP-LINK RS200 WiFi Range Extender. It's Host Name is listed as
'RS200'. If I remove the device from the network and then add it back, it's Host Name is now
'RS200-3'. Plus, I actually have two TP-LINK RS200 WiFi Range Extenders in use which makes
things even more chaotic.

5) Some devices have a Host Name that match the device's MAC Address. Why don't these devices
have Host Names? Why can't I assign them host names? I have several devices that use this
naming convention and it makes it difficult to manage all my devices because MAC addresses
are not very descriptive.

6) Another Host Name issue is that there are several devices on my network that are named
'amazon-<MAC Address>-<enumeration>' which correlate to several Amazon Echo and Echo Dot devices
in my home. The enumeration is included in some Host Names but not all Host Names. Plus, given
the use of MAC addresses here, which seem to be unique across all of my devices, the
enumeration seems a bit redundant (at least to this XFI Rookie).

7) Device IP Addresses; The only way I can assign a device a host name that makes sense to me is
to add a device using an assigned IP address. I have done some experiments here, but if I add a
device that uses an IP address that is in use, the new device get transported to the 'Offline
Devices' list instead of the 'Connected Devices' list. No mention of the IP address issue at all.

8) There is a 'Connected Devices' list along with an 'Offline Devices' list. There isn't any way
to 'Edit' any of the devices that are offline. Plus, they only have a deletion button and when
you click the button, the device doesn't actually get deleted, it just moves to a 'Managed
Devices' list on the 'Parental Control' page. This is really confusing.

9) Wifi; a) I was told by the person who was helping me upgrade to 400Mbps (from 150Mbps) service
that the Wifi speed (which is why I upgraded to the XB6 in the first place) would be faster. It
isn't faster at all. This is a really big deal to me because it makes me feel like I was lied to
or hoodwinked; b) Download Speeds change throughout the day which when slow (sometimes SLOWER than
the current upload speed) makes it painful to try to do work using my Android Phone and/or Tablet;
Download speeds range from around 4Mbps up to maybe 35Mbps which is dosappointing when compared to
the 484Mbps speed I get on my Win10 PC which is directly plugged in to the XB6. This issue is a
killer. I upgraded my service for faster speeds, not the ho-hum speeds I'm seeing.

Highlighted
Service Expert

Re: Experiencing Poor XB6 WiFi Performance and I Have Some Network Questions

There is no user manua yet.  I found this:

 

https://community.shaw.ca/docs/DOC-14080




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Problem Solver

Re: Experiencing Poor XB6 WiFi Performance and I Have Some Network Questions

Comcast is encouraging users of its Wireless Gateways XB3 and XB6 to use Xfinity xFi. Most of your concerns can be addressed there, and it's a lot easier to manage your network using xFi than through the gateway. 

 

As for the slow wifi speeds, there's a few things you can do -

 

1. Separate the 2.4 GHz band from the 5 GHz band by giving them separate SSID names, and let your faster devices connect to the 5GHz band. Leave the 2.4Ghz to low priority speed devices like printers, lights, and thermostats.

2. Position the XB6 in a more centralized location in your home to allow for better coverage. 

3. You didn't mention what the layout of your home looks like, but you mentioned that you have two wireless extenders in use. Be cautioned that while those may improve overall coverage, they WILL cut down your speeds by half. Normally I'd suggest changing the WPS band from 2.4 GHz to 5GHz to improve speed, but I don't think the XB6 gives you that option.

If you need improved speed, position the extenders on either side of the XB6, as far away from each other as possible. You can also contact Comcast about purchase of their xFI Pods mesh system. Or, you can connect a wireless access point (or a wireless router configured to work like an access point only) to it via one of the ethernet ports and string it to a dead spot location - those will have more powerful antennas generally and may eliminate the need for the extenders. 

 



<<<< "Sometimes the best way to learn something is by doing it wrong and looking at what you did." - Neil Gaiman >>>>
Special Events
FIFA World Cup 2018 on Xfinity See More
Discussion stats
  • 2 replies
  • 154 views
  • 2 kudos
  • 3 in conversation