Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,725,776

members

63

online now

1,887,891

discussions

Back to Top

Electrical Shock when Touching Splitter?

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 5
651 Views
Not sure if this is normal, but while checking the tightness of the connections on my cable splitter, I can distinctly feel current when touching the input connector and one of the outputs at the same time on my two-way splitter (Antronix). It feels like a mild electric shock and seems to be most noticeable on the leg going to the DVR if I'm not mistaken. Is this normal at all? It feels alot like the shock you get when touching the wires inside a telephone NID if anyone has had such an experience. I noticed this when I was checking the tightness of my connections, as over the last few days my Upstream power level seems to have increased from about 46db when the cable and internet was first installed to about 49.2db or slightly above now. Downstream looks fine at about 5db, and SNR looks OK running right at 36db. When checking outside the house at the grounding block, the connector coming from the pole drop has a small amount of braiding showing from underneath the compression fitting. Looks like the tech was about a millimeter shy of completely seating the connector before he crimped, but I'm not sure if it's really an issue? My biggest concern is the current I'm feeling at the inside splitter. Any ideas?
4 REPLIES
Posted by
Connection Expert

Message 2 of 5
645 Views

It's not normal. Sounds like a grounding issue.

 

Unless you know how to do so, I would have a tech come out and check the integrity of the coax ground at the demarc/grounding block outside/on the side your home.

 

[Edit]

 

I see you posted this at BBR as well. You got a good answer there too.

Message Edited by EG on 04-11-2009 10:34 PM



Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 5
638 Views
Yeah, I checked the BBR posting and decided that I better put a meter on some of my wiring tomorrow and check the continuity. On another note, ss far as the bit of exposed braiding on the drop connection, could something like that cause my somewhat high Upstream power levels (@49.2db)? All other levels are close to spot-on with Downstream power level @ 5.2db and SNR @36db.
Posted by
Connection Expert

Message 4 of 5
634 Views

Even if the shield is a bit exposed, as long as it is making good contact with the fitting/connector, it will not be an issue.

 

Of course seeing any part of it exposed does not inspire confidence in its integrity.

 

Unless you know how to re-do the connection, have a tech come out to re-do it.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 5 of 5
625 Views
It's not that I don't know how to re-barrel it, I just don't have the compression crimper and the prices are rediculous for those things considering I'd only use it once. I'll probably just have the tech redo it if they come to check out the grounding issue. I'm still curious as to why the upstream power level went up seemingly overnight from when it was first installed. Don't get me wrong, I'm not losing connection or anything like that, it's just close to borderline of the specs (49db).  Removing the splitter and connecting straight to the modem gets it down to about 46.5db. The drop from the pole to the grounding block is about 80ft, with another 50-60ft of cable before it enters the house and goes into a single two-way splitter. I went behind the tech during the install and noticed that both connections at the grounding block weren't even finger-tight, so I'm wondering about the quality of the connection to the tap at the pole.
Message Edited by CycoSomat1c1972 on 04-12-2009 07:55 AM