Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,706,770

members

31

online now

1,870,598

discussions

Back to Top

Can't get Ubuntu (Linux) to connect to my Xfinity internet service

SOLVED
Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 15
14,566 Views

The harddrive in my laptop which previously ran Vista crashed. So I bought a new hard drive and didn't want to spend 200 dollars for a new operating system. Therefore I went with Ubuntu, which I absolutely love. Now the problem I'm having is that I can't figure out how to connect to the internet. When I replace the hard drive with one that runs Vista I can connect to the internet just fine. However I'm in love with Ubuntu and I want to have my internet service on the Ubuntu OS. I've played around with the networking tools and have tried all sort of things but since I'm relatively new with Linux OS I haven't been able to get anything to work. I've been able to pick up other people's wi-fi signals and get internet just fine. So I've got to imagine that there HAS to be a way to use my Xfinity service on my Ubuntu OS. Any help would be greatly appriciated otherwise I have no choice but to cancel my subscribtion from Comcast and complain for not forewarning there customers that Xfinity is not Linux freindly. 

1 ACCEPTED SOLUTION

Accepted Solutions
Posted by
Networking Expert

Message 9 of 15
15,960 Views
Solution

If the network manager doesn't show eth0, then you likely have a deeper problem than DHCP, likely drivers.  But we'll need to see more specific information:

 

1. Is there a check mark next to Enable Networking when you right click on the network applet in the task bar?

2. Screenshots would be nice, but I see that will be a problem since you have no networking to post them, so just describe them in detail.

3. Describe the Connection Information dialog.

4. Describe all tabs on the Edit Connections dialog, especally the Wired tab.

5. If there are no connections listed in the Wired tab, run the command "sudo ip addr" and post the output.

6. If that command lists network interfaces, find eth0 and note the MAC address (it will look like 6 pairs of hex numbers separated by a colon.  If nothing shows up here, we will have to go in another direction.

7. Add a connection manually by pressing the Add button on the Wired tab. Up should come an editing dialog. 

8. Give the connection a name (whatever you want), and check Connect automatically.

9, On the Wired tab, enter the MAC address you noted above.

10. On the 802.1x Security tab, make sure Use 802.1X security for this connection is NOT checked.

11. On the IPv4 Settings tab, select Automatic (DHCP).

12 Press OK, then Close.

13. Reboot.

 

Are things any better?

 

Most of these instructions you can find on various sites on the Web. Here is a link to the Ubuntu documentation page on Network Manager. It has pictures if hte above is hard to understand.

 

 




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

14 REPLIES
Posted by
Contributor

Message 2 of 15
14,562 Views

Are you trying to connect wirelessly, or is your laptop connected directly via an ethernet cable?

Posted by
Networking Expert

Message 3 of 15
14,550 Views

Exact laptop model?  If using wireless, what router and what adapter in the laptop?  What version of Ubuntu? 

 

Wireless setup in Linux systems is notoriously difficult due to lack of decent drivers.  Depending on the adapter in question, this can be simple or near impossible.  It's all about the details here.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 4 of 15
14,545 Views

I have a HP pavilion dv6700 connected directly to my modem. I believe it's ubuntu 10.10. I'm not that familiar with it. But I feel like I might have to somehow manually set up a "wired connection" or a "VPN". 

Posted by
Contributor

Message 5 of 15
14,533 Views

I have a laptop with a Ubuntu derivative on it so the steps should be similar... what I have found seems to be that the Ubuntu Network Manager will overwrite any manual edits made to the config files... so you will need to use the Network Manager to setup a connection with eth0 (that is typically the name of the first wired network-card -- wireless is usually wlan0).

 

The Ubuntu network manager can be found using the menu System -> Preferences -> Network Connections.

If you're still having trouble, let me know.

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 6 of 15
14,528 Views

That's the problem I'm having.. I'm surfing right now using my other hard drive that has vista. And if i switch it out for the one that has Ubuntu and open the network manager it won't show "eth0" or anything for that matter in the wired network tab. All the other tabs have nothing to choose from either. However if I keep my wi-fi switch off and click on the network icon on my desktop I'm only allowed one option - "Auto-Ethernet". Everytime I try to connect, it fails. The guy from comcast seemed to think it's because they don't support linux systems. Now I'm not very tech savy myself, but I find it hard to believe that comcast would purposely make sure that Linux OS's were unable to use their services. So I got to believe there's a way to do so. Which is why I'm stumped with this one.

Posted by
Email Expert

Message 7 of 15
14,522 Views

Did you solve your problem? You marked Baric's question above as the solution. If it's not, click on Options next to that post and select "Not the solution".

 

My guess is that you don't have Ubuntu configured to get its IP address automatically via DHCP. Instructions on how to do this are here.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Contributor

Message 8 of 15
14,501 Views

@shorty3300

Can you please post the contents of your /etc/network/interfaces

 

You should have two lines that look like the following:

 

auto eth0
iface eth0 inet dhcp

 

if you do, and it's still not working post the results of:

 

ls /etc/NetworkManager/system-connections

 

 

Posted by
Networking Expert

Message 9 of 15
15,961 Views
Solution

If the network manager doesn't show eth0, then you likely have a deeper problem than DHCP, likely drivers.  But we'll need to see more specific information:

 

1. Is there a check mark next to Enable Networking when you right click on the network applet in the task bar?

2. Screenshots would be nice, but I see that will be a problem since you have no networking to post them, so just describe them in detail.

3. Describe the Connection Information dialog.

4. Describe all tabs on the Edit Connections dialog, especally the Wired tab.

5. If there are no connections listed in the Wired tab, run the command "sudo ip addr" and post the output.

6. If that command lists network interfaces, find eth0 and note the MAC address (it will look like 6 pairs of hex numbers separated by a colon.  If nothing shows up here, we will have to go in another direction.

7. Add a connection manually by pressing the Add button on the Wired tab. Up should come an editing dialog. 

8. Give the connection a name (whatever you want), and check Connect automatically.

9, On the Wired tab, enter the MAC address you noted above.

10. On the 802.1x Security tab, make sure Use 802.1X security for this connection is NOT checked.

11. On the IPv4 Settings tab, select Automatic (DHCP).

12 Press OK, then Close.

13. Reboot.

 

Are things any better?

 

Most of these instructions you can find on various sites on the Web. Here is a link to the Ubuntu documentation page on Network Manager. It has pictures if hte above is hard to understand.

 

 




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 10 of 15
14,484 Views

Thanks for all your help guys. I greatly appriciate it. I haven't solved the problem yet because I'm at work. And I only have one laptop at home so I have to switch out my hard drive to try follow your instructions the best I can and then once I have switched my hard drives back to get internet agian I will post the results later tonight. Thanks again!

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 11 of 15
14,471 Views

YES!! it works! I'm using Ubuntu to write this post. All I had to do was add a new wired connection and type in the MAC address and it worked just fine! Thanks for all your help guys!\

 

Posted by
Contributor

Message 12 of 15
14,466 Views

shorty3300 wrote:

YES!! it works! I'm using Ubuntu to write this post. All I had to do was add a new wired connection and type in the MAC address and it worked just fine! Thanks for all your help guys!\

 


Glad you have it working. I know how good it feels after a victory against the configuration beast. Smiley Happy

Posted by
Networking Expert

Message 13 of 15
14,458 Views

Glad you got it working.  I'm kind of curious how the normal default entires were missing.  During installation, the proper entries for your system are created.  Since the connection works, I would have expected the scan to find the adapters and add the appropriate entries.  I don't know much about the Ubuntu install, so I really have no insight into why it didn't work properly in this instance.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 14 of 15
14,454 Views

Well I something must have been wrong with the install. I got it off a cd a freind gave me. When i tried the first suggestion whiched called for me to manipulate the file /etc/sysconfig/network/ I didn't even have that file.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 15 of 15
13,539 Views

I suspect your real problem was nothing to do with Linux:

 

The XFinity cable modem binds to just one Mac address at a time.  If your Vista instance gets a DHCP lease, then you switch to Linux, you'll get nothing.  Same thing in reverse.

 

So power cycle that stupid modem before switching operating systems.

 

My system: Ubuntu 11.04, Comcast Xfinity Internet, Motorola Sufboard SB5101