Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,727,513

members

41

online now

1,889,405

discussions

Back to Top

Can't connect vizio tv to wireless network

SOLVED
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 1 of 13
264,622 Views

Have a new Comcast cable connection with modem Arris TG862G/CT. Have connected multiple laptops in the house over wi-fi network after providing Network name (SSID) and Network Key (both provided on the bottom of modem Arris TG862G/CT).

 

However, am unable to connect a Vizio TV (model M420KD) to this new wi-fi network. After selecting the network  and providing WPA passphrase (same as Network key?), it displays the message "Unable to connect.  (Note: TV was earlier on the wi-fi network for a DSL connection from verizon.) 

 

Thanks for any help in solving this issue.

1 ACCEPTED SOLUTION

Accepted Solutions
Posted by
Networking Expert

Message 2 of 13
291,886 Views
Solution

I would try several things:

 

1. Reset the TV's nework setting completely to remove any settings from the previous wireless connection that may cause trouble.  That means proxy settings, wireless settings, TCP/IP settings, etc.  Everything.

2. Log into the gateway and change the wireless security settings to WPA2PSK with AES, DO NOT USE the combo WPA/WPA2 setting, many devices get confused and won't work properly.

3. Try connecting the TV again.  If the automatic scan and connect doesn't work or it doesn't ask for WPA2 passphrase (if it asks for WPA, something is wrong), try a manual configuration where your explicitly enter the SSID and WPA2 passphrase.

4. Try changing the wireless channel on the gateway, your TV many have trouble with the current selected channel.

5.  If that fails, try connecting with an ethernet cable.  

 

 




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

12 REPLIES
Posted by
Networking Expert

Message 2 of 13
291,887 Views
Solution

I would try several things:

 

1. Reset the TV's nework setting completely to remove any settings from the previous wireless connection that may cause trouble.  That means proxy settings, wireless settings, TCP/IP settings, etc.  Everything.

2. Log into the gateway and change the wireless security settings to WPA2PSK with AES, DO NOT USE the combo WPA/WPA2 setting, many devices get confused and won't work properly.

3. Try connecting the TV again.  If the automatic scan and connect doesn't work or it doesn't ask for WPA2 passphrase (if it asks for WPA, something is wrong), try a manual configuration where your explicitly enter the SSID and WPA2 passphrase.

4. Try changing the wireless channel on the gateway, your TV many have trouble with the current selected channel.

5.  If that fails, try connecting with an ethernet cable.  

 

 




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Networking Expert

Message 3 of 13
264,590 Views

Oh, and add the TV's IP address if it gets one as a trusted IP.  Make sure the gateway's firewall is MEDIIUM or LOW and no parental/access controls are in place.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 4 of 13
264,586 Views

Baric,

 

As suggested, I changed wireless security settings to WPA2PSK with AES,  and tv is now on wi-fi network. Thank you so much.

 

Parsha

Posted by
Networking Expert

Message 5 of 13
264,579 Views

You're very welcome, glad it helped.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon

Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 13
261,913 Views

Baric,

 

I have the exact same modem (Arris TG862G/CT) and am trying to get a wireless connection to a Vizio TV (M3D460SR). I walked through the steps you outlined and was able to get the TV to show a connection, however, when I run a wireless test on the TV I show excellent signal strength but zero data coming into the TV and no internet apps work. 

 

Any Ideas?

 

 

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 7 of 13
261,596 Views

I'm having the same exact problem, just started this week. Wonder what's going on??

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 8 of 13
256,385 Views

what do i need and how do i connect vizio 60" to xfinitly wirless router

 

Posted by
Connection Expert

Message 9 of 13
256,351 Views

Do you know how to work the Vizio TV Controls?

If so, can you see the Wireless Router SSID or name?

Do you know the Wirelesss Router SSID and wireless password?

Is the Vizio close enough to the Router to see the signal?

 




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 10 of 13
253,000 Views
I was also experiencing the exact same issue connecting my new Vizio TV to my wireless network. I was using WPA/WPA2.
I changed my wireless network configuration to use WPA2 Personal (AirPort Extreme only uses AES) and that did the trick. I'm now connected using wifi and currently watching a movie using the amazon app.
Thanks for posting the resolution!
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 11 of 13
252,518 Views

i've restored the settings, checked my gateway and it's been at wspa2-psk AES the entire time and though it picks up the network name, the password that's worked for all my other devices, isn't connecting to the tv. what else do i do?

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 12 of 13
250,410 Views

I am also having trouble with Comcast internet connecting to Vizio TV.  It shows "connected" although data is not transferring. 

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 13 of 13
248,769 Views

I just figured out that the Vizo is case sensitive so make sure the case on the router matches what you are typing into the TV