Xfinity plant
Xfinity globe
Community Forum

Bridged Router to GB Ethernet Switch, Switch Only Powers 1 Connection

New Poster

Bridged Router to GB Ethernet Switch, Switch Only Powers 1 Connection

Hello All,

 

Our modem for phone and data is a Cisco DPC3941T. The router functionality is not powerful enough to cover our whole house so we are attempting to use our own router. In an attempt to avoid colliding wifi networks, our Cisco box is in bridge mode.

 

Our home is wired for ethernet. It has a central console where our modem is connected-that's where the ethernet input ports are located. Normally we'd run ethernet cables from the Cisco box to those ethernet input ports and all the gadgets connected to the ethernet output ports in their respective rooms would come online-that's what the technician did before he left. But, as the box is in bridge mode, this is obviously not the solution. Bridge mode makes it so only Port 1 is live so the only ethernet port that comes online is the one connected to Port 1.

 

I tried to solve this problem using 2 different ethernet switches, plugging the ethernet cable from Port 1 on the Cisco box to the switch and then running cables from the rest of the ports on the switch to the ethernet input ports on the central console. With both switches, the result was the same: Everything lights up green but only one ethernet connection actually ever works at a time.

 

I've done countless resets, tested over a dozen different cables, and spent time on the phone with Comcast and I can't figure this out. It's looking like they're going to need to send a technician out but I thought I'd see if anyone here had any advice.

 

For now, I've connected Port 1 on our Cisco box to the ethernet input that connects to the WAN port on my router in another room. The WiFi network works as it should. It is also worth noting that the ethernet ports on the back of my router DO work in this setup but it isn't located near my control console so I can't use them to connect to the ethernet inputs that would bring the rest of the ports in my house to life.

 

One theory I've been kicking around to explain why my router's ethernet switch functionality would work but an actual ethernet switch would not is that the router has a dedicated WAN port for data input, but the switches both just had 5 uniform ports. But, from what I'm reading that shouldn't matter.

 

What do I need to do to get Port 1 to properly power my ethernet switch?

 

Thank you!

 

Expert

Re: Bridged Router to GB Ethernet Switch, Switch Only Powers 1 Connection

You can't hang an ethernet switch off of a straight cable modem or a bridged gateway device as only 1 IP address is issued.

Problem Solver

Re: Bridged Router to GB Ethernet Switch, Switch Only Powers 1 Connection

The problem you have is that for all the devices to work, they need to be properly assigned an IP address either manually, or by using a DHCP server - which your Cisco gateway should be doing if it wasn't in Bridge Mode. As it stands, as you have it in Bridge Mode, your personal router or some other device should take over that function. (Which was the case when your router was connected to the bridged gateway directly via the router's WAN port).

 

The easiest solution I can think of would be to restore the Cisco gateway to Router mode (i.e. disable Bridge Mode) , and configure your personal wireless router to act as a Wireless Access Point only (no routing functions). That way, your Cisco can directly connect to the main console (which I assume is an ethernet hub or switch) and take over the routing and the DHCP functions for all of your devices, but your personal router can still work to extend your wireless coverage. Otherwise, you'd have to run a separate ethernet cable to connect the WAN port of your router to the gateway, or manually configure each and every device on your network for network access...which you do *not* want to do. 

 

You can have both the Cisco gateway and your personal router work as wireless access points, in fact, that would improve wireless coverage in your home. Or if you wish, you can turn off the wireless function in the Cisco gateway, and let your personal router work as a standalone wireless access point. 

 


"Sometimes the best way to learn something is by doing it wrong and looking at what you did." - Neil Gaiman