Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,651,185

members

38

online now

1,826,561

discussions

Back to Top

AGAIN: Paying for Internet Performance pro but getting Internet Performance speed with TEC tc8305c.

Posted by
Visitor
  • Congrats on Posting your first topic!

Message 1 of 2
189 Views

Long story short, I noticed some buffering issues when streaming netflix, I went and looked at my account page and saw that my modem is configured for Internet Performance instead of Internet Performance Pro

 

I have contacted both online support AND phone support, BOTH did the restart of the modem, check health, etc... Both said the modem has the correct bootfile, etc..


After all those attempts to reset my modem, I ran a speed test for them

35 MB Down, 5 MB up

same SPEEDS. Nothing changes, this is DIRECTLY connected to the modem and a cat 6 cable ( doesn't matter ). I ASKED them to re-roll the provision for the modem and got stupid responses like "It already has the correct bootfile", yadda yadda.  

 

Anyone ever get soemthing like this resolved?

 

 

 

1 REPLY
Posted by
Valued Contributor

Message 2 of 2
161 Views
On your bill does it actually say Performance or Performance Pro? If it says Performance you will need to pay for an upgrade to Performance Pro. Also I would call Comcast again to just ask them what your internet package is named mainly and/or what it includes.