Xfinity plant
Xfinity globe
Community Forum

175mbps- Xfinity Speed Test But 35 to 55mpbs from Other Test Sites.

Frequent Visitor

175mbps- Xfinity Speed Test But 35 to 55mpbs from Other Test Sites.

In brief speeds down and up are as provisioned from the comcast test site, but sites outside comcast, even going back to a comcast server are generally less than half the advertised down speed

Equipment: SB6183, Netgear R7000. 

After the increase to 150mpbs I was clocking 40 to 55mpbs at DSLReports and the xfininity speed test. The comcast tech added my old Surfboard modem back so I could compare results agains the current SB6183. There was not much difference. After a very unsatisfactory chat with a  second line tech (your modem we can't do anything) although in fact he did something (reload the firmware?), Xfinity speed jumped to >150mpbs and DSLReports speed increased. The next day both were at >150mbps.

 

Yesterday and again this morning it was back to xfinity site >150mbps but all others <60mbps. 

xfinityspeed.jpg

 

 

speedtestnet.jpg

ookla.jpg

 

I ran tests using the current versions of Edge and Firefox (57) running on updated win 10 home using a wired gigabit ethernet connection. Results were similar on two other PCs, one wired, the other on on a wireless ac connection with ~800mbps bandwidth.  

 

 

 

speedtestnet.jpg
Expert

Re: 175mbps- Xfinity Speed Test But 35 to 55mpbs from Other Test Sites.

Do the Xfinity speed test again. Let it run through. When it completes, look in the upper right-hand corner for "Advanced Settings". Click on it and manually choose the IPv4 test. Run it and see what download speed you get.

Frequent Visitor

Re: 175mbps- Xfinity Speed Test But 35 to 55mpbs from Other Test Sites.

 

IPV4 result this morning is just below. I sometimes see a difference between 4 and 6 just as I sometimes see a difference between tests with Edge and Firefox, but in the long run the differences appear random.  This morning speed is is up from several test sites. The last image is the recent test histroy from DSLReports showing the variation from day to day and actually hour to hour.

 

Yesterday I had another chat with Comcast, but that seems to be a dead end. The CSR does what she does and says everything looks good. I do the usual for her and test results remain variable. The answer remains the same-not Xfinity hardware, ask the manufacturer. I am having difficulty understanding how this could be a local hardware problem, that is what could cause two different modems, router in/router out/ gigabit switch in/out, gigabit wired/ wireless ac and three PCs (2 with Norton, 1 with Defender) to have the same erratic download speeds-generally but not always good from speedtest.xfinity and very erratic from outside the comcast network. Does this not suggest a problem upstream of my house - at the comcast border?

 

xfinipv4.png

 

28441532

 

xDSLRptSum.png

Expert

Re: 175mbps- Xfinity Speed Test But 35 to 55mpbs from Other Test Sites.

Just as an FYI. One reason that their *in house* speed tests may show faster speeds than other third party testing sites is because their speed testing servers lie on *their* network's edge, therefore they are not subject to any third party's potential backbone deficiencies / routing deficiencies / distance related latency issues etc;


Frequent Visitor

Re: 175mbps- Xfinity Speed Test But 35 to 55mpbs from Other Test Sites.

Yeah got that, but what's going on with low speeds from the xfinity server in San Jose and sometimes higher speeds from the speedtest.net server in San Jose.

A few minutes ago from xfinity 96mpbs down and from speedtest.net 167mbps down. Last night at 12:30 PDT it was about 80 to 90 down from every test site but just to keep me off balance I got ~37mpbs up at the xfinity site, but only about the expected 5 -6 mpbs from other sites.

 

This really does look like an xfinity network problem, but no one seems to be responsible at least from the CSR view. They can only say "no outage".

 

Do I have to buy the 250 plan to get a consistant 125?

Frequent Visitor

Re: 175mbps- Xfinity Speed Test But 35 to 55mpbs from Other Test Sites.

Oh and let me add that the online  Status Center continues to show 

Cable Modem

(red dot) ISSUE DETECTED

 

And of course each time I call there is no solution or explanation for this though I am begining to suspect that the issue is that I'm not renting it from comcast.

Expert
Moved:

Re: 175mbps- Xfinity Speed Test But 35 to 55mpbs from Other Test Sites.