Welcome to Comcast Help & Support Forums
You can contribute an answer or post a question.
Reply
Posted by
Visitor
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
Member Since: ‎02-07-2013
Posts: 3

Xfinity Player and Remote apps not working on iPad1 IOS 5.1.1

The Xfinity Player and Remote apps are not working properly on my iPad1, running IOS 5.1.1. I first loaded the Player app, logged in with my primary Comcast/Xfinity account, and tried to watch several movies. Every movie I selected crashed immediately with the error "Sorry, we've experienced some difficulty playing your video". This happens on every movie, every time.

 

After reading through several forum posts, I decided to install the Remote app, as others stated that that app has the same movie-streaming capability and lineup. After loading that app and logging in with my primary account, I tried to launch several movies, none of which would play. After digging through more forum posts, I came across a post from a user (not a Comcast/Xfinity support person) who stated that, after their multiple discussions with Comcast/Xfinity support, they were able to get movies to play by manually setting their zip code and selecting their provider in the settings (*Note to Comcast/Xfinity - if this is a requirement, it should be part of the initial app setup process, not something you have dig through forum posts to discover). After switching from the auto-generated 'Comcast Recommended Lineup' to my actual zip code/provider, I tried to launch a movie. This time, the movie played...IN SPANISH. Launched another movie. SPANISH. The info menu on ANY movie I play comes up as '(Movie Title) Esp Dub'.

 

I went through all of your general troubleshooting steps, with both apps, in an attempt to resolve the issue. Log out, log back in - same problems on both. Log out, reboot, log back in - same problems on both. Log out, uninstall, reboot, reinstall, log back in, same problems on both. I have scoured the settings menus in both apps and have found nothing to resolve either issue with either app. 

 

I then contacted chat support, who opened a ticket for me. I then got a follow-up voicemail asking me if everything is fixed now. It is not. I have not returned the call as of yet.

 

I have seen recommendations from Comcast/Xfinity support people in the forums to 'try another WiFi connection'. This is not the issue - I have tested the Player app with an Android tablet, on the same WiFi, and it works perfectly. The Android version of the app even gives you the option to view each movie in either English or Spanish, whereas the iPad app does not.

 

I have also tried watching movies on my laptop, using my primary account, which works perfectly.

 

I have seen multiple forum posts about these issues, several that end with a tech saying something to the effect of 'we will look into it and update this thread'. Some have been sitting for months with no update. In the Apple app store, as of right now, the Player app has a rating of 2 stars out of 5, with 135 5-star ratings, and 490 1-star ratings. The Remote app has a rating of 2.5 stars, with 124 5-star ratings and 253 1-star ratings. Many of the negative reviews in the app store are due to the issues I have listed here, as well as others.

 

I, and I'm sure others with the same issues who are looking for answers beyond 'reboot, reinstall, try again, we'll look into it', would appreciate it if someone from support would provide some assistance in this thread, and see it through to resolution.