Xfinity plant
Xfinity globe
Community Forum

xFi Thinks I've not Upgraded, iPhones won't connect

Regular Visitor

xFi Thinks I've not Upgraded, iPhones won't connect

Setting up new ARRIS TG1682G Modem for xfinity xfi. Successfully got internet access via wifi on the Mac. When went to connect iPhones (7's both on iOS 11.2.1) to the wifi, nothing. Neither phone will connect. Even after letting try for minutes upon mintues. Just spins trying to connect to either the 2.4 or 5ghz spectrums. Resetting the modem causes the same issues and won't resolve it. Have reset the network settings on one of the iPhones and still can not connect.

 

When logging into xFi app or online it says need to upgrade to the xfi experience. After logging in, it says "It looks like you've already gone through the upgrade process". Why yes, yes I have. And seems to give limited access on what can be done.

Image-1.jpg
New Poster

Re: xFi Thinks I've not Upgraded, iPhones won't connect

I have the same issue. Hw can this be resolved [comcast?]

Official Employee

Re: xFi Thinks I've not Upgraded, iPhones won't connect

 kehulse, are you still experiencing both of these issues? Connectivity for apple devices as well as trouble accessing xFi. Please let me know and we can look into it. 

Official Employee

Re: xFi Thinks I've not Upgraded, iPhones won't connect

cc3d, can you please confirm if you are still experiencing issues? If so, please provide some details around the specific issues - access to xFi or connectivity. Thanks. 

New Poster

Re: xFi Thinks I've not Upgraded, iPhones won't connect

I'm having the same issue, but on Android!  What was the fix for this?

New Poster

Re: xFi Thinks I've not Upgraded, iPhones won't connect

Same issue here... Whats going on?