Xfinity plant
Xfinity globe
Community Forum

"a new device has connected"

Contributor

Re: "a new device has connected"

That's why I keep my XFINITY hotspot turned off. That's what they told me mine was from but I still haven't heard a feedback after I sent the security department my firewall list
New Poster

Re: "a new device has connected"

This message is to the Comcast employee KenF. Does Comcast have a fix yet? Thx. 

New Poster

Re: "a new device has connected"

Trying to set up my new pods and received incessant notifications that a new device connected to my net work. Freaked out, unplugged all pods and am changing password!
Contributor

Re: "a new device has connected"

As this thread goes back to January and there's still no fix, it's time for me to chime in.  In early May, I started getting one and then two devices showing up as "not connected" on my gateway admin page.  I have an Arris TG1682G with no wifi extender.  I spoke to three different Comcast reps who had no knowledge of this issue and they told me to do the same thing ComcastDaniella suggests -- click "forget device" on xFi.  That does not work in my case.

 

I've blocked the devices on the gateway and have repeatedly clicked "forget device" on xFi.  The same devices always return within 24 hours.  If I reset the gateway to factory defaults, increase the firewall level and even change my password, then the devices return within minutes.  There's no way to get rid of them and since it's always the same two devices, xFi does not notify me because the notification setting is only for "a first time connection".  I literally check the xFi web page (I have no devices to download the app) every day.  I just had xFi forget the devices again, but I know they will return soon.  Be assured, these devices are not mine.

 

Both devices are from the Chinese firm ZTE and only have a MAC address.  My neighbor has five unknown devices showing up on her gateway and another friend has more than a dozen.

 

Are there any updates on this issue?  It really is time for a full resolution. 

Official Employee

Re: "a new device has connected"

Hi @Happygal, sorry to hear you were having such problems with it. We are working with our technical teams to resolve the notices. In some instances "new device connected” notifications are being incorrectly sent before a valid WiFi password is entered for that device to join the network, and these devices may incorrectly appear in the Connected Devices list in xFi temporarily. Be assured that these devices are not connected to your home network, and here is how to confirm it:


     You can verify if an unknown device has connected to your network by checking for an IP address in ‘Device Details’. Fully authenticated devices that have entered a valid WiFi password will have an IP address assigned and displayed; devices that have not entered a valid WiFi password will not have or display an IP address. If an IP address does not appear in the Device Details, then the device is not connected to your home network. You can remove these devices from appearing in your xFi Connected Devices list by selecting the device, then selecting ‘Device Details’ and ‘Forget Device’.

     We apologize for any inconvenience and continue to work with our technical teams to bring this issue to a full resolution. If you would like me to trouble shoot more with you, please send me a Private Message by right-clicking on my name. If you prefer, I can send you a message and look at your account from there. 

Official Employee

Re: "a new device has connected"

Hi @flaboy,

If they only have a MAC address, and no IP in Device Details, then they are not really connected. The notification is incorrectly sent before the wifi password is entered for that device to join the network. 
We are working on it, and I apologize for the hassle this is causing you. 

If you would like me to trouble shoot more with you, please send me a Private Message by right-clicking on my name. If you prefer, I can send you a message and look at your account from there. 

Contributor

Re: "a new device has connected"

Hi @ComcastDaniella:  Many thanks for your response.  As these devices are not connected and I have them blocked, I really don't see a need at this point to trouble shoot my account.  I appreciate Comcast's efforts to find a resolution and I'm hoping when that happens, we'll be able to get rid of these unknown devices for good.  Should the situation change, I'll let you know.  When there is a fix, will it be posted in this thread or will there be some type of special announcement?  Again, many thanks for your efforts.

Official Employee

Re: "a new device has connected"

@flaboy Thank you for your cooperation with me. Once we have a fix in place, we will post to the forums. I can't say if it'll be in the thread or an annoucement, but we will keep you updated. 

Thanks for your kind words, and for using the forum!

If you need anything else, please feel free to start a new thread or call in for support.

Contributor

Re: "a new device has connected"

But they do have IP addresses. 

Contributor

Re: "a new device has connected"

Funny I was told in March you were working on a fix. I bet in August you will post you are working hard on a fix or just post problem solved. 

Regular Contributor

Re: "a new device has connected"

Removing my comment as unhelpful...watching for Comcast updates.

Joe V
(not a Comcast employee, just another paying customer)
Contributor

Re: "a new device has connected"

Hi @fossilsol.  Perhaps my situation is a bit different from yours, but, neither of the two devices showing up as "not connected" on my network have an IP address and they never have had an IP address since this started for me in early May.  Only a MAC address and they remain blocked as well.

Contributor

Re: "a new device has connected"

All the ones i and others have had have ip adresses and can not be blocked since they never connect for more than a few minutes making it hard to catch and block.  

Contributor

Re: "a new device has connected"

@fossilsol -- I understand what you're saying and my best guess is that a couple of different things may be going on with this issue.  What's causing it and why it's different -- I can't explain.  I can confirm that my two friends mentioned in some of my previous posts have also never had any of the devices connected (like me), while others like you have that brief connection not giving you the chance to block them.  In my case, anything that says 'not connected' can be blocked and the setting holds.  My glitch is if I have xFi 'forget' these devices, they still reappear within anywhere from a couple of minutes to 24 hours -- can't get rid of them permanently.  I wonder how widespread this issue is? There are many, many internet customers who probably don't know how to access their gateway admin page or even know about the xFi app or web page.

New Poster

Re: "a new device has connected"

Do you have an update on the fix for this?  I just got my internet upgrade and now I'm receiving these messages:  New Device Connected - which is not ours.

Contributor

Re: "a new device has connected"

@tedgomur -- don't hold your breath.  This issue, for some, dates back to January.  If you call Comcast, they know absolutely nothing about it and tell you to have xFi 'forget' the device.  Doesn't work as devices eventually reappear.  @ComcastDaniella says they're working on it.  I have no reason to doubt her but I'm not optimistic this will ever be solved.

Contributor

Re: "a new device has connected"

You had better post anything that you find out about this security thread here. It is disgusting enough Comcast doesn’t take security anymore serious than this but to suggest you not post in this thread and inform the very people that has the exact security issue is grossly negligible.
New Poster

Re: "a new device has connected"

Wow - this sounds so frustrating.  Can you confirm that the issue is that you get these meaningless messages only?  Or is there an actual security breach that I need to be worried about?

Official Employee

Re: "a new device has connected"

Hi tedgormur, 

If they only have a MAC address, and no IP in Device Details, then they are not really connected. The notification is incorrectly sent before the wifi password is entered for that device to join the network. 
We are working on it, and I apologize for the hassle this is causing you. 

If you would like me to trouble shoot more with you, please send me a Private Message by right-clicking on my name. If you prefer, I can send you a message and look at your account from there. 

New Poster

Re: "a new device has connected"

@ComcastDaniella  How do I make sure there is no IP address?  I've been looking at the devices on my tv and I can't find that...

Highlighted
Official Employee

Re: "a new device has connected"

Please log into your xFi, and go to the Devices Tab. There, select a device you're questioning and go to Device Details. There, you will get a pop-up with infomation including the MAC Address and the IP Address. If it says Unknown, then it hasn't connected. 

Contributor

Re: "a new device has connected"

Whats the device name that is showing when you hit the "forget" tab and then it comes back soon after. I was getting the alerts from names that would change by a few numbers on each one. What I did before I made my report with the security department was unplugged any device that uses any type of Wi-Fi connection made in laptops tablets iPads phones home alarms any of the new wireless doorbells light bulbs refrigerators and the list goes on. Then I unplug the modem and the cable box and reset my TV so it wasn't connected to the internet through the Wi-Fi. I waited a few minutes and plugged in the modem which I have the Gateway at the time and then I plugged in any device but took Wi-Fi and logged in and kept track of the devices names. And then logged in with my laptops and phones and what I found out was my laptop was thrown out a separate device name that was coming from my network card and I believe there's one that comes from the modem as well that should be Cisco. So if I went and hit the forget button on those as soon as I log back in to the internet through my laptop it would go ahead and put that name back in my list. It might be what's wrong with some of yours guys and it could be that and extra like I had. If it's something you can do is you can log in to your admin modem settings to your browser make sure to change the password and use higher lower case and special for your password and then log out and back in with the new one. And make sure that you turn off your hotspot that's on the modem and disable the WPS setting so it doesn't allow you to push the button on top of the modem to connect another device to your Wi-Fi. If you're still using devices that use the lower signal then it's a easy way for people to hack in if they're within a certain radius of your modem. But if you've done all that you can go into your modem settings and on the left side go down to the bottom of the tabs and find your firewall settings and copy your inbound firewall setting and send it to the email after calling the support team for security and talk to a supervisor and get their email address and send it to them so they can start a case on investigating it. Good luck I know it helped mine so far