Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,746,220

members

14

online now

1,904,928

discussions

Back to Top

Xfi issues with port forwarding

New Poster

Xfi issues with port forwarding

Keeps getting "we're having some trouble" error evrytime I try to port forward. And I cannot use the port forward on the actual modem anymore, its blocked. What good is Xfi if it does not work!

Screen Shot 2017-09-03 at 10.31.56 AM.png
Official Employee

Re: Xfi issues with port forwarding

Hi, ceelo404 - Do you have an external router connected to your gateway? Are you getting this error only when you try to set up a port forwarding or on any other page? 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

Re: Xfi issues with port forwarding

I am also having the same issue. No external router connected to my gateway and this is only happening when trying to set up port forwarding.

Regular Visitor

Re: Xfi issues with port forwarding

I'm also having the same issue.  I tried adding a port for my connected phone and it worked, but adding a port for a connected security camera continues to give the same error message.  

New Poster

Re: Xfi issues with port forwarding

I'm having the same issue. Had previously set up a port forward, but it no longer appears to be working. When I go to the port forward page of the XFI web, it gives this error message.

 

I do not have an external router connected to the gateway. I get this error whenever I load that page. No other pages in the xFI app seem to give the problem.

New Poster

Re: Xfi issues with port forwarding

Also - tried rebooting the gateway, which did not help.

Official Employee

Re: Xfi issues with port forwarding

I will be reaching out to everyone individually to confirm some additional details that will help in the troubleshooting of these port forwarding issues. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

Re: Xfi issues with port forwarding

We have a security camera system that requires setting up port forwarding to be able to view the cameras remotely from another computer. I have attempted port forwarding on xFi and am getting the same error as everyone else is getting. I spent almost an hour and a half on the phone with Comcast Tech Support, only for them to tell me that it was an issue on their end that tech services would have to address. The support representative said the error should take 24-48 hours to resolve and that was 6 days ago with no changes in the error as of today. Since we were recently broken into and robbed at gunpoint in our own home, this is critical to us. Is this something that Comcast can resolve or do we need to start looking elsewhere for internet, phone and TV services? Thanks. 

Official Employee

Re: Xfi issues with port forwarding

Hi missylori, I am so sorry to hear this. I will be happy to look into it for you. I will reach out via private message. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

Re: Xfi issues with port forwarding

Same problem here. 

 

 

ScreenShot_20170927080109.png
New Poster

Re: Xfi issues with port forwarding

The same check back later message over here.

New Poster

Re: Xfi issues with port forwarding

I would also like to know the fix for this. Been having loads of trouble with my Xbox lately for NAT Type and I'm not able to use port forwarding. The old way while archaic at least worked.
Regular Visitor

Re: Xfi issues with port forwarding

dose anyone here have a solution to solve this problem?

New Poster

Re: Xfi issues with port forwarding

I am having same issues. 

New Poster

Solution

Hello everyone,

This is a technical issue affecting a lot of Comcast users. Some outages and misconfigurations reported by Comcast Tech support engineers.

 

The quickest remediation for this that worked for me:

 

1) Take a paperclip/pen and at the back of the router the reset button hold for 35 seconds (this will factory reset).

2) Wait until boot completely and you will see default SSID by factory, etc.

3)Join the router Wi-Fi like the first time when you joined at Comcast, register the configuration on the browser, etc.

4) You're all set, Advanced menu will be available to do port-forwarding without Xfi App/Web.

5) Don't register again to Xfi, just wait 3 months and try again if Comcast engineers fixed this particular issue.

 

Enjoy

New Poster

Re: Xfi issues with port forwarding

I'm having the same problems as well.

New Poster

Re: Xfi issues with port forwarding

I'm having the same problem too:

 

"Sorry, we're having some trouble gathering the list of your port forwards. If the problem persists, check back later."

Official Employee

Re: Xfi issues with port forwarding

All - for those that have been receiving the following message when attempting to port forward:

"Sorry, we're having some trouble gathering the list of your port forwards."

This issue should be resolved. Please check xFi when you get the chance and let me know if you still experience issues accessing the port forward page. 

 

 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Regular Visitor

Re: Xfi issues with port forwarding

Brittany, I checked again this evening and still get the same error when trying to add a port forward. To clarify, the page can be accessed and the error occurs when adding the port forward.
Frequent Visitor

Re: Xfi issues with port forwarding

Im getting still getting it. I had it before and when I factory reset my modem, it allowed me to configure my ports locally. Now its back again. It would be a nice to allow us to configure port forwarding by IP address not by pc name.

New Poster

Re: Xfi issues with port forwarding

I have comcast for cable and internet, ADT for security and a separate recording external secuirty cameras, plus an apple time capsule. For the last 5 years since moving here, I have had this issue but circumvented it by hiring a private technician to come out and fix the port issues. Comcast techs can't fix there ports to open and every single time that is where the problem stems from. It has nothing to do with apple or the ADT or anything. Its the ISP i.e. Comcast. 

Without fail, after any power failure the router from comcast resets and all ports close. 

I spent 5 hours today at home (2.5 hours on the phone with a tech who tried everything except opening the ports for me to get it to work). Finally she just said you need a new router. Again that is not the issue. 

 

I cannot open the ports myself in this Xfi app because of that same error message everyone else is reporting below. After Irma and the power outage, our systems were not working again. No security cam and no adt pulse. Our entire fence is down and we are completely exposed to an empty lot behind us and a main street. I have made it a point to call ADT and apple techs and each one have made reports stating that comcast has failed to provide "open port" access to me as their client, therefore blocking the usage of third party devices/companies such as ADT. Thankfully we have documented all of this. Why doesn't comcast just allow the open ports so we can use our other devices freely? Each time I call in I am told that moving to comcast security system will solve the issue... great time for a sales pitch is not when I am mistrusting of your services.

 

 

I really hope that this can be solved once and for all. 

Screen Shot 2017-10-01 at 1.13.14 PM.png
Regular Visitor

Re: Xfi issues with port forwarding

I can't even type in a

field when I try to setup port forwarding.

New Poster

Re: Xfi issues with port forwarding

I'm having the same issue. When I go to the port forward page of the XFI web, it gives this error message.

 

I do not have an external router connected to the gateway. I get this error whenever I load that page. No other pages in the xFI app seem to give the problem.

Frequent Visitor

Re: Xfi issues with port forwarding

Can we switch back to the old way until somebody figures this out?

Port forwarding in this update wasn't thought out properly.

New Poster

Re: Xfi issues with port forwarding

I'm having the same problem.  Should I go back to the Comcast office and downgrade to the old router?  Or should I ditch the xfinity gear and go with my own router since this iisue seems wide spread and not being resolved?

Frequent Visitor

Re: Xfi issues with port forwarding

This worked for me.

Do a hard reset, by pushing the reset button for 30sec. in the back.

log in 10.0.0.1

adim

password

go to advanced, port forwarding and Xfi was not in port forwarding, it was the old add a service way.

 

Hope it works for you!!

New Poster

Re: Xfi issues with port forwarding

So ---- exactly what is the problem.

 

 

How do we disable this piece of trash  --- completely???