Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,746,220

members

13

online now

1,904,928

discussions

Back to Top

XFi on Mictosoft Edge

Frequent Visitor

XFi on Mictosoft Edge

Does Xfinity Xfi work on Microsoft Edge.  I can open the page fine in Chrome but get a message that the page can't be loaded when I use Edge.

Official Employee

Re: XFi on Mictosoft Edge

Hi sking57, it's possible that this is a compatibility issue. What version of Edge are you using?




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Frequent Visitor

Re: XFi on Mictosoft Edge

Microsoft Edge 40.15063.0.0

New Poster

Re: XFi on Mictosoft Edge

I'm havin the same issue. It telles me it takes too long and wont give me any options but to leave the page

 

Official Employee

Re: XFi on Mictosoft Edge

sking57, trip56304 - I tested this on Microsoft Edge v40 and was experiecing issues as well. I have sent it to the engineering teams to investigate. In the meantime, I would recommend using another browser for access and I will provide an update when this is resolved. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Frequent Visitor

Re: XFi on Mictosoft Edge

I've been trying to get an answer on this topic since May 11th. I have Edge version 40.15063.0. It seems when Comcast can't resolve a problem,they just stop responding to your questions and hope you'll go away. Don't hold you breath waiting for a solution. Changing browsers isn't a solution, it's a band aid. 

New Poster

Re: XFi on Mictosoft Edge

It is September 17th and this issue has still not been resolved. Anything to report Xfinity? 

Service Expert

Re: XFi on Mictosoft Edge


srpruitt wrote:

It is September 17th and this issue has still not been resolved. Anything to report Xfinity? 


Can you try using Flash with Edge?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Frequent Visitor

Re: XFi on Mictosoft Edge

I've tried with and without Flash enabled. No luck either way.

Official Employee

Re: XFi on Mictosoft Edge

All, the teams are aware of the compatibility issue with MS Edge v40 and they are looking into getting this resolved. Unfortunately I do not have a time frame for when this will be fixed, but I can provide an update as soon as I have one. 

 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Frequent Visitor

Re: XFi on Mictosoft Edge

As of today, Xfi is working on Edge. Hopefully it will continue to work. Thanks for the fix.

Discussion stats
  • 10 replies
  • 676 views
  • 0 kudos
  • 6 in conversation