Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,764,405

members

23

online now

1,919,512

discussions

Back to Top

XFINITY xFi

Service Expert

Re: xFi app says I need to upgrade my hardware

We have the option to set up multiple sub-accounts in My Account that can be assigned to each of our children.  That is what I had to do.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Frequent Visitor

Re: xFi app says I need to upgrade my hardware

And there are tons of standard wireless routers that do the same thing, usually easier, better, and without risking your online security the way this does.  I'm just saying, do the research on the downsides of what this could mean.  If your login details get out for xfinity in any way (share with family, friends, log in from an unsecure location when traveling for streampix, lose phone, people come to your house and get it somehow, whatever way), you have just lost 100% of your security for good.  Anyone could now log in remotely, change yoru passwords, disable your firewall, and open up any ports they want, possibly without you even noticing.  Then they will always have free reign over your computer, can see what you do, remote control it, do whatever insidious things they want behind the scenes.  This is a bad idea.

 

A personal modem and router are physical and staionary.  You log into it directly from a direct connection.

Regular Visitor

Re: XFINITY xFi

I used the pause for my son and it worked great. However when I try to resume his device it is still blocked. I even deleted it and re-added it. It says it is active but when I print the parental control report it confirms it is blocked. I can't unblock it anywhere. Thanks for any advice.

Service Expert

Re: XFINITY xFi


Anon413731 wrote:

I used the pause for my son and it worked great. However when I try to resume his device it is still blocked. I even deleted it and re-added it. It says it is active but when I print the parental control report it confirms it is blocked. I can't unblock it anywhere. Thanks for any advice.


Did you try the xFi website?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Official Employee

Re: XFINITY xFi


Anon413731 wrote:

I used the pause for my son and it worked great. However when I try to resume his device it is still blocked. I even deleted it and re-added it. It says it is active but when I print the parental control report it confirms it is blocked. I can't unblock it anywhere. Thanks for any advice.


Hi Anon413731,
As RobertWy suggested, if you have been using the mobile app, please try to unpause the device through the xFi website xfinity.com/myxFi.
If the problem persists, let me know and I will send this to our support team for resolution.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Regular Visitor

Re: XFINITY xFi

Yes, I have used both the mobile app and the web site. I also ran through all of the troubleshooting tests which say everything is OK. Yet the parental controls report confirms the reality that the device is still blocked.

Official Employee

Re: XFINITY xFi


Anon413731 wrote:

Yes, I have used both the mobile app and the web site. I also ran through all of the troubleshooting tests which say everything is OK. Yet the parental controls report confirms the reality that the device is still blocked.


I am sorry to hear you are still experiencing issues. It sounds like xFi and the settings in your Gateway may have gotten out of sync. I will get this issue sent to the appropriate team for resolution. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

Re: XFINITY xFi

We have been using xFi since June, it has been very helpful in limiting our kid's device use.  However, in the last approximately 2 weeks it has not worked at all.  It says they are in bedtime mode or it says they are paused, but their is no effect on their devices.  About the time I noticed problems, I also discovered there were some new features.  Also, when I try and manage it from the xfinity website instead of the app, the page cannot load.  

 

Thanks

 

New Poster

Re: XFINITY xFi

I called CS today to determine bandwidth consumption by device on my home network.  While they failed to tell me about this app, I did eventually discover it on my own.  I've loaded it up on my W10 machine using Chrome and have also installed it on my iPhone.  The interface comes up fine, my devices are listed, functionality seems to be in place for the app to work.  Only problem is that all of my usage graphs are blank.

 

Is there something I need to do to get real-time and historical 30-day usage retrievable from the router via the app?

 

I have a DPC3941T gateway, if that makes any difference.

Service Expert

Re: XFINITY xFi

I've had mine for several months but I don't think there was any history before I started using Xfi.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Regular Contributor

Re: XFINITY xFi

I also am currently having the same problem.  Trying to pause all devices assigned to my children but they just keep on working....way to go Comcast!  I'd have to say that this app works about as good as everything else Comcast throws out there.....

New Poster

Re: XFINITY xFi

I have 46 total devices in my home that connect to my Xfinity Gateway.  Prior to Friday, I had a DPC3941T gateway.  On Friday, I upgraded to Gigabit service and got the XB6.  Since then, about 30 of my devices show online in xFi, while the other 15 show as inactive, even when I am actively using them at home.  I tried to go through telephone support and just kept getting told the various wemo switches that show inactive were doing so because they were not actively uploading or downloading.  I knew that wasn't true though because the MANY other wemo switches I have were showing as active 24/7.  The devices that are inactive say so all the time, but their data usage graph has bars that show data usage each hour.  Attached is a screenshot showing one of my 4 NestCams, which uploads 1080p video constantly (unless I turn it off) to the cloud, as inactive right now, but using lots of data.  I can login to the camera, see the live feed, and yet xFi will show it as a constant inactive device.  Any help?

 

 

1.jpg
Service Expert
Moved:

Re: XFINITY xFi

New Poster

Re: XFINITY xFi

Xfi does not work I get message saying phone Xfinity support which I did. After 30 mins on phone with support, transferred to level 3 support they tell me that xfi is no longer available and no eta on a fix. I think it must work for some folks though! My guess is that it's been deactivated for customers with Comcast security cameras installed because it tracks the high amount of data the Comcast security cameras are using. My four cameras newly installed in august used 1000 gigs ! I ended up having to turn off recording on 3 of cameras. Can't wait to get rid of them, absolutely useless if can't record. But can't drop for six months based on deal I signed for $100 dollars off each camera. Anyway if others that have security camera can't get into xfi then I bet that's the issue !
New Poster

Re: XFINITY xFi Not Working.

having the same issue here

New Poster

Re: XFINITY xFi

Ask your neighbor to change his password.  (I barely know my neighbors' names- how/why you have their wifi password is... odd)

New Poster

Re: XFINITY xFi

I already set up modem through a phone call because self activation didn't work. Now that it is activated when I sign into xfi app it prompts me to install again without option to skip. Help
New Poster

Re: XFINITY xFi

I have Xfinity and am interested in xFi. I own my own telephony modem and router and do not want to rent from Comcast. According to Comcast's website, the only xFi compatible equipment would be the Arris 1682G, Cisco 3941T or Arris TG3482G. I am wondering if anyone knows if these are all Voice/Telephony compatible and which is the "best" of the three. Thanks for any information.

Service Expert

Re: XFINITY xFi


Gargoylz wrote:

I have Xfinity and am interested in xFi. I own my own telephony modem and router and do not want to rent from Comcast. According to Comcast's website, the only xFi compatible equipment would be the Arris 1682G, Cisco 3941T or Arris TG3482G. I am wondering if anyone knows if these are all Voice/Telephony compatible and which is the "best" of the three. Thanks for any information.


I have the 1682G and it supports Xfinity voice.  It has been a very good gateway since I got it about six months ago




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Problem Solver

Re: XFINITY xFi

Comcast, it been a week and xFi is not blocking anything at all. Pausing, bedtime mode, protected browsing, and parental controls are all not working at all and the issue is widespread. Can someone resync xFi and my gateway?

New Poster

Re: XFINITY xFi

So I received the Arris 1682G and I can’t access Xfi. Every time I try it says I need an upgrade, but I already upgraded. The app even helped me set up the modem, but it doesn’t work anymore. Help?
New Poster

Re: XFINITY xFi

Did you get it straightened out? Because I’m having the same problem
Frequent Visitor

Re: XFINITY xFi

I am having the same issues with pausing devices and the bedtime mode not working... I have contacted Comcast, only to have this issue fall on deaf ears. It worked for awhile, then it stopped. I wonder if it from an update to the app. My wireless gateway is Cisco DPC3941T.

Problem Solver

Re: XFINITY xFi

I personally think it’s just xFi not working as they intended where they might or might not even know it. It’s not even working online either.
Official Employee

Re: XFINITY xFi

Hi Ddoub1, are you still receiving the upgrade message when you login to xFi?




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Official Employee

Re: XFINITY xFi

Hi jweaver0312, jlmank33 - I see open tickets for this issue on both of your accounts. I will follow up and see if I can get more information on the status of those tickets for you. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Frequent Visitor

Re: XFINITY xFi

Upate:

Talked to an level 3 agent, she tried some different things, but was unsuccessful. She schedule a repairmen to come out to check my modem, ect. After getting off my cell phone with her, I noticed that she ended up knocking out my telephone service. Instead off calling back, I just waited for a repairman to come.

 

The repairman showed up and told me that he has no clue of the xFi app and they do not handle that. But he was able to get my phone fixed (the phone that the level 3 agent messed up) and he said that modem ect. looks good.

 

Thankfully, I was able to get ahold of Zack from Comcast National Repair. He is getting my repair ticket escalted to Comcast Engineers. He has been in contact with me to make sure things are getting done.

 

So for anyone having this same trouble, do not give up! Same yourself a lot of time,frustration & aggravation and call the Advance Repair Team <Edited. Not a public info>. I have gotten further with them in less than 24 hours than I have in 4 days will the usual customer service!

 

I will post back Zack's findings & how they fixed it once it is fixed.

Frequent Visitor

Re: XFINITY xFi

I have used this feature for several months. Today, 11.7.17, the gateway page for users and devices will no longer load in my browser. See screenshot of what comes up for me when trying to access the gateway. I've tried 3 different browsers and still nothing. Also was on a call with service and they were stumped also. They said to keep trying. 

 

Any help or ideas are appreciated. 

 

Thanks.

Screen Shot 2017-11-07 at 12.19.23 PM.png
Service Expert

Re: XFINITY xFi

There was a broad network outage earlier.  Do you still have the issue?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Frequent Visitor

Re: XFINITY xFi

Thank you for replying RobertWy.

 

Still a problem. When I log in to my account I can see my dashboard, but I can't access the internet user, devices usage area that I've come to depend on these last several months. I think it's called the Gateway? When I try to access it from my history this is the url that comes up https://internet.xfinity.com/gateway-offline  -- and the content showing is the screenshot from my original question. 

Service Expert

Re: XFINITY xFi


_newbie wrote:

Thank you for replying RobertWy.

 

Still a problem. When I log in to my account I can see my dashboard, but I can't access the internet user, devices usage area that I've come to depend on these last several months. I think it's called the Gateway? When I try to access it from my history this is the url that comes up https://internet.xfinity.com/gateway-offline  -- and the content showing is the screenshot from my original question. 


One possibility is you are not logging in with your primary account userid/password.  You can find what Comcast thinks it is by logging into My Account.  If that doesn't help, try talking to customer service. 1800comcast.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Problem Solver

Re: XFINITY xFi

You can still access it with a secondary account.
New Poster

Re: XFINITY xFi

So I started a chat session to find out if its possible to un-link MyXfi from home router. This is because the port fed feature does not seem to work through MyXfi for me.  I was told I need to downgrade my modem and to take it in and it would be replace.

Seems there should be a way to un-link MyXfi.

 

Regular Contributor

Re: XFINITY xFi

I recently added an XiD tv box running as a slave to the XG1 dvr.  Ever since then, the main dvr shows up as a wifi device in xFi.  It doesn't have an ip address and xFi won't let me forget it.  Anyone have any ides on this?

Service Expert

Re: XFINITY xFi


ThomT wrote:

I recently added an XiD tv box running as a slave to the XG1 dvr.  Ever since then, the main dvr shows up as a wifi device in xFi.  It doesn't have an ip address and xFi won't let me forget it.  Anyone have any ides on this?


The XiD box communicates with the XG1, so I suspect this is normal.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Regular Contributor

Re: XFINITY xFi


RobertWy wrote:

ThomT wrote:

I recently added an XiD tv box running as a slave to the XG1 dvr.  Ever since then, the main dvr shows up as a wifi device in xFi.  It doesn't have an ip address and xFi won't let me forget it.  Anyone have any ides on this?


The XiD box communicates with the XG1, so I suspect this is normal.


I would think that it is normal also, except that xFi is a wifi tool and I believe that the XG1 and XiD communicate via MOCA.  I checked the wifi gateway via login at 10.0.0.1 and it does NOT show the XG1 at all.  

Service Expert

Re: XFINITY xFi


ThomT wrote:

RobertWy wrote:

ThomT wrote:

I recently added an XiD tv box running as a slave to the XG1 dvr.  Ever since then, the main dvr shows up as a wifi device in xFi.  It doesn't have an ip address and xFi won't let me forget it.  Anyone have any ides on this?


The XiD box communicates with the XG1, so I suspect this is normal.


I would think that it is normal also, except that xFi is a wifi tool and I believe that the XG1 and XiD communicate via MOCA.  I checked the wifi gateway via login at 10.0.0.1 and it does NOT show the XG1 at all.  


You are correct, I forgot about MoCA.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon