Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,745,575

members

35

online now

1,904,514

discussions

Back to Top

XFINITY xFi

Official Employee

Re: XFINITY xFi


BigKahuna2 wrote:

I swapped out my DPC3939 gateway for the Cisco 3941 so that I could start using the xFi app. I have called Comcast 4 or 5 times in the last few days and no one is able to solve my problem.  After I launch the app on my phone and enter my wifi info and submit it, about 5 minutes later it keeps telling me that it cannot find my gateway.  When I enter the app on my DVR or try to set up xFi online, it keeps telling me that I need to upgrade my equipment.  I just swapped the gateway out yesterday - am I supposed to wait for the billing to catch up?  Thank you for any suggestions.


Once you complete the activation of the new Gateway using the xFi mobile app you should be able to access the xFi experience from the mobile app, online and through X1. The team was working on a fix for this very issue that you experienced. I believe it should be in place within the next day or so. I will follow up and let you know once it is resolved.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Official Employee

Re: XFINITY xFi Not Working.


7bpc wrote:

Will there be a fix for Microsoft Edge?


Can you clarify? Are you referring to the WiFi icon that links directly to xFi from the top navigation? If so, we're in the process of updating the xfinity.com top navigation experience and not all customers will see the WiFi icon prior to accessing xFi for the first time. Have you tried accessing xFi directly from xfinity.com/myxfi?




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

Wifi Password Disclosure

Comcast apprarently does not believe that disclosing the WiFi password to anyone that picks up the television remote control is a bad idea - announcing this great new feature in a promotional email today. I could not believe it so I picked up my remote and asked it to tell me my WiFi password and there is was - for anyone to see. So now anyone that is in my house can have the WiFi password.  I'm smart enough to use the login creditials once connected to my router and obtain and manage the password that way. I believe this is a really poor and potentially dangerous feature and would like to know if anyone has any idea on how to disable it?

 

 

Official Employee

Re: XFINITY xFi


PhilAnderson wrote:

I have several questions.  I will try not to garble them all together.  Today, I began to install xFi, but quickly received a message that I needed to upgrade both my modem and my cable box.

1) First the modem.  I have two, one on each of two separate cable lines into my house.  I have a retail box (i.e., I own it) Motorola SB6141 in the upstairs room with the cable box and the TV.  I have an Arris 1682G downstairs that is wired to my phone and to an ASUS router.

A) Can I simply swap the positions of the two routers for the purpose of getting xFi to work?  I am aware that the swap may cause other issues with other devices, but I am willing to figure that out later.

Will I need to have Comcast zap my boxes again once they are connected, or should they simply work once they are wired and booted?

C) Assuming a signal is necessary, what is the best way to do this?  Do I need to call the 800 number, or is some easier way?

2) Next, the cable box.  The online "Review Equipment" says I need to replace my PA PX013ANM with an X1 TV box.  I thought my PA PX013ANM was an X1 TV box.  Am I missing something here?  Will it be sufficient to simply swap the two modem locations to enable xFi capacity?

 


I can help with your first question. To use xFi, you'll need to use your xFi Gateway (Arris 1682G) as both your modem and WiFi router. If you place your Gateway in Bridge Mode and use a third-party wireless router, the devices connected to your network will not appear in the Devices list of xFi, and you will not be able to manage them on the xFi site or app. 

 

Have you tried accessing xFi yet? If your Arris 1682G is activated you should be able to sign in to xfinity.com/myxfi or download the xFi mobile app and begin using the features.

 

I'll continue to research your second question.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Service Expert

Re: Wifi Password Disclosure


bjb52 wrote:

Comcast apprarently does not believe that disclosing the WiFi password to anyone that picks up the television remote control is a bad idea - announcing this great new feature in a promotional email today. I could not believe it so I picked up my remote and asked it to tell me my WiFi password and there is was - for anyone to see. So now anyone that is in my house can have the WiFi password.  I'm smart enough to use the login creditials once connected to my router and obtain and manage the password that way. I believe this is a really poor and potentially dangerous feature and would like to know if anyone has any idea on how to disable it?

 

 


Isn't it true that anyone who has access to a remote can find the wifi password without using voice?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: Wifi Password Disclosure

According to Comcast this morning revealing the password is a feature on the WiFi app and it can not be disabled. The only assistance Comcast was able to provide was setting it up so it's protected by the Parental Control Feature in the Xfinity Settings Menu so that anyone trying to access any app has to enter a 4 digit code. I've never been in a situation like this before where my password is just revealed to anyone so easily.

Frequent Visitor

Re: XFINITY xFi Not Working.

Yes, the wifi icon is no longer there. I have been able to access xFi from the icon before it disappear. I cannot access xFi from xfininity.com/myxfi either. The page won't load. I can access xFi using Internet Explorer 11 browser from both the website and the WiFi icon, which is visible in Internet Explorer. 

ou tried accessing xFi directly from xfinity.com/myxfi

 

ou tried accessing xFi directly from xfinity.com/myxfi

 

Official Employee

Re: Xfi


UK1 wrote:

I downloaded the new Xfi. The network that is indicated as mine is a different name and shows a different password than mine. The network name shown does not show up as an available network. Why is my network not what Xfi is listing?


The team found a fix for this issue. Could you please try to sign in to xFi again and let me know if you are still experiencing this same issue? Thank you!




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Official Employee

Re: XFINITY xFi


BigKahuna2 wrote:

I swapped out my DPC3939 gateway for the Cisco 3941 so that I could start using the xFi app. I have called Comcast 4 or 5 times in the last few days and no one is able to solve my problem.  After I launch the app on my phone and enter my wifi info and submit it, about 5 minutes later it keeps telling me that it cannot find my gateway.  When I enter the app on my DVR or try to set up xFi online, it keeps telling me that I need to upgrade my equipment.  I just swapped the gateway out yesterday - am I supposed to wait for the billing to catch up?  Thank you for any suggestions.


I've received confirmation that your new Gateway (Cisco 3941) wasn't properly onboarded for xFi. That issue should be resolved now. Could you please try to access xFi again and let us know if you are still experiencing the same issue? Thank you!




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

Re: Xfi

I have been having so much difficulty getting port forwarding working on Xfi. This interface is easy, but the functionality does not work. Even when I am able to get it configured, I am not certain the port forwarding will work 100% of the time. The thing that bothers me most is that about 5 days ago I noticed that 5 ports were forwarded to my PC. I never configured these ports, so I removed the PC from port forwarding. Just tonight, the port forwarding to the PC appeared again. I would like to have control over which ports are forwarded from the internet to my devices at home, but this is not the case.

New Poster

Re: Xfi

"Managed devices and Port Forwarding pages are moved to cloud"

I understand that this cannot be reversed.  However, this is leaving me with an unfixable problem.  I had set up blocks on some devices for certain days / times and those blocks are still in place.  I can't manage devices through the gateway admin and the Xfi portal / app doesn't seem to know about these blocks.  How can I remove them?

 

New Poster

Re: Wifi Password Disclosure

I agree with the other posts, having the wifi password to anyone that can access the X1 remote and go to apps is a huge security risk.

When you add parental control to apps, it blocks all apps (Netflix, sports app, etc).

There is an option where the my comcast account can require a password (not in parental control, its available on the comcast website). Why cant comcast add the same feature for Xfi, where it requires a admin password to access? Seems simple.

Now when Comcast gets sued due to a security breach maybe they will listen, and not leave wifi passwords open to anyone that can access the X1 remote! How do I delete the Xfi app from X1?

Connection Expert
Connection Expert
Administrator
Administrator
Moved:

Re: XFINITY xFi

New Poster

xFi devices and Voice service with new devices

I received a email informing me of the new xFi service. I followed the links to request the upgrade and noticed my current TEC TC8305C needs to be upgraded to new equipment to enjoy xFi. When I started the request for the upgrade I noticed the new device doesn't include Xfinity Voice, at least the website shows my current device and service it supports (Voice + Data) and the new device is shown with just Data.

 

Is it simply a website problem or this upgrade to xFi leaves Xfinity Voice customers behind?

Service Expert

Re: xFi devices and Voice service with new devices


JohnsCreek wrote:

I received a email informing me of the new xFi service. I followed the links to request the upgrade and noticed my current TEC TC8305C needs to be upgraded to new equipment to enjoy xFi. When I started the request for the upgrade I noticed the new device doesn't include Xfinity Voice, at least the website shows my current device and service it supports (Voice + Data) and the new device is shown with just Data.

 

Is it simply a website problem or this upgrade to xFi leaves Xfinity Voice customers behind?


My Arris TG1682G has voice and it works with xFi.  See if you can get one.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: XFINITY xFi

I can pause and limit users on my WiFi, but I live in an apartment and my kids can still log onto xfinitywifi hotspot. Is there anything I can do?
Service Expert

Re: XFINITY xFi


Berns7 wrote:
I can pause and limit users on my WiFi, but I live in an apartment and my kids can still log onto xfinitywifi hotspot. Is there anything I can do?

Maybe turning xfinitywifi off is an option?

 

https://www.xfinity.com/support/internet/disable-xfinity-wifi-home-hotspot/




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: XFINITY xFi

That won't fix the issue because my neighbors also has xfinitywifi that we can log into. I've also tried changing our Xfinity.com password and that did not stop us from being able to access the internet through a neighbor's xfinitywifi.
Official Employee

Re: xFi devices and Voice service with new devices


JohnsCreek wrote:

I received a email informing me of the new xFi service. I followed the links to request the upgrade and noticed my current TEC TC8305C needs to be upgraded to new equipment to enjoy xFi. When I started the request for the upgrade I noticed the new device doesn't include Xfinity Voice, at least the website shows my current device and service it supports (Voice + Data) and the new device is shown with just Data.

 

Is it simply a website problem or this upgrade to xFi leaves Xfinity Voice customers behind?


All xFi Gateways (make and model number Arris 1682G, Cisco 3941T or Arris TG3482G) support XFINITY Voice. I've alerted the team that manages the website to investigate further. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Service Expert

Re: XFINITY xFi


Berns7 wrote:
That won't fix the issue because my neighbors also has xfinitywifi that we can log into. I've also tried changing our Xfinity.com password and that did not stop us from being able to access the internet through a neighbor's xfinitywifi.

Sounds like your only option is some kind of "manual parental control" - collect the devices at bedtime, for instance.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Official Employee

Re: Xfi


GSwarthout wrote:

"Managed devices and Port Forwarding pages are moved to cloud"

I understand that this cannot be reversed.  However, this is leaving me with an unfixable problem.  I had set up blocks on some devices for certain days / times and those blocks are still in place.  I can't manage devices through the gateway admin and the Xfi portal / app doesn't seem to know about these blocks.  How can I remove them?

 


I've alerted the team of this issue and they will be reaching out to troubleshoot. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

XFi Digital Dashboard not working

I've been on the phone with tech support and they don't know about XFi. Can't sse the dashboard when I hit the icon in the uper right hand corner or when I use the XFi ap om my iPhone. Access to the internet is fine, it is a dashbord issue only. Please help

Service Expert

Re: XFi Digital Dashboard not working

Do you have one of the compatible gateways?

https://www.xfinity.com/support/internet/xfinity-xfi-overview/




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Problem Solver

Re: XFINITY xFi

My Wifi icon on the xfinity homepage is missing in IE11 even after clearing cache.

Problem Solver

Re: XFINITY xFi


jweaver0312 wrote:

My Wifi icon on the xfinity homepage is missing in IE11 even after clearing cache.


Update: The issue was being cuased by an Adblock proxy blocking the new elements.

Service Expert

Re: XFINITY xFi


jweaver0312 wrote:

jweaver0312 wrote:

My Wifi icon on the xfinity homepage is missing in IE11 even after clearing cache.


Update: The issue was being cuased by an Adblock proxy blocking the new elements.


That's interesting.  I did nothing and the WiFi icon appears in my IE11 today.  Maybe Comcast corrected the issue?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Regular Visitor

Re: XFINITY xFi

So anyone with access to my TV can now view my WiFi password!  No security here.

This Xfinity app should be secured with a PIN, or at least the "Show WiFi Passwords" feature.

Need to add some basic security or maybe some options to require a PIN for some of the features.

Tags (3)
Frequent Visitor

Re: XFINITY xFi

Cisco DPC3941T won't sign in to Xfi.
I can sign into my wireless gateway Cisco DPC3941T, that displays the standard xfinity gateway web page and function, but When I try to sign in to internet.xfinity.com/ page. (Wanted to access their cool new nicknaming devices, and monitoring traffic functions) I still get the message "Sorry, We're Having Some Trouble"

I installed the xfinity Wifi app for adroid, and during installation is says "Let;s activate your modem" at which point I stopped.
If I am able to use my modem and and getting good broadband connection, is't my modem already activated? Would activating it with my wireless app cause changes to the config?
thanks!

Bonus round: Repeated talks with Comcast help and their Techs have not yielded anything of note.

sorry.jpg
Frequent Visitor

Re: XFINITY xFi Not Working.

I cannot access either way. This is what I get after it attempts to load:

Capture.PNG

 

 

Problem Solver

Re: XFINITY xFi


RobertWy wrote:

jweaver0312 wrote:

jweaver0312 wrote:

My Wifi icon on the xfinity homepage is missing in IE11 even after clearing cache.


Update: The issue was being cuased by an Adblock proxy blocking the new elements.


That's interesting.  I did nothing and the WiFi icon appears in my IE11 today.  Maybe Comcast corrected the issue?


I guess so since this is happening on almost an area by area basis. 

Service Expert

Re: XFINITY xFi

Did you try different browsers?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Official Employee

Re: Xfi


mostlymustard wrote:

I have been having so much difficulty getting port forwarding working on Xfi. This interface is easy, but the functionality does not work. Even when I am able to get it configured, I am not certain the port forwarding will work 100% of the time. The thing that bothers me most is that about 5 days ago I noticed that 5 ports were forwarded to my PC. I never configured these ports, so I removed the PC from port forwarding. Just tonight, the port forwarding to the PC appeared again. I would like to have control over which ports are forwarded from the internet to my devices at home, but this is not the case.


Thanks for the feedback. I've asked the team to look into this issue. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Frequent Visitor

Re: Xfi

XB6 installed today, and my mistake was using xfi app. Now all my port forwarding is in the cloud, the problem is I cant add any more forwards. The website tells me my modem needs firmware and to reset, but that doesnt help, and the app tells me there is a problem and to please try again later.

 

Also, before the debacle of using xfi, I added about 8 or 9 forwards through the mso portal 10.0.0.1 but only 4 show up in the website as active forwards, however the ones that dont show up still work.

 

Very buggy, I want my modem back, and without the ability to use bridge mode - my network has been severely crippled at home.

Service Expert

Re: Xfi


CCguy wrote:

XB6 installed today, and my mistake was using xfi app. Now all my port forwarding is in the cloud, the problem is I cant add any more forwards. The website tells me my modem needs firmware and to reset, but that doesnt help, and the app tells me there is a problem and to please try again later.

 

Also, before the debacle of using xfi, I added about 8 or 9 forwards through the mso portal 10.0.0.1 but only 4 show up in the website as active forwards, however the ones that dont show up still work.

 

Very buggy, I want my modem back, and without the ability to use bridge mode - my network has been severely crippled at home.


Any chance you can try to take the XB6 to an Xfinity Store and ask for a replaceement?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Frequent Visitor

xFi app says I need to upgrade my hardware

I'm using the Arris TG1682G and the xFi app says I need to upgrade. Isn't it compatible?

Service Expert

Re: xFi app says I need to upgrade my hardware


richf7 wrote:

I'm using the Arris TG1682G and the xFi app says I need to upgrade. Isn't it compatible?


Yes, that is the model I have.  If I were you, I would try calling or posting in Customer Service.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: XFINITY xFi

I have an issue where a certain device is on pause and it gives me an error message when I try to remove it. And it can still access the internet so I can't regulate just that one device on the network.
Problem Solver

Re: XFINITY xFi

How come certain sites being blocked by protected browsing pop up with the normal protection screen saying its looking out for me and it was blocked becuase it was suspicious while other sites will say 404 Not Found Error?

Service Expert

Re: XFINITY xFi


jweaver0312 wrote:

How come certain sites being blocked by protected browsing pop up with the normal protection screen saying its looking out for me and it was blocked becuase it was suspicious while other sites will say 404 Not Found Error?


Is this happening with your xFi web site?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Service Expert

Re: XFINITY xFi

I check my xFi data usage every day and I got a surprise today: xFi data usage has been at max for the last 24 hours.  Looking at each device, I see that my Chromecast Ultra has been at max for the last 24 hours.  I have not used it for that period.  Here is a snapshot:Chromecast.jpg

 

 




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Regular Visitor

Re: XFINITY xFi

Are there any range extenders that work with Xfi specifically the TG1682G?

Administrator
Administrator

Re: XFINITY xFi


RobertWy wrote:

I check my xFi data usage every day and I got a surprise today: xFi data usage has been at max for the last 24 hours.  Looking at each device, I see that my Chromecast Ultra has been at max for the last 24 hours.  I have not used it for that period.  Here is a snapshot:

 

 


I have a chromecast ultra as well and I have noticed it using a lot of data in the background when not using it. Because of that I started pausing the device when I am not using it, however what is showing for you it is still very unusually high and when I have personally notice this it is only for short periods of time. I don't think this is an issue with the XFI itself, but it's something that surely would have to be monitored on your end since I don't think there is a way to disable background data consumption on the chromecast itself. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

Re: XFINITY xFi

Swapped out my failing cable modem today for a DPC3941T, which *should* be xFI compatible. It is a "Technicolor" and not Cisco branded, if that matters. 

Unfortunatley, I am getting a "To access xFi, you'll need to upgrade your service/equipment." error. 

Looks like my SW (or is it Firmware?) verison is 2.3p18s1. Ive tried to powercycle since Ive seen mention of ver 2.5 out there, but I am not getting that push. 

Is that the issue? I have downloaded the (android) app, but, like others, it defaults to "lets set up your cable modem!" which clearly is already set up and functioning. 

Since this is a new unit I picked up today (not bridged, BTW) I am not sure what the next step is. Hate to swap it out AGAIN, and have to reconnect everything up again. 

Is there a way to force the latest SW version?

Problem Solver

Re: XFINITY xFi


skeptic555 wrote:

Swapped out my failing cable modem today for a DPC3941T, which *should* be xFI compatible. It is a "Technicolor" and not Cisco branded, if that matters. 

Unfortunatley, I am getting a "To access xFi, you'll need to upgrade your service/equipment." error. 

Looks like my SW (or is it Firmware?) verison is 2.3p18s1. Ive tried to powercycle since Ive seen mention of ver 2.5 out there, but I am not getting that push. 

Is that the issue? I have downloaded the (android) app, but, like others, it defaults to "lets set up your cable modem!" which clearly is already set up and functioning. 

Since this is a new unit I picked up today (not bridged, BTW) I am not sure what the next step is. Hate to swap it out AGAIN, and have to reconnect everything up again. 

Is there a way to force the latest SW version?


The technicolor one isn’t xFi capable. Only 3 gateways are. Cisco DPC3941T, Arris TG1682G, and the Arris TG3482G

Problem Solver

Re: XFINITY xFi


RobertWy wrote:

jweaver0312 wrote:

How come certain sites being blocked by protected browsing pop up with the normal protection screen saying its looking out for me and it was blocked becuase it was suspicious while other sites will say 404 Not Found Error?


Is this happening with your xFi web site?


No. It is while going onto certain sites being blocked by the filter for parental controls using protected browsing. Certain blocked sites will display the xfinity xFi blocked page and certain sites that are also blocked by that will say 404 Not Found. 

New Poster

Re: XFINITY xFi

Thanks. At least its a definitive answer, inasmuch as a massively disappointing one. One wonders why, then, they would be handing out incompatible units - especially ones with identical model numbers. Sigh. 

 

(FWIW, my account details note my device is a "CISCO DPC3941T" but the unit itself notes "technicolor")

Problem Solver

Re: XFINITY xFi


skeptic555 wrote:

Thanks. At least its a definitive answer, inasmuch as a massively disappointing one. One wonders why, then, they would be handing out incompatible units - especially ones with identical model numbers. Sigh. 

 

(FWIW, my account details note my device is a "CISCO DPC3941T" but the unit itself notes "technicolor")


I would either call Comcast to fix that on the provisioning side or pick up a new gateway at the service center. Even though the Cisco one has a few FW problems, hopefully the fixes are on the way or you could ask someone at the service center to give you an Arris TG1682G if you would like xFi. 

Problem Solver

Re: XFINITY xFi


jweaver0312 wrote:

skeptic555 wrote:

Thanks. At least its a definitive answer, inasmuch as a massively disappointing one. One wonders why, then, they would be handing out incompatible units - especially ones with identical model numbers. Sigh. 

 

(FWIW, my account details note my device is a "CISCO DPC3941T" but the unit itself notes "technicolor")


I would either call Comcast to fix that on the provisioning side or pick up a new gateway at the service center. Even though the Cisco one has a few FW problems, hopefully the fixes are on the way or you could ask someone at the service center to give you an Arris TG1682G if you would like xFi. 


Sorry about the reply to myself. Using the forums on safari on iPhone isn’t that great. And also, you could try to ask for a XB6 but they likely don’t have that there as that model is not in a whole lot of areas yet.