Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,746,220

members

13

online now

1,904,928

discussions

Back to Top

Devices keep getting new name (hostname-#)

Frequent Visitor

Devices keep getting new name (hostname-#)

all of our devices keep getting incrementally rolled hostname, i.e. hostname-1, then hostname-2, etc. for the same device. This is making it impossible to control access for my son as it is considered a new device and is not associated with his profile. He's not spoofing his MAC addr, but that is changing as well, so I cannot just set a reserved ip to associate with the that. Any thoughts?  As mentioned, it's not just his desktop, its almost all devices on the network (both wifi and wired)

Official Employee

Re: Devices keep getting new name (hostname-#)

 

sully_1, have you tried uninstalling the app? Are you seeing this on the xFi website as well?




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Frequent Visitor

Re: Devices keep getting new name (hostname-#)

Yes, both app and website show the same behavior. It shows up the same when looking at the Gateway page as well.
Official Employee

Re: Devices keep getting new name (hostname-#)

Hi, sully_1 - Could you please provide the screenshots of what you see on the website and in gateway portal? You can send me those in a private message. Thank you!




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Frequent Visitor

Re: Devices keep getting new name (hostname-#)

Sorry just saw this, will PM those shortly

Official Employee

Re: Devices keep getting new name (hostname-#)

Hi, sully_1! I'd like to follow up on your issue, I have an agent from xFi team looking into your issue. I also escalated this issue to our Tech Support Team because I don't think this issue is related to xFi only. As soon as I get an update - I will let you know. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Frequent Visitor

Re: Devices keep getting new name (hostname-#)

Thanks!

Admin1

Re: Devices keep getting new name (hostname-#)

sully_1 -- Following up on your support ticket. Support ticket shows as resolved. Can you confirm please?




Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Frequent Visitor

Re: Devices keep getting new name (hostname-#)

Zach, that is not correct, the behavior is still continuing

New Poster

Re: Devices keep getting new name (hostname-#)

I have seen something similar happen to me. I didn't recognize the letters and numbers of the device the app listed yesterday, so I wasn't sure what the device was. I now know the device was my laptop, since my iPhone says it is waiting for the device to be available for the wifi sync, but the device has been renamed on the Xfi app, which I knew was my computer since I was using the internet on it. I can't find the old name listed under devices, either.

New Poster

Re: Devices keep getting new name (hostname-#)

I’m experiencing the same problem.  I’m wondering if it may be related to the fact that I 2.4ghz and 5ghz networks and I have a network extender to reach the far corners of my house (resulting in 4 separate networks that our devices can switch between).  When our devices switch from one network to the other, maybe that’s when they look ‘new’ and get registered as a new device with a new name.   I agree with the original poster, though - this renders the parental controls functions useless because the new devices don’t get assigned to a user.   

Frequent Visitor

Re: Devices keep getting new name (hostname-#)

I have a range extender, but this behavior started before that. So may not be correlated.

New Poster

Re: Devices keep getting new name (hostname-#)

Maybe has something to do when the IP address lease expires and it gets a new one?  

Frequent Visitor

Re: Devices keep getting new name (hostname-#)

It happens daily, IP lease is set for a week. Tried stateless IP v6 and that doesn’t change anything either, still keeps happening