Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,708,572

members

56

online now

1,872,229

discussions

Back to Top

Cannot access to xFi app - CISCO DPC3941T

Posted by
Regular Visitor
  • Congrats on Posting your first topic!

Message 1 of 6
184 Views

Hi all,

I'm trying to access to XFi apps and show me a message: "To access xFi, you'll need to upgrade your service/equipment" but I have a compatible router (CISCO DPC3941T), even a I cannot acces by website (https://internet.xfinity.com/), same message. I had read all messasges in this forums but I couldn't find ther right solutions. Please, Let me know What Do I need to resolve it. 

 

I am a primary user, I reset muy router several times, I change my firewall configurations many times, I test different web browsers, I mean, I tried several ways but I couldn't access. Please any advice?. 

5 REPLIES
Posted by
Official Employee

Message 2 of 6
141 Views

Hello johnerick77. I can assist you with getting the xFi app working. Please send me a private message and include your full name, service address, and account number so I can assist you. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Frequent Visitor

Message 3 of 6
119 Views

I'm having this exact same issue with an ARRIS TG1682G. 

Posted by
Official Employee

Message 4 of 6
85 Views

Hi MdAsh, sorry to hear you were receiving this message. I just checked and it looks like xFi should now be accessible for you. When you get a chance, please log into xFi - either xfinity.com/myxFi or in the xFi mobile app - and confirm. Let me know if there are any problems. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Official Employee

Message 5 of 6
69 Views

@johnerick77, I received your private message.  Glad to hear xFi is working for you now. Please post again if there is anything further we can do for you. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 6
43 Views

I'm having a similar issue with the CISCO DPC3941T. When I try to access the xFi webpage I get the error message "Settings Currently Unavailable. If you're having trouble accessing your home network, try our troubleshooting tips." I have tried rebooting my modem, using a different browser, and using the xFi mobile app, but I still receive the same error. 

 

Any additional help would be appreciated.