Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,725,392

members

72

online now

1,887,402

discussions

Back to Top

voicemail setup

Posted by
New Poster
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 1 of 26
2,768 Views

I had no trouble setting up voice mail on Galaxy 8. Cannot setup voice mail on th iPhone 7?

 

25 REPLIES
Posted by
Frequent Visitor

Message 2 of 26
2,766 Views
I had no problem setting mine up. It prompted me to choose a password and greeting when I pressed Voicemail in the phone app. Did you try to hold the 1 key and set it up that way?
Posted by
New Poster
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 3 of 26
2,640 Views

I tried this, it did NOT work. The intructions just keep repeating and asking me if I am still there. It does not recognize that I am pushing the keys.

Ready to exchange for S8

Posted by
New Poster

Message 4 of 26
2,600 Views

my voicemail was not set up properly by xfinity and when I received phone it didn't work. Now I've been fighting to get the correct system settings for over a week and I keep getting brushed aside and told to be patient. It can't be that difficult to provide the number and programming code to enable this, but somehow xfinity screws it up. 

Posted by
Valued Contributor

Message 5 of 26
2,550 Views

I have the same problem, the voice kept asking if I was still there and it asked me to enter the new password then press # but I already did. The system didn't recognize the keys/buttons I entered. I tried the Panasonic DECT 6.0 handset connected to the cell phone via Bluetooth with same problem. I am waiting for Xfinity Mobile reps to resolve this problem for me. I have the LG X-Power, btw.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 26
2,517 Views

Same for me as far as the VM not being enabled at all. I was told that others have been complaining as well. If I dial 1 (long press) I get a message saying my VM is not enabled for my account. If I try to use the VM app it says my logon is no good. Clearly there is an issue.

Posted by
Frequent Visitor

Message 7 of 26
2,505 Views

Yes, clearly there is an issue. We have had an ongoing 3.5 week problems with the VM on the LG Power X. Have been told for the last 2+ weeks it has been escalated to a Tier 3 level and they will get back to us. They never have. Every contact has been initiated by myself even when I am promised a call back from a representative at a definitive date and time.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 8 of 26
2,466 Views
Mine is the same on S7! I try to log in and it says I'm not in the right account. When I long press 1, it says the voicemail of the number is not available.
Posted by
Valued Contributor

Message 9 of 26
2,431 Views

I am sure XM does not have the fix as of now for the voicemail problem that I am experiencing. I have not been contacted by any XM reps as promised and the problem is still there: The system never recognized I already pressed the keys on the dialpad when I tried to set up the voicemail. Calls and text have worked great, though. It also means I will not be able to use the phone with other automated voice systems like my banks, credit cards...

Posted by
New Poster
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 10 of 26
2,397 Views

Same problem here. The app works fine but everytime I try and set my password the voice kept asking if I was still there and it asked me to enter the new password then press #. After 3 tries it says to try later. The customer service is trying to say it is a problem with the phone. My wife has the same phone and the same problem. The phone works fine with other auto attendants eg: banks, company voice mails etc. so I doubt it is the phone.

 

I have yet to get a respose from Xfinity

 

 

Posted by
Valued Contributor

Message 11 of 26
2,377 Views

hanks for telling the phone worked fine with other automated systems. At least the problem only exists with the XM voicemail system.

Posted by
Frequent Visitor

Message 12 of 26
2,345 Views

Still no resolution on the voicemail issue. Yesterday was 4 weeks.

Posted by
Valued Contributor

Message 13 of 26
2,330 Views

Right, my voicemail problem is still there, no fix. No one from XM contacted me either.

Posted by
Frequent Visitor

Message 14 of 26
2,248 Views
Same issue here. Have spent hours on hold and talking with CS. They say they are aware of the issue and that it's up to the engineers to resolve. I asked them to turn off my voicemail all together in the meantime, so at least people won't try and leave a message. That didn't even work. Unanswered calls still go to voicemail. Very frustrating.
Posted by
Valued Contributor

Message 15 of 26
2,230 Views

If you have an Android phone, try the Xfinity Mobile Voicemail app. I could use the Xfinity Mobile Voicemail app to check the voicemail on my X-Power. However, I couldn't set the PIN for the voicemail so I couldn't check voicemail via phone, any phone.

Posted by
Frequent Visitor

Message 16 of 26
2,208 Views
That is good info. I'm using an iPhone, so as far as I can tell I don't have any access to it at all. It would be nice if it could at least be accessed online.
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 17 of 26
2,134 Views

I get the same thing on my X Power and been trying to get Xfinity Mobile to fix it and they cannot seem to get it right

Posted by
Frequent Visitor

Message 18 of 26
2,074 Views

Voicemail issue is now at 5 1/2 weeks. No resolution. No ETA on a resolution. That's right 5 1/2 weeks.

Posted by
Frequent Visitor

Message 19 of 26
1,950 Views

Now at 6 weeks and 1 day on the unresolved voicemail issue. Told it is a known issue and they have no resolution let alone an ETA on a resolution.

Posted by
Frequent Visitor

Message 20 of 26
1,645 Views

Now at 8 weeks and 2 days and still have a voicemail issue. "It is a known issue and they are working to resolve it" is the broken record I keep hearing over and over again.

Posted by
Frequent Visitor

Message 21 of 26
1,487 Views
I decided to try and set up my voicemail again today, just for the heck of it. I'm not sure if the issue has been resolved across the board, but I was successfully able to set mine up!
Posted by
New Poster
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 22 of 26
1,406 Views

Same here !!!!!! It works !!

Posted by
Contributor

Message 23 of 26
1,030 Views

Just out of curiousity... would that be New Britain, CT in your handle?  Smiley Happy 

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 24 of 26
959 Views

How did this get resolved?  I am having same issue

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 25 of 26
144 Views

Just out of curiosity, what did you do to get it to work?  Having same issue on an iPhone 8. Can't get visual voicemail to set up.  Called XM cust service and the rep on the line didn't even understand what an IMEI is and were of no help.

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 26 of 26
52 Views

It might not be the same problem but did you all try to turn on the cellular data first before setting up voice mail?