Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,761,411

members

69

online now

1,917,337

discussions

Back to Top

Xfinity mobile website has a bug

Problem Solver

Xfinity mobile website has a bug

When xf mobile submits monthly charge and it is being processed by CC company, website says "Auto charge failed, verify info on file" under device menu, "Past due" under Billing, but 0 days past due when looking at Recent charges. CC website says charge submitted yesterday and in pending state.

 

 

Untitled.png            Devices

 

Untitled.png               Billing

 

Untitled.png   Recent charges

Official Employee

Re: Xfinity mobile website has a bug

mvenanzi, thanks for reporting this discrepancy. Is this still showing incorrectly?




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Problem Solver

Re: Xfinity mobile website has a bug


ComcastKenF wrote:

mvenanzi, thanks for reporting this discrepancy. Is this still showing incorrectly?


Yes it is, today mobile site says "1 days past due" but CC still says charge is pending. Mobile site should not be reporting "Auto-pay failed"  or past due while waiting for payment to clear.

Official Employee

Re: Xfinity mobile website has a bug

ComcastKenF wrote:

mvenanzi, thanks for reporting this discrepancy. Is this still showing incorrectly?

Yes it is, today mobile site says "1 days past due" but CC still says charge is pending. Mobile site should not be reporting "Auto-pay failed"  or past due while waiting for payment to clear.

Definitely odd. Let's check this discrepancy further. I'll look into your account. Can you private message me your full name, account number and address once again? 

 

Thanks. 

 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Problem Solver

Re: Xfinity mobile website has a bug


ComcastKenF wrote:
ComcastKenF wrote:

mvenanzi, thanks for reporting this discrepancy. Is this still showing incorrectly?

Yes it is, today mobile site says "1 days past due" but CC still says charge is pending. Mobile site should not be reporting "Auto-pay failed"  or past due while waiting for payment to clear.

Definitely odd. Let's make sure this discrepancy further. I'll look into your account. Can you private message me your full name, account number and address once again? 

 

Thanks. 

 


Sent info via PM, but don't see what would be found in my account, It definitely looks like a web site bug. It will probably change once the CC company clears the payment. The charge did not get refused by CC, so payment hasn't failed as reported by mobile site.

Official Employee

Re: Xfinity mobile website has a bug

ComcastKenF wrote:
ComcastKenF wrote:

mvenanzi, thanks for reporting this discrepancy. Is this still showing incorrectly?

Yes it is, today mobile site says "1 days past due" but CC still says charge is pending. Mobile site should not be reporting "Auto-pay failed"  or past due while waiting for payment to clear.

Definitely odd. Let's make sure this discrepancy further. I'll look into your account. Can you private message me your full name, account number and address once again? 

 

Thanks. 

 

Sent info via PM, but don't see what would be found in my account, It definitely looks like a web site bug. It will probably change once the CC company clears the payment. The charge did not get refused by CC, so payment hasn't failed as reported by mobile site.

 

mvenanzi, just saw you posted here. I basically said the same thing (haha). It'll probably clear once the payment posts fully. I'll monitor to be sure. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Problem Solver

Re: Xfinity mobile website has a bug


ComcastKenF wrote:
ComcastKenF wrote:
ComcastKenF wrote:

mvenanzi, thanks for reporting this discrepancy. Is this still showing incorrectly?

Yes it is, today mobile site says "1 days past due" but CC still says charge is pending. Mobile site should not be reporting "Auto-pay failed"  or past due while waiting for payment to clear.

Definitely odd. Let's make sure this discrepancy further. I'll look into your account. Can you private message me your full name, account number and address once again? 

 

Thanks. 

 

Sent info via PM, but don't see what would be found in my account, It definitely looks like a web site bug. It will probably change once the CC company clears the payment. The charge did not get refused by CC, so payment hasn't failed as reported by mobile site.

 

mvenanzi, just saw you posted here. I basically said the same thing (haha). It'll probably clear once the payment posts fully. I'll monitor to be sure. 


I agree, all I was trying to report is that web site shouldn't be telling customers that auto-pay failed if it actually didn't

Official Employee

Re: Xfinity mobile website has a bug

Gotcha. I appreciate you bringing this to our attention. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Problem Solver

Re: Xfinity mobile website has a bug

I received email over night from xf mobile that my auto pay was made. Today mobile site is giving mixed messages:

Untitled1.png

 

 

Untitled.png

 

Untitled2.png

Official Employee

Re: Xfinity mobile website has a bug

mvenanzi, not sure if that is still reflected on your end, but I don't see any unpaid balances on my end. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Problem Solver

Re: Xfinity mobile website has a bug


ComcastKenF wrote:

mvenanzi, not sure if that is still reflected on your end, but I don't see any unpaid balances on my end. 


Site still say "Auto-pay failed, verify info on file" on device tab, but others say paid.

Official Employee

Re: Xfinity mobile website has a bug

ComcastKenF wrote:

mvenanzi, not sure if that is still reflected on your end, but I don't see any unpaid balances on my end. 

Site still say "Auto-pay failed, verify info on file" on device tab, but others say paid.

Thanks. Do you see this on the app as well?




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Problem Solver

Re: Xfinity mobile website has a bug


ComcastKenF wrote:
ComcastKenF wrote:

mvenanzi, not sure if that is still reflected on your end, but I don't see any unpaid balances on my end. 

Site still say "Auto-pay failed, verify info on file" on device tab, but others say paid.

Thanks. Do you see this on the app as well?


Nope

Official Employee

Re: Xfinity mobile website has a bug

Thanks. I've reached out to the folks at XFINITY Mobile to take a look at this for us. I'll follow up soon. 

 

KenF




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon