Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,636,352

members

27

online now

1,814,192

discussions

Back to Top

problems with xfinity mobile connect app iphone

Posted by
Regular Visitor
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 1 of 14
2,204 Views

Since the upgrade to the email system I am having problems with my iPhone and iPad not syncing properly.  Incoming email is not an issue.  The problem is emails being deleted on one device and not showing as being deleted on the othe devices, i.e. an email deleted from the website via PC does not show as being deleted on the mobile devices and email deleted on the mobile devices do not show as being deleted when going to the website (they sometimes show as being read).  This was not a problem prior to the upgrade; my account was setup for IMAP prior to upgrade.  Deleting and reinstaling the app on the mobile devices "corrects" the problem on the initial load of email but doesn't fix it going forward.  Signing out and signing back in does not resolve the issue.  Running Windows 10 on the PC and iOS version 10 on the mobile devices.  iPad is WiFi only.

 

Any suggestions for a fix?

13 REPLIES
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 2 of 14
2,177 Views

I'm experiencing the same issue!  It's very frustrating.

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 3 of 14
2,155 Views

I was on phone with tech support and they opened a ticket as she was ghosting my screens and she had same issue.  I am on iPhone SE, IOS 10.0.2, IMAP with correct port assignments.  My desktop is Windows 10, using Xfinity Connect.  I ensured all devices are IMAP not POP.

 

1) Sent test email to my PC.

2) Deleted test email on PC.

3) It deleted from PC inbox.

4) It did not delete from iPhone inbox.

 

5) Sent new test email to my PC.

6) Deleted test email on my iPhone.

7) It deleted from iPhone inbox.

8) It deleted from PC inbox.

 

It appears it is a one way issue.  Hoping they fix soon as have been using Connect since it became an app.   Wondering if it has something to do with one of the delete settings.  On PC Connect you have an option in mail to immediately delete email.  Not sure if that would move it to trash or delete it completely.  On iPhone the small increment for delete is one week.  Will be my next experiment.

Posted by
Visitor
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 4 of 14
2,112 Views
I am able to receive and see messages but my app crashes each time I try to send or reply to a message. I have logged off, reinstalled the app but to no avail.

Any thoughts??

Thanks.
Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 5 of 14
2,082 Views
I have the same issue. Frustrating work on iPad all day and when I am mobile and open email on phone see 100+ 'new' emails that have already been deleted on iPad.

Using the most current app on both devices.
Posted by
Frequent Visitor
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 6 of 14
2,029 Views

I am having the same issue. Work all day using comcast's webeamil through my browser. Then look on my iphone and nothing I've done all day has synched up with comcast's iphone app. So frustrating. I've spoken to customer service three times about this. They keep telling me they are working on it. But nothing seems to be a happening. It all went south when they upgraded the design of their webmail interface. The only solutiion is to delete the app at night and reinstall it. So stupid. 

 

FIX IT!!!!!

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 7 of 14
2,021 Views

I am also having the app crashing issue. Very annoying, and renders the app useless. I hope Comcast is aware and building a fix. 

Posted by
Visitor
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 8 of 14
1,386 Views
I open the app and it immediately crashes. Spent almost an hour with customer service and they were nice but far from helpful. I was told to contact Apple even thought the only thing not working on my phone is Xfinity Connect. Horrible customer service.
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 9 of 14
701 Views
Having the exact same problem!!!!
Posted by
Official Employee

Message 10 of 14
671 Views

Rest assured we are aware and working on it.  The problem does seem to be both elusive and impacting some people more than others, but we are working to figure it out.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 11 of 14
653 Views
Has this been fixed? Suddenly cannot retrieve Voicemails with Xfinity Connect app. Worked great until 2017.
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 12 of 14
644 Views

I'm having the same issue, it's very frustrating and when I try to send an email from my laptop, I get constant message that the draft is being saved.  Very annoying.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 13 of 14
620 Views
Having a problem sending emails using XFINITY connect. I compose the email hit send, app crashes. Open app find email sitting in outbox. Click send again and again app crashes. Only does this on my iphone 6s+. App works ok on my ipad. HELP
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 14 of 14
528 Views
I am having all the same problems!! Anyone have a "fix" yet? I was on the phone with Comcast and was disconnected!