Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,683,503

members

91

online now

1,851,848

discussions

Back to Top

Xfinity connect app stopped working on iPhone and iPad

Posted by
New Poster
  • Congrats on Posting your first topic!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 1 of 7
2,060 Views

I can. O longer access my email from my iPhone nor my iPad using the connect app. Is anyone else having this problem? I get an error message, and also updated my IOS two days ago 

 

6 REPLIES
Posted by
Contributor

Message 2 of 7
2,056 Views
Had same problem on Android. Signing in and out of all Xfinity apps and on computer and reinstalling app helps intermittently. But sometimes need to log out and in again repeatedly to get app to work.
Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 3 of 7
2,010 Views

Yes, I'm having the same problem.  Are you on the IOS beta program?  My Xfinity Connect quit on both my iPad and iPhone after upgrading to the latest IOS 10.3 (beta1 I believe)

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 4 of 7
1,818 Views
Same here for connect app on all my IOS devices. Been like this for 6 weeks. I'll wager that if you call customer service in pakistan they'll offer to restart your modem remotely. That seems to be the # 1 Xfinity customer service response
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 5 of 7
1,794 Views

I have the same problem with phone and tablet, iOS 10.3 update worked until last week. Now can't access email. 

 

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 7
1,186 Views

I have same problem (10.3 update). It just stalls and I have to reboot to get to work again. Very unreliable app

Posted by
New Poster
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 7 of 7
682 Views

Same here, can't connect.  Ever since email "update" I have been having issues on iPhone & iPad.  On my computer email is very slow to load & I frequently have to log in again.  Nice "upgrade".