Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,787,754

members

32

online now

1,938,085

discussions

Top

Voice@Go not working on Samsung Galaxy 7 Edge

ANSWERED
Regular Visitor

Voice@Go not working on Samsung Galaxy 7 Edge

So the connect app has been solid on my Samsung phone, until ATT/Samsung rolled out Android 7.0.

 

Ever since the upgrade the voice2go feature where I'm notified of an incoming call on my xfinity voice line works intermittenly at best. Typcially when I reset the apps data or reinstall it.

 

I've deleted the apps data and re-signed in as well as uninstall/reinstalled the app.

 

My account is provisioned with the access as it's working fine on an iPhone.

 

Any ideas?

Accepted Solution

Re: Voice@Go not working on Samsung Galaxy 7 Edge

I actually found the solution to fix this.  It has to do with Battery Optimization in Android Nougat.

 

You have to disable battery optimization for the xfinity connect application.

 

To do this you have to go to:

1. Settings

2. Applications

3. Click the 3 ... at the upper right corner.

4. Select Special Access

5. Optimize Battery Usage

6. The view defaults to 'Apps not optimized', change to 'All apps'.

7. Find the 'Connect' app in the list.

8. Turn off the feature so that it's not blue (the slider toggle).

9.  That is it.

 

After doing this change the app started to function correctly and I get notified of incoming calls to my land line.

 

In a side note, I found disabling this feature on other applciations to fix an issue where I would not get push notifications until I waked my phone when it was idle for awhile.

 

Glad I was able to figure out this one.  Hope it helps some of your others with Andriod Nougat.

 

This also resolved it on my Google Pixel Tablet as well.

View answer in context
Frequent Visitor

Re: Voice@Go not working on Samsung Galaxy 7 Edge

I have the same problem on my galaxy S7.  Worked fine until amdroid 7.0 installed.

Contacted customer service but they were unable to resolve.

Valued Contributor

Re: Voice@Go not working on Samsung Galaxy 7 Edge

You might want to give the following a look to see if it perhaps has somehow gotten reset.

 

With the Connect App open, select the three horizontal lines in the upper left corner of the screen and then choose the Settings menu option.  From the screen that opens up, select the Notification Preferences option.  Down at the bottom of the screen you are taken to should be a Voice2Go heading with Incoming Calls beneath it.  Make sure that option is set to On, which at least in my case means the colored dot is to the far right and is a very bright blue color.  

 

Additionally, at the very top of the screen you might want to check the All Notifications setting and make sure it is set to On as with it off it automatically turns all notifications off.  

 

At the actual Android level, select the Settings and then select Notifications.  Scroll down the list of apps until you get to the Connect app and select it.  Make sure the Block All setting is not turned on.  

 

Hope this helps you out.

Regular Visitor

Re: Voice@Go not working on Samsung Galaxy 7 Edge

Thanks for the info but that is not the problem...

Regular Visitor

Re: Voice@Go not working on Samsung Galaxy 7 Edge

This continues to be an issue.  The xfinity connect app was causing issues with my other apps where I wouldn't get notifications so I had to remove the app from my phone.  I still have it on my Google Pixel tablet and will try again if the app has a new update.  It also doesn't work properly on my Google Pixel table either.  

 

In both cases once I sign in it works where I get notified that an incoming call is coming into my xfinity voice line.  But after some length of time it seems that it gets disconnected from the xfinity service and no longers works.  I can clear the apps data re-sign in and then it works for a little while, then nothing after some length of time.

 

I hope they fix it, but since it's been almost a half a year it seems they are no longer investing in this app, at least not the android side.

Regular Visitor

Re: Voice@Go not working on Samsung Galaxy 7 Edge

I actually found the solution to fix this.  It has to do with Battery Optimization in Android Nougat.

 

You have to disable battery optimization for the xfinity connect application.

 

To do this you have to go to:

1. Settings

2. Applications

3. Click the 3 ... at the upper right corner.

4. Select Special Access

5. Optimize Battery Usage

6. The view defaults to 'Apps not optimized', change to 'All apps'.

7. Find the 'Connect' app in the list.

8. Turn off the feature so that it's not blue (the slider toggle).

9.  That is it.

 

After doing this change the app started to function correctly and I get notified of incoming calls to my land line.

 

In a side note, I found disabling this feature on other applciations to fix an issue where I would not get push notifications until I waked my phone when it was idle for awhile.

 

Glad I was able to figure out this one.  Hope it helps some of your others with Andriod Nougat.

 

This also resolved it on my Google Pixel Tablet as well.

Frequent Visitor

Re: Voice@Go not working on Samsung Galaxy 7 Edge

Good job, looks like this fixed my same problem on my Galaxy S7.