Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,745,273

members

66

online now

1,904,365

discussions

Back to Top

Not receiving home phone calls in app running on Android 7.0 - final resolution

Regular Visitor

Not receiving home phone calls in app running on Android 7.0 - final resolution

I posted a message earlier concerning home phone calls not being forwarded to connect on my galaxy s8. I worked with ComcastJoeTru for a few days and thought we had resolved the issue. He reset the back end provisioning for my account which worked and I was able to receive calls and the post was closed. Unfortunately after only one day I was no longer receiving home calls. I then started doing some research on my own and have found a solution that I want to share with the community. Battery optimization needs to be turned off for the connect app. Since I have done this every call is forwarded to my phone without fail. Following are the steps to turn off battery optimization.

 

Go to settings, apps

Tap the three dots in the upper right corner and select special access

Select Optimize Battery Usage

Tap on apps not optimized and select all apps

Scroll down to find the connect app and move the slider to the left (this turns off optimizatiion for this app)

Scroll back to the top and tap on all apps and select apps not optimized

The connect app should now be in the list

 

As I said, since I have done this I have not missed a call. Hope this helps anyone else that has been having issues with the app.