Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.








Not able to download app


Not able to download app

I am having trouble with getting the xfinity connect app to download on my i pad. They did an update a couple of days ago and since then it was stuck in a waiting mode.  I have tried everything. I put a feed out to the apple forums. They said to try uninstalling and reinstalling.  I was able to uninstall but when I go to the app store to reinstall it says update pending. When I tap to update it it starts and then just as the circle is full from loading it just sits there stuck again. Is that anything that could be fixed from your end. It is on my i pad 2 running ios 9.3.5

I am sure it is the app as I have no problem on my windows laptop.

I am not real tech saavy but I would really appreciate any ideas you may have. I am getting ready to take a trip and would like to get the problem solved so I don`t have to take the laptop.  Thank you, Cindy 

Forum Changes:
Open Wifi Hotspots Northeast Division... See More
Discussion stats
  • 0 replies
  • 0 kudos
  • 1 in conversation