Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,808,595

members

66

online now

1,954,461

discussions

Top

"Subscription Required" - I already have a subscription

New Poster

"Subscription Required" - I already have a subscription

I have a subscription to most of the online streaming channels but when I try to watch them I get a "subscription required" message, even when signed in. Specifically, I'm trying to watch Fox Sports 1 and cannot.

New Poster

Re: "Subscription Required" - I already have a subscription

i'm having the same problem. no problem watching last night, but today it says i need a subscription. 

 

 

New Poster

Re: "Subscription Required" - I already have a subscription

I'm having the same problem. Even my TV wont work. and it will be 4 days till a tech can fix it.  I think i'm calling another cable provider in the morning and seeing if they can get me service sooner.  If so, goodbye comcast.

Contributor

Re: "Subscription Required" - I already have a subscription

Comcast is well known for having the WORST customer service, and they are proud of it.  If you go to youtube and do a search for "comcast doesn't give a", the first video in the list is a promotional video explaining comcasts take on their service and relationship with customers.

Regular Visitor

Re: "Subscription Required" - I already have a subscription

Same problem here. Worked yesterday and failed today... Comcast sucks!!!

Frequent Visitor

Re: "Subscription Required" - I already have a subscription

Service Expert
Moved:

ATTENTION ------ U2R4E

Your post contained personal information and was removed to a secure location. These are public forums, and you should never post account numbers, street addresses, telephone numbers, email addresses, your full name, or anything else personally identifiable to you. Spammers and hackers can easily harvest that information. Your post is below with the information redacted or removed. Please read the forum guidelines for posting.

 

Your original post with the information removed is below:

 

I am not sure this will help, but it worked for me. 

 

If you are using Mozilla Firefox,

 

1) Go to the Tools Menu and then /Options.

 

2) In the Left Menu click on Security

 

3) In the Security window go to the Paswords section.

 

4) If the Remember Passwords For Sites button is Checked, click on the Saved Passwords button.  If it is not checked then go to step #9  and see if that helps.

 

5) In the Search space provided, type in comcast.  It should retrieve any Sites and Usernames for the the Xfinity TV site.  (To be safe, make sure to write down the Usernames and Passwords associated with each Site.  You can see your passwords by clicking on the Show Passwords button.

 

6) Select any Sites that have the word comcast in them and Delete each entry you find.

 

7) Repeat steps 5 and 6 by searching on the word Xfininty.

 

8) Try logging in.  (NOTE: You may want to do step #9 prior to logging in, but some of you may not have to)

 

9) Call Xfinity/Comcast at 1-800-934-6489; ask for tech support; then ask the representative to do a UDB Refresh on your account.  Tell them it is due to the Subscription Required error message.

 

10) Cross your fingersMan Happy

 

Good Luck,

Brian

XXXXXXXXXXXXXXXXXXX





The Support Forums are "public" forums and you should not post identifiable information (full name, account number, address, phone numbers & email addresses).  Users of these forums are Comcast customers,the same as you & me and volunteer their time to assist with the issues and/or problems that you may be experiencing.  Please ensure your post is in the correct Forum to begin with.  Please do not send me Private Messages for personal help but instead use the Forums to allow everyone to read and offer comments to assist you.  Comcast employees are identified with RED lettered User Names.

New Poster

Re: ATTENTION ------ U2R4E

 

Sorry for that.

 

I only left a temp e-mail adress so I'm not worried about it, but thanks anyways.

 

I've been working on the subscription required issue for a few days and wanted to get some personal feedback to see if my temporary solution worked.

 

Thanks,

U2R4E