Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,649,342

members

62

online now

1,825,164

discussions

Back to Top

"Sorry we've experienced some difficulty playing your video"

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 1 of 9
4,721 Views

Mini Ipad2, XFINITY Player App.  Won't play selected videos.  Logged in just fine.  But when I go to play, receive the error "Sorry, we've experienced some difficulty playing your video"  Happens pretty much every day.

 

Thanks

8 REPLIES
Posted by
Silver Problem Solver

Message 2 of 9
4,719 Views

First I have to say it, there is no ipad mini 2 its ipad mini only.

 

make sure you logged in with the primary account holders credentials

does this happen on every video or just some

 

try this

 

log out of your account, delete the app, restart the pad, download the app, log in, try again.   make sure you are subscribed to the shows you want to watch.  Do they work on your computer.  You also need to be close to the wireless to get them to show properly.

 

 

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 3 of 9
4,718 Views

you are correct it is an ipad mini.  we also have an ipad2, my apologies.

we just got the ipad mini like a month ago and it never worked consistently, we just uninstall and reinstall try it a few times and then switch to netflix if we can't get it going.  yes i can watch on the computer just fine. thanks 

Posted by
Silver Problem Solver

Message 4 of 9
4,716 Views

does it work on the ipad 2 at all.   We need to isolate what the issue is. you have two ipads does it do the same thing right by the wireless router>  what speed internet do you subscribe to?

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.

Message 5 of 9
4,660 Views
It works on the ipad2 just fine. I have comcast internet, no idea ehat the speed is. Sorry
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 9
4,538 Views
I am having the exact same problem. TV works fine, xfinity on my computer works fine, the OLD xfinity "play now" app WORKED fine - however the old app no longer allows me to stream to my phone because it auto launches into the NEW app, (or promps me to load the new app). The new app lets me sign in, seems to recognize me, but will always give me that darned error message. I tried signing out - delete - restart - reinstall - re-sign in - it didn't help.
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 7 of 9
4,507 Views

exact same error message, also on the iPad mini, also on the app Smiley Sad  it works fine from the computer...  any thoughts?

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 8 of 9
4,399 Views
I have the same issue and have had the issue ever since the app split in two. I used to watch just fine on the old app. This problem is on 4 devices. My iPhone 4, my wife's iPhone 4S, my iPad 3 and my wife's iPad 1.
Posted by
Visitor
Message 9 of 9
4,375 Views

I am having the same problem. I pay for the extra internet speed and still it will not play. I even downloaded the shows that I wanted to watch and they will not even play.