Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,806,204

members

48

online now

1,952,357

discussions

Top

Xfinity keeps telling me to upgrade Flashplayer

Frequent Visitor

Xfinity keeps telling me to upgrade Flashplayer

I am trying to use the Xfinity web site to watch shows on line.  Xfinity keeps telling me that Adobe Flashplayer needs to be updated.  It doesn't; I am running the latest version (19.0.0.226 : NPAPI & ActiveX) and I have verified it on the Adobe web site as well. I tried uninstalling and reinstalling flashplayer, clearing cache with no luck.  I have tried using IE and I get the same results (Xfinity says I need to update Flashplayer).

 

I am using Firefox 41.0.2 and W7 Pro, 64 bit, and IE 11.

I tried opening a ticket with Xfinity, and that was no help.  Any assistance would be appreciated.

Frequent Visitor

Re: Xfinity keeps telling me to upgrade Flashplayer

Didn't think I would be answering my own post....I talked to Comcast again and it looks like the Firefox add-ons selection was showing Shockwave Flashplayer 11.8 (even though V19 was installed).  Here is what we figured out:

- Open the Firefox menu and select add-ons

- Deactivate Shockwave Flash

- Go to Control panel and uninstall Flashplayer (even if its the latest version)

- Go to https://get.adobe.com/flashplayer/ and download the latest version of flashplayer.  Be sure to uncheck the McAffee box and also note what folder it downloaded to.

- Using Windows Explorer, browse to the download folder and double click on flashplayer19_ha_install.exe

- Flashplayer will install, prompt you to close Firefox, and continue installation.

- After installation is complete, Re-Open Firefox and go to the Add-on page and activate shockwave flash.

The Shockwave flash entry should show V 19.

 

 

 

Discussion stats
  • 1 reply
  • 541 views
  • 0 kudos
  • 1 in conversation