Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,808,892

members

46

online now

1,954,662

discussions

Top

Xfinity home page videos do not play.

ANSWERED
Regular Visitor

Xfinity home page videos do not play.

When I am on the Xfinity home page and select any news, sports, entertainment, etc... and if it is a video, the video do not display on the screen. There is no error message, just a blank screen. My computer is new and able to play high end video games so what can the problem be. If I google the info and find the video on line, I can play it, but not on Xfinity.

Don Alix

Accepted Solution

Re: Xfinity home page videos do not play.

Could you perhaps try a different browser?  You also want to make sure you have the latets version of Flash and Silverlight installed.

View answer in context
Problem Solver

Re: Xfinity home page videos do not play.

Could you perhaps try a different browser?  You also want to make sure you have the latets version of Flash and Silverlight installed.

Regular Visitor

Re: Xfinity home page videos do not play.

I am havig the same issue.  I am using the lastest versions of Flash and Silverlight, also have Chrome and Firefox installed as IE has issues (like it has always, worst of the browsers).  All I get is a blank screen on any of the browsers.  The commercials play, the main video does not.  Since the commercials play, it means it is Xfinity issue, not my system.  This has been going on for about 2-3 weeks only.  Running Win 7 Pro 64-bit on AMD 6-core 3.5 ghz w/16 gigs RAM.  It is something that Comcast did or failed to do.

Contributor

Re: Xfinity home page videos do not play.

Same here.  I've tried Firefox, IE8, and Chrome.  They all behave the same.  The ad runs then the video doesn't.  The indicator will move to the 2nd or 3rd video down, then it will move down again, then move down again, then move down again, and it will keep going until it comes to the very end and stop.

New Poster

Re: Xfinity home page videos do not play.

This post says that the problem is solved and that I can go to the solution but it takes me nowhere.

Regular Visitor

Re: Xfinity home page videos do not play.

It has not been solved.  I have more than one PC and the settings and software for each are different from each other.  Two use Vista, one 32-bit and one 64-bit.  Two others use Win7 64-bit.  Have tried several browsers.  No luck.  It is a Comcast issue, since only the commercials play. 

Regular Visitor

Re: Xfinity home page videos do not play.

I had to stop using xfinity as my home page. Today I tried again, no good, I did the Adobe and Silverlight thing and made up my mind to stop using Xfinity as my home page. Went to MSN and all worked fine. Maybe, just maybe if enough changed they will find time to fix the problem....It has to be Xfinity problem if the other home pages work; Right?? Tired of them trying to pass the buck or yet wanting me to use their "fix for money" sight................

Regular Visitor

Re: Xfinity home page videos do not play.

I have updated all software and tried MSN and chrome.

Contributor

Re: Xfinity home page videos do not play.

Don't know what happened, but the videos seem to be playing today.  Tried with both Firefox and IE8.  Tried multiple videos and they all played.  Are the Comcast gods with us today?

Frequent Visitor

Re: Xfinity home page videos do not play.

Homepage videos do not play, Streampix doesn't work, Premium Channels (HBO,SHO, etc) don't play. It is my fault, I chose Comcast, and they like taking my money, and laughing at me when I ask for help.

Contributor

Re: Xfinity home page videos do not play.

I updated my Win 7Pro OS with MS IE 11 and the videos on the Xfinity home page would not show up, just blank, with only the audio portion functioning. Reinstalling MS IE 11 did not help. The fix that finally worked was found on the MS Technet library.  Check the Software Rendering mode:

1. Open Internet Explorer for the desktop, click the Tools menu, and then click Internet Options.

2. On the Advanced tab, go to the Accelerated graphics section, and then turn on Software Rendering mode by choosing the Use software rendering instead of GPU rendering box.

If the Use software rendering instead of GPU rendering option is greyed out, it means that your current video card or video driver doesn't support GPU hardware acceleration.

Contributor

Re: Xfinity home page videos do not play.

I'm thinking of doing the same thing (Using a different home page). It seems like they are on top of the money but take their time fixing things. Why they didn't leave it the way it was a few yrs. ago when everything worked right is beyond me. Since then it's been a comedy of errors. If they worried as much about our service as they do our money it would be the best service around. My on screen keyboard don't work right, the videos don't work, and I can go on but what's the use? They don't do a thing about it. Even posting this didn't work right.

OH AND THE "SOLVED" DON'T WORK EITHER.

Regular Contributor

Re: Xfinity home page videos do not play.

I've tried everything to fix this issue and nobody bothers to respond to your question.   Does anybody know how to fix this?

Contributor

Re: Xfinity home page videos do not play.

Jason I don't believe they care as long as they get the money. Every other video I play works fine except theirs. It's obviously something wrong with the new site they put up. I wished they would of left it alone.

Contributor

Re: Xfinity home page videos do not play.

Osbueno I tried that with no progress.

Regular Contributor

Re: Xfinity home page videos do not play.

Thanks John.  I just wish they would fix these issues.

Contributor

Re: Xfinity home page videos do not play.

Jasonc126 & Johnnn..., don't know what to say, then... I switched back to the old graphics rendering settings for my graphics card in MS IE 11, and the video went away... again.  After switching back to the new rendering mode setting; Poof!  The Xfinity home page videos reappeared.  The MS TechNet article did mention that if switching the graphics card rendering setting didn't work, then either the graphics card, its drivers, or both, were not likely supported... go figure?

Contributor

Re: Xfinity home page videos do not play.

I have a workstation card because I do a lot of graphics but I've had comcast since they replaced ATT and it always worked great and every other video from every other place work great including the ads but not todays videos etc. I'm calling them today and I'll let everyone know what they say. Oh Images in Emails don't work either in lite mode but I gave up on that one.

Contributor

Re: Xfinity home page videos do not play.

I called and got a recording. I don't do recordings.

Regular Contributor

Re: Xfinity home page videos do not play.

I just sent the moderator a private message...Hopefully I'll get a response cause I haven't seen anybody from Comcast respond to these issues.

Contributor

Re: Xfinity home page videos do not play.

Jasonc126 & Johnnnn... Perhaps it would be good to compare graphics cards?  There seems to be only a couple of main ones used these days; i.e,  AMD & NIVDA?

Contributor

Re: Xfinity home page videos do not play.

If that made a difference why does every other video on the web work including the ad videos at the start of the videos. It has to be something on their siye because they worked until comcast changed their homepage. Also there are a bunch of people with this issue. We are just the only ones on this thread. There are other threads about this. Go to the top and click on solution found and you will see a bunch there too.

Contributor

Re: Xfinity home page videos do not play.

I observed the same results visiting other websites, and the video problems seemed to be confined to the Xfinity home page.  I've followed this thread from the start because the problem was so perplexing.  In fact, Comcast Tech support try to help fix this problem, and so did my HP tech support folks, with no success.  A long Google search of this problem turned up a Microsoft Technet article which worked... go figure?  My HP laptop uses an AMD Radeon 6670M HD graphics card integrated into the Intel HD graphics family chipset.

Contributor

Re: Xfinity home page videos do not play.

I have an workstation NVIDIA Quadro 600 Low Profile card because I'm not a gamer and it can handle the extensive graphics prodjects I do. But again it worked fine until Comcast did one of their homepage transitions. I think KISS is not their motto. BTW it does the same thing on IE and Firefox. 

 
Contributor

Re: Xfinity home page videos do not play.

I'm not a video gamer enthusiast either.  Strangely, I encountered this problem more than a year ago when using a Student Version of Solid Works.  For the SW graphics to display properly, I had to either check or uncheck (can't remember) the box to use software instead of the graphics card's GPU for rendering.  Stranger yet, at first this problem didn't occur when I first used Chrome or Safari as my browser, after upgrading to MS IE 11.  Then somehow the video problem popped up in those browsers too when I tried to access the Xfinity home page.  Don't know what to say, except that I seem to have to use one rendering setting for SW and the other for the Xfinity home page.

Contributor

Re: Xfinity home page videos do not play.

Thanks my card does have auto settings for whatever environment I'm in ie graphics , surfing, etc. I'll try a few and see what I get.

 

Nope, I turned off everything, tried every mode to no avail. Thanks for the idea though.

New Poster

Re: Xfinity home page videos do not play.

I literally just got off the phone with Comcast.  After going through 3 different groups to troubleshoot... the answer is this simple:

 

USE GOOGLE CHROME.

 

Apparently there is a compatibility issue with IE11/Windows 8 at the moment and their programmers are working with Mircrosft to resolve it.  This resolved all Constant Buffering issues for me.

Contributor

Re: Xfinity home page videos do not play.

I use Google Chrome. I've also tried Safari, Firefox, and IE to no avail. If every one of the videos play except the ones on comcast home page and even some of those if you search them out on other sites then it is in comcasts home page but they would rather use Obamas excuse "it's your fault" instead of fixing the coding.

Contributor

Re: Xfinity home page videos do not play.

FYI: Please check this out, but I believe Microsoft only supports IE 10 in Windows 8, while IE 11 is the upgrade for Win7.  We ran into this novelty while updating my daughter's HP ENVY notebook, which sad to say, uses Win8.  The video problems only occurred on my HP Pavilion laptop, which uses WinPro 7. 

Problem Solver

Re: Xfinity home page videos do not play.

I will contact the Xfinity Home team to verify this video issue and to also see if we have a temporary work around.




Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

Regular Contributor

Re: Xfinity home page videos do not play.

Thanks Larry.  We've been trying to communicate this to you guys on the forum for a while but nobody responds.

Contributor

Re: Xfinity home page videos do not play.

Hey I don't know what you did but my videos started working again. Yipee. The images in my email still don't work but Comcast tried to fix those and couldn't. I've learned to live with that though.


ComcastLarry wrote:

I will contact the Xfinity Home team to verify this video issue and to also see if we have a temporary work around.


 

Regular Contributor

Re: Xfinity home page videos do not play.

My videos are still not working.

Contributor

Re: Xfinity home page videos do not play.

The only thing I got that I think could of fixed it was a Java update I recieved. Everything else is as it was on my PC. 

Frequent Visitor

Re: Xfinity home page videos do not play.

sometime ads show but not main video.

Regular Visitor

Re: Xfinity home page videos do not play.

8/25/14  12:08       Problem fixed itself........Can't explain it, videos now work..............I will now use Comcast.net as my homepage........untill something else goes wrong.........................

 

Frequent Visitor

Re: Xfinity home page videos do not play.

Same problem. I click on video in IE,  Chrome or FF and there's nothing playing.

 

http://xfinity.comcast.net/video/Jay-Leno-returns-to-TV-with-CNBC-car-program/342773827928/Comcast/T...

 

Have no problems with videos on any other site but Comcast's home page. 

 

Frequent Visitor

Re: Xfinity home page videos do not play.

What the ---- is up with comcasts home page? Videos do,nt play-pop ups all the time! Wasted alot of time on the phone with them-reset modem-change browsers-nothing helps. I see that many others are having the same issues! What bothers me most is that comcast will not address these issues or even admit they are having problems. they always act like your equiptment is at fault. When I called them they acted like they never heard of these issues.

Contributor

Re: Xfinity home page videos do not play.

Something like this was happening on my system sometime ago.  Only the Comcast homepage seemed to experience problems with displaying video clips.  Initially the problem only occurred when using MS IE - and just after an MS IE upgrade too.  However, later the problem also appeared when using Chrome, Safari, and Mozilla as the browser.  The problem, in my situation, was solved after changing the option to use either software or hardware acceleration for the particular graphics card in my computer.  The exact process to change the GPU setting is slightly different for each browser.  In any case, for MS IE, choose: tools>Internet options>advanced> and either uncheck or check the accelerated graphics box.  Cheers & Good Luck!

Frequent Visitor

Re: Xfinity home page videos do not play.

Thankfully, they've changed the source for the videos and are again using a former version ~ which works great. 

Contributor

Re: Xfinity home page videos do not play.

Mine are working again too.

New Poster

Re: Xfinity home page videos do not play.

Solved?  I have not found the solution any where in the threads.  Obviously, Xfinity programmers do not know how to fix the problem.  The home page videos will not play using IE, so I switched to Google Chrome and it works fine.