Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,807,343

members

7

online now

1,953,181

discussions

Top

Xfinity TV Go App on iPod Touch

New Poster

Xfinity TV Go App on iPod Touch

I accidentally deleted my xfinity tv go app on my iPod touch but when I went to go re-download it from the Apple Store, it said I needed ios7!9or higher to download the app. The app description says I only need ios6 ( which I have) or higher. I have a 4th generation iPod touch which should also be compatible with the app. I used the app this morning and it was working fine on my iPod touch. The Comcast website also says that you only need ios5 or higher to run the app so I'm a little unclear on what the app requirements even are now. Is there any way this can be fixed or is there an older version of the app I could download or am I out of luck? I just don't understand why I should need ios7 to download the app given I have ios6 and the app was working fine this morning.
Discussion stats
  • 0 replies
  • 805 views
  • 0 kudos
  • 1 in conversation