Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,623,108

members

25

online now

1,803,071

discussions

Back to Top

Xfinity Stream and iPad Air - not friends

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 5
425 Views

I've been trying for over 2-3 weeks to log in to the Xfinity Stream app thru my iPad. I can't even get passed the first screen!! (Let's start by adding this iPad to your Xfiniity TV account)

I KNOW I'm using the correct user name and password, since I'm able to login here online. Is there an issue with the iPad or something???? It just says "something has gone wrong" after I hit go - not much help there.

4 REPLIES
Posted by
Official Employee

Message 2 of 5
409 Views

Randizzle wrote:

I've been trying for over 2-3 weeks to log in to the Xfinity Stream app thru my iPad. I can't even get passed the first screen!! (Let's start by adding this iPad to your Xfiniity TV account)

I KNOW I'm using the correct user name and password, since I'm able to login here online. Is there an issue with the iPad or something???? It just says "something has gone wrong" after I hit go - not much help there.


Sorry you're having trouble. iPad Air is one of the more popular devices with the Stream app so I'm sure we can get it working for you.  A couple thoughts:

 

  1. For the sign-in process, we use something called "Safari View Controller" - which is a version of the native browser on your device. If you have your device set to use a different default browser, that may cause issues (have seen this more on Android devices where we use Chrome "Custom tabs"). 
  2. We use (likely require) cookies so please ensure those aren't disabled/blocked

If both of those fail to resolve the issue, we've implemented single-sign-on between several of the XFINITY apps. Perhaps download and try signing into the "XFINITY Connect" app (email app). If that works, you can then try again with XFINITY Stream and it should recognize the user ID and let you in.

 

Please report back how it goes!  Again, sorry.

 

-ComcastDan




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 5
305 Views
Nope, that didn't work either.
Safari is the default and I'm allowing cookies. Didn't have to change those.
I downloaded Connect, logged into email successfully and then tried Stream, same exact issue.
Pretty frustrating actually. Smiley Sad
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 4 of 5
116 Views
I am having the same issue
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 5 of 5
61 Views
As much as I didn't want to, I upgrade to the latest iOS and got it to work.
That's the trade off I guess.