Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,651,521

members

59

online now

1,826,843

discussions

Back to Top

Xfinity Stream Says I am not on my Home WifI...

Posted by
Regular Visitor
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 1 of 25
997 Views

This seems to be an intermiteint issue with the service.  I have a desktop PC (i.e., wired) using my Comcast Business class Internet service.  Starting last Saturday evening, I began to get the message that I could not watch Live TV because I was not on my Home WiFi.  I am only able to watch TV GO channels.

 

This happned about three months ago...and took several weeks to get resolved.  Then it seemed to work fine until last Saturady now it is happening again.  This is very frustrating.  

 

I have Comcast for Phone, TV and Business Class Internet...I expect better relaibility for more than $300/month.

 

What is the issue here?

24 REPLIES
Posted by
Visitor
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 2 of 25
796 Views

I had the same problem, and Comcast's tech support has been trying for 5 days to figure out why their apps were detecting that I was not on my home network. I've read that one issue can be that Comcast has the wrong MAC address for your cable modem, but that checked out. Then tonight I noticed an old post on this forum where someone suggesting checking to see that your router is using Comcast's DNS servers. I checked, and mine was set to use Google's DNS servers. I changed the router to use 75.75.75.75 and 75.75.76.76 and now I can watch live local channels on my MacBook, my iPhone's Xfinity Stream app, and my Roku's Xfinity Stream (beta) app. This may not be your issue, but it's worth checking.

Posted by
Official Employee

Message 3 of 25
700 Views

Hi DrGary, I can assist you fixing this in home Wi-Fi error. Are you using the username and password that is linked to your personal account or your business account? If you are using a username that is linked to your private account at home while connected via hardline at your job then that would be the problem.  If the content is labeled "Watch in Home only" then you must be connected to your home modem to view that content. Also we are moving from our TV GO app, if you are still using this please try downloading the new Xfinity Stream app. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 4 of 25
684 Views
Same issue for me. Just started about an hour ago. Channel clearly says in home below it, click on it, switches to tv go option, and says accessing data. Tried it on two different phones that have the stream app. Never had this issue before.

Seems like every other week it's a new thing. First error codes channels not playing, to recorded shows that were supposed to be an hour, end up being a few minutes only.

Keep up the great work comcast, ha.
Posted by
Official Employee

Message 5 of 25
678 Views

Hi -MF-, have you tried accessing this content on a laptop/desktop? Can you please try removing the Xfinity stream app from your phone and add it back? This will allow your app and account to reconnect to your home network if you are indeed connected to your home " in home network".




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Frequent Visitor
  • You have posted 10 replies to the community. Thank you for keeping the conversations going!
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 25
671 Views

we are experiencing the same issue on our laptop, desktop and ipad. This issue started today

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 7 of 25
664 Views

^ Yes I removed the app, reinstalled it, same issue. 

I've tried it on two different phones in the house. I've tried it on two different laptops, and one desktop, channels that are considered 'in home' do not work. Example I'm in the Chicago area, a local sports channel called CSN as in ahem Comcast SportsNet. Underneath it says In-home in gray....below that in blue with an info saying available to watch in home only. The watch channel option is greyed out and cannot click it. 

 

Before you ask- yes I'm connected to my network. I've tried it on wifi, and hardwired via ethernet. 

 

This is clearly an issue on Comcast's end, and not suprising. Guess I'll just wait it out until they get it resolved like the other things I listed above that they finally got around to.

 

Posted by
Official Employee

Message 8 of 25
647 Views

@-MF- I can assist you further in getting this resolved. Would you please send me a private message with your full address, account number, and the name on the account by clicking my name (ComcastAmir) and then clicking "private message me"? 

 

@JFamily have you tried uninstalling the app on your equipment? Have you tried rebooting your modem so that it registers to your devices in your home? Sometimes when the Xfinity hot spot option is open on your modem your device will revert to using the hot spot instead of your in home network. Please make sure you are connected to the correct internet network. Also if you have an Ethernet cable please try testing our website via hardline on your laptop.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Frequent Visitor
  • You have posted 10 replies to the community. Thank you for keeping the conversations going!
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 9 of 25
618 Views

Yes, we are using our ethernet hardline on the laptop and desktop. trying to stream online it says that we are not using home internet. We have reset our modem and it does not work.

We were able to watch in the morning, but not tonight. Seems similar to other issues report today and in the past.

Posted by
Official Employee

Message 10 of 25
594 Views

Thank you for that information -MF- I have received your private message and will update you as I make progress on this issue. It looks like we are doing some work in your area that is directly related to your problem, I will keep you posted as we make progress in getting this resolved for you. 

 

@JFamily Can you please send me a private message with your account information as well? I will look into this and see if it is related to work being done in your area or if we need to correct some things on our end. Thanks




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 11 of 25
586 Views
Same issue here. I had this going on for weeks during fall 2016, while I'm definitely on home wifi. Tried all they reinstall and restarts, and just losing channels. Some seem to be fine, as I went around, but most say I can't do because I'm not in home. It's quite frustrating. Especially as I was sitting still watching a channel for about ten minutes and then got the noice that I wasn't in home.
Posted by
Regular Visitor
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 12 of 25
580 Views

I am having the same issue with my home desktop computer.  However, only those channels carrying DC sports are affected (Nats, Wizards, and Caps).  The "Watch" button is greyed out for these channels.  All other channels are available.  I chatted with a support person who said this was due to a partial outage somewhere and should be fixed in a few hours.

Posted by
Official Employee

Message 13 of 25
572 Views

Hi WVmac, can you please send me a screen shot of the error that you're receiving on your end?




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Official Employee

Message 14 of 25
569 Views

Hello mmengele, I can look further into this for you. Can you please send me a private message with your full address and account number by clicking my name (ComcastAmir) and then clicking "private message me" Thanks.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 15 of 25
550 Views
Yes. Attaching them. And the channels I do seem to be able to see say TV Go.
IMG_1104.PNG
IMG_1105.PNG
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 16 of 25
520 Views

Ditto to this scenario. It looks like this is a widespread issue tonight maybe..? Or at least I hope this many ppl don't have this problem every day. The message is appearing on my acount accessed on my computer browser & on my Xfinity stream app on my phone. I've: logged out & back into both, turned my modem on/off, turned my devices on/off (can't hurt). 

What's the deal guys? Got a fix?

Posted by
Frequent Visitor

Message 17 of 25
512 Views

I'm getting the same error, on multiple devices.   I've restarted the modem and my devices.  The My Account app won't let me use Administration tools either because it says I'm not at home though I'm definitely connected to my home network.   There's  clearly a bigger issue here.

Posted by
Official Employee

Message 18 of 25
502 Views

Thank you for that information @smity1220, I am showing that most of you experiencing this problem ( not all) is due to work being done in the area. Please go online or to our my account app to view any updates regarding these events in your area.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 19 of 25
489 Views

I've been getting this error all afternoon. (Everything was fine this morning). 

 

Xfinity Stream is not recognizing my home network on my laptop and my phone (iphone).

 

Has a solution been determined?

Posted by
Official Employee

Message 20 of 25
483 Views

I have notified our network and engineering teams, I will keep you all updated as we continue to make progress on getting this resolved.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 21 of 25
435 Views

I'm having the same issue on my home wifi this evening.  It was working fine earlier today.

Posted by
Official Employee

Message 22 of 25
424 Views

 

Hi alanj3, thank you for your response. We are aware of the issue and are in the process of repairing it. I will update this thread as we continue to make progress.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Official Employee

Message 23 of 25
340 Views

Hello all, I have notice from our engineering team that this issue has been resolved on the back end. If you are still experiencing this problem please sign out and then sign back in to the app or website. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 24 of 25
307 Views

We tried you suggestion but it is still telling us that we are not on our home network. I worked on 5/10 and stopped working on 5/11.

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 25 of 25
242 Views

I'm having the same problem!!