Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,809,602

members

7

online now

1,954,970

discussions

Top

X1 TV App - Recorded Shows Are Green & Choppy

New Poster

X1 TV App - Recorded Shows Are Green & Choppy

For the last week or two, watching recorded programing on my mobile devices has been almost impossible. Roughly 80% of the recordings repeatedly flash to a green screen and pause/freeze. This happens on both my iPad Air and iPhone 6s. The ability to watch recorded shows on my mobile devices is one of the main reasons why I love xfinity. Any help would really be appreciated.

Thanks,

Jesse
Problem Solver

Re: X1 TV App - Recorded Shows Are Green & Choppy

I don't have an answer for you as to why this is happening, but maybe a little extra testing could narrow it down.  You said some of the recorded content plays back fine, so is it specific shows that have the problem, or can one show play back fine one time, then be choppy/green another time?

 

If the same show plays choppy/green on both devices, maybe the Cloud DVR recordings are corrupted if you can see the issue always at the same place in a recording.  Is it possible for you to watch one of the choppy/green shows on a PC or laptop?  Does it play fine or is it bad there as well?

 

Post back with your results.

Regular Visitor

Re: X1 TV App - Recorded Shows Are Green & Choppy

Same problem here.  Worked fine until around 2 weeks ago.  Each day I try newly recorded shows, same issue.

IMG_1204.png
Regular Contributor

Re: X1 TV App - Recorded Shows Are Green & Choppy


keni6 wrote:

Same problem here.  Worked fine until around 2 weeks ago.  Each day I try newly recorded shows, same issue.



Same here (Boston). Plays back ok to TV via DVR. I'm also getting ”500" playback errors on iPad, but fine again from DVR.   Seems like a server problem.

Problem Solver

Re: X1 TV App - Recorded Shows Are Green & Choppy

What am I looking at here?  I'm assuming this is through the app, since the XTV web portal doesn't have that particular control in the lower right corner?  The Android app doesn't have that either.  Do you get the same green screen watching through the XTV web portal?  That would say to me a defect in the Cloud DVR recording, most likely requiring a Comcast engineer to look at it.

 

The DVR recording and the Cloud DVR recording are 2 separate files stored in 2 different places.

 

EDIT: Just realized keni6 was not the OP.


keni6 wrote:

Same problem here.  Worked fine until around 2 weeks ago.  Each day I try newly recorded shows, same issue.


 

Regular Visitor

Re: X1 TV App - Recorded Shows Are Green & Choppy

Screen grab is my painful experience using iPad app :-)

New Poster

Re: X1 TV App - Recorded Shows Are Green & Choppy

Im having the same problem - also in Boston and for about the same time. I doubt that is a coincidence. Did anyone ever get an answer from Comcast as to why this is happening? Are they messing around with their streaming service?

New Poster

Re: X1 TV App - Recorded Shows Are Green & Choppy

Oooops, these responses were going to my comcast email not my gmail email so I dind't realize there were responses.

 

Keni6's image was exactly what I was dealing with on my iPad/iPhone. Comcast did call me earlier this week which I really appreciated. I haven't experienced this issue in a week or so, so hopefully its been fixed. 

New Poster

Re: X1 TV App - Recorded Shows Are Green & Choppy

I am having all of the same trouble (Houston). It doesnt seem to discriminate between any particular show. Some are unwatchable they are so bad. They are fine on actual DVR device. Even tried doing a download to ipad rather than stream and it didnt help. Called comcast but couldnt get anyone who could help so I hung up. Grrr

New Poster

Re: X1 TV App - Recorded Shows Are Green & Choppy

Same issue here too.
New Poster

Re: X1 TV App - Recorded Shows Are Green & Choppy

I have the same issue here, usually accompanied with audio skipping, tested on Moto X, Ipad Mini, and Iphone 6S, skips occur at the same time across all three devices, easily repeatable. I made sure each device was only running the Comcast Xfinity TV app, no improvements. Any sugguestions to fix the problem? 

New Poster

Re: X1 TV App - Recorded Shows Are Green & Choppy

I've been having a similar issue for the past 2 months and it's driving me crazy! How was this resolved for you?j

Admin1

Re: X1 TV App - Recorded Shows Are Green & Choppy

Hello -- App issues can generally be resolved by logging out/logging back into the App or by uninstall/re-install of the App. 

 

For further troubleshooting we would need to know the following:

 

Connected to Mobile Network or WiFi 

Name of Mobile Carrier (if connected through Mobile Network)

Make/Model of device being used

Operating System of device

Content you're seeing this issue on

User ID being used when problem occurs

 

Please send that information to me in a Private Message.

 

Click my name (ComcastZach) and click Private Message Me. 




Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

Re: X1 TV App - Recorded Shows Are Green & Choppy

I'm having the same issues, and it's quite frustrating. Choppy playback, green glitchy screen, audio issues, and lately it's been restarting the shows after about 30 seconds of playback. It'll get thirty seconds in, show the green glitchy screen, freeze up for a few seconds, then restart the show.

The only way I can seem to get it to stop the cycle is to skip forward a few minutes using the slide bar. It won't work if I try to use the "skip ahead" button.

It used to work just fine, whether I was streaming or watching a show I saved to the iPad, until a couple months ago. It was just occasional and inconvenient, but now it's constant and makes it literally unwatchable.

My internet is good (I'm pretty consistently at roughly 125mbps download), the iPad is fine (I can watch YouTube and Netflix without issue), and I don't have any problems regarding distance from the router/modem.

I've tried uninstalling and reinstalling the xfinity app, restarting the iPad, updating both the iPad and the xfinity app- none of these things has helped.

We have an iPad Air 2, if that helps anyone with a possible solution.

EDIT: forgot to mention- I live in Urbana, Illinois. Not sure if that'll help, but I suppose it can't hurt.

Thanks in advance for any help!
Regular Visitor

Re: X1 TV App - Recorded Shows Are Green & Choppy

I have been having all these same issues forever.  My only relief has been streaming live which worked fine.  As of this week it is now experiencing the same issues as recorded shows.  Internet is fine.  I switch to Netflix or Amazon a watch with absolutely no problems.  I am IPad Air 2, both apps are the same. TV used to be worse than TV GO but now they are both totally useless.  I basically use it to see what taped and then go and watch on that stations app.