Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,808,840

members

67

online now

1,954,627

discussions

Top

Videos won't play

New Poster

Videos won't play

I am also experiencing the problem of not being able to play Xfinity videos but only for User ID’s running as Standard User.

 

Can play videos on the same machine with my one User ID running as Administrator.

 

Hope this helps in your troubleshooting because I personally think it’s suicidal to surf the Internet as an Admin.

 

Windows 7, IE 9
Silverlight :4.1.10111.0
Flash :11.1 r102
Javascript:enabled
Cookies:enabled

Tags (1)
New Poster

Re: Videos won't play

Just attempted to play the NCIS video with Jamie Lee Curtis under Just In.  Video window appears with message Starting playback. Thats as far as it goes, nothing else happens.

Official Employee

Re: Videos won't play


thekman58 wrote:

Just attempted to play the NCIS video with Jamie Lee Curtis under Just In.  Video window appears with message Starting playback. Thats as far as it goes, nothing else happens.


I tested the NCIS you are referring to and found no issues.

 

Try using a different web browser and let me know if it works. This is not a permanent solution but it will help us narrow down your issue.

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

Re: Videos won't play

Hi, comcastjoe,  I have the same issue with videos in firefox, but not in google chrome.  They run just fine there.  I haven't tried I.E9.

 

Win7 64bit

Silverlight

Flash, up to date

Firefox 13.0.1

Official Employee

Re: Videos won't play


flyincat wrote:

Hi, comcastjoe,  I have the same issue with videos in firefox, but not in google chrome.  They run just fine there.  I haven't tried I.E9.

 

Win7 64bit

Silverlight

Flash, up to date

Firefox 13.0.1


There is something in Firefox that is blocking videos from playing. Try uninstalling Firefox and then install it again.

 

Also, are you getting an error message? Blank screen? What is happening when trying to play a video?

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

Re: Videos won't play

Joe, I already have uninstalled an reinstalled firefox to no avail. I see a blank white spot or the xfinity screen says it loading and and thats all that happens. It never loads the video. i've updated everything and enabled everything I can think of.

Official Employee

Re: Videos won't play


flyincat wrote:

Joe, I already have uninstalled an reinstalled firefox to no avail. I see a blank white spot or the xfinity screen says it loading and and thats all that happens. It never loads the video. i've updated everything and enabled everything I can think of.


If you have any ad blocking plug-ins in Firefox, please disable them and then try watching a video again.

 

Thanks,
Joe
XfinityTV.com/Xfinity.com Support
Twitter: @XfinityTVJoe




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
New Poster

Re: Videos won't play

I have internet explorer 11 on my computer. I have been trying to watch videos from xfinitytv.comcast.net for weeks and it hasn't worked. I even downloaded firefox, and the videos still will not play. What should I do?

Discussion stats
  • 7 replies
  • 2807 views
  • 0 kudos
  • 4 in conversation