Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,708,570

members

52

online now

1,872,228

discussions

Back to Top

Sound not transferring properly thru my apple tv

SOLVED
Posted by
New Poster
  • Great Job! Your reply has been accepted. Thank you for helping and Congrats on your 1st Solution.
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 1 of 7
473 Views

I have not had a problem with this until today worked as early as last night even.  I screen share my mac through my apple tv and today the sound doesnt come out of my soundbar that is connected to my tv like it usually does and only plays through my computer speakers.  I reset everything and it plays through other sites and computer programs like it's supposed to.  It's just the xfinity stream site that this no longer working properly.

1 ACCEPTED SOLUTION

Accepted Solutions
Posted by
New Poster
  • Great Job! Your reply has been accepted. Thank you for helping and Congrats on your 1st Solution.
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 2 of 7
860 Views
Solution

Fixed thr problem clearing my cache history. not any issuse anymore

6 REPLIES
Posted by
New Poster
  • Great Job! Your reply has been accepted. Thank you for helping and Congrats on your 1st Solution.
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 2 of 7
861 Views
Solution

Fixed thr problem clearing my cache history. not any issuse anymore

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 3 of 7
379 Views

I'm having the same issue today.  I can airplay from imac to apple tv, video works fine but no sound. how do you clear the cache history?

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 4 of 7
255 Views
This did not fix my problem. Is there anything beyond clearing the cache that I need to do? Thx!
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 5 of 7
223 Views

Same problem here. 

Occured about the same time as OP.

tv.xfinity site stopped transferring audio to AppleTV. All other audio from my Mac transfers fine. Even other sites. Exclusive to xfinity stream.

I cleared the cache the other day and fixed the problem, but only temporarily. About a day later it happened again. 

Clearing the Cache whenever this happens is NOT a solution. As this negatively affects everything else in order to fix it. 

I tried removing just the xfinity site data from the cache, but that didn't work. There must be some other listing burried in there associated with Xfinity that is not obvious.

 

PLEASE FIX THIS PROBLEM XFINITY

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 7
194 Views

I am having the same issue. Video going to my TV, but sound only coming from laptop. I called Xfinity and they said it was an issue on my end, not theirs. Aparently they dont read these forums since others are having the same issue. I hope they fix it soon.....soon like today.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 7 of 7
111 Views
Yeah this is terrible. Comcast needs to address this issue. If anyone finds a work-around, I'd love to hear it