Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,680,373

members

64

online now

1,849,380

discussions

Back to Top

Roku Not working any longer

Posted by
New Poster
  • Congrats on Posting your first topic!

Message 1 of 7
723 Views

Well all my XfinityStream on demand shows all died at once. My Computer and Roku both Started with the Something Went Wrong or Unable to Retrieve at the exact same time. A Chat fixed the computer issue but I am still unable to load anything on roku after erasing the channel from the Roku and adding it again and then xfinity.com/authorize to activate it and still Live Tv works and On demand does not. This is horrible because Roku is my new way of watching in my living room.

6 REPLIES
Posted by
Official Employee

Message 2 of 7
677 Views

Davis937 wrote:

Well all my XfinityStream on demand shows all died at once. My Computer and Roku both Started with the Something Went Wrong or Unable to Retrieve at the exact same time. A Chat fixed the computer issue but I am still unable to load anything on roku after erasing the channel from the Roku and adding it again and then xfinity.com/authorize to activate it and still Live Tv works and On demand does not. This is horrible because Roku is my new way of watching in my living room.


I'm sorry you're having trouble.  I refreshed your account and removed your existing Roku device. Can you please try to sign in again and let me know if things are resolved?

 

Do you happen to know what the agent did to fix your computer issue? It might help us update the agent's documentation on how to resolve these issues in the future.  Again, sorry.

 

Thank you,

ComcastDan




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 3 of 7
524 Views

My Xfinity Sream app on my Roku does not work today  I reinstalled it twice but all I get, after entering the authorization code, is Error createDrmSession403-102 "This device can onnly access Xfinity on your home wifi".  

 

Of course, I am home, as I was yesterday! Help!

Posted by
New Poster
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 4 of 7
504 Views
Same thing happening to me ..exactly Smiley Sad
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 5 of 7
489 Views

Somebody fixed something because now, after 4 hrs and 8 activations,  it works again. Thank you!

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 7
476 Views

Mine is back working as well

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 7 of 7
329 Views

I have the same issue with my Roku and the Xfinity stream app.  It says "This device can only access Xfinity stream on your in-home  Xfinity wi-fi. .... "  

ERROR 403-102

Is any one else having this problem again?  or still? 

Any idea how to fix it?  I removed Xfinity from the roku and reinstalled... nada  

Thank you