Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,806,676

members

52

online now

1,952,666

discussions

Top

Out of Home

New Poster

Out of Home

I am connected to my home wifi. When I try to watch anything on xtv.comcast.net, it tells me that I am Out of Home.  I click on the Learn More, and it just tells me that I'm Out of Home.  I click retry, and it just says that I'm Out of Home.

 

Why is this so junky, clunky, and WRONG? I do I tell it that I'm on my home wifi network when I'm really on my home wifi network?

 

 

Bronze Problem Solver

Re: Out of Home

Do you have a Comcast router combo with the xfinity hotspot on it?  If so is that the wireless you are connected to?

New Poster

Re: Out of Home

It's like a router, but y'all give it a fancier name than that now.  I have my home network, then there's the public exposed free wifi thing.  I am connected to my home network, and not to the free public exposed one.

Frequent Visitor

Re: Out of Home

Getting same message.

New Poster

Re: Out of Home

same issue

New Poster

Re: Out of Home

What to do about this?
New Poster

Re: Out of Home

I just got an e-mail from Comcast that said that they had unlocked the service that would allow me to watch TV on my computer. So of course I immediately tried it and got the same "Out of Home" message that the rest of you guys are getting. I know I have a non-standard configuration, I have the WiFi in my cable modem shut off, it's operating in bridge mode. I have a lot better control of the security settings using the WiFi features of my own router. It's been working well that way for quite a while now.

 

Strange that they would introduce a new feature that requires a particular modem setup and not publish the setup requirements at the same time that they introduce the feature. And they haven't updated the "help and support" web page with a link to help with this new service either. Maybe not so strange, it does fit with the normal quality of Comcast customer service, doesn't it?

Frequent Visitor

Re: Out of Home

I called in, definitely an issue on their end.  This X1 platform is serious Beta.  The Live TV streaming has been terrible, the support has been dreadful.  I hope they can get it together soon.

New Poster

Re: Out of Home

It's working today. I didn't do anything to fix it, so Comcast must have fixed it on their end. It's working on both my computer and on my phone. So give it another try folks, maybe it's really fixed.

New Poster

Re: Out of Home

Yes, it's working! Thank you!

New Poster

Re: Out of Home

I'm having the same problem. Comcast sent the announcement yesterday, November 18th, and it hasn't worked at all.
I have rebooted everything, and no luck. It didn't fix itself overnight, like others on this thread.
Frequent Visitor

Re: Out of Home

Apparently this has been an issue for a while now. I had it for a couple days, and I finally called the number listed in the app settings. He told me it was a bug that they were trying to work out. He also told me to uninstall and reinstall the app on my devices as that seemed to have been working with others. I unintalled the app and reinstalled, and it did indeed start working again. Somehow the web portal started working after that as well. I really can't explain the logic behind that web portal working, but it did.

New Poster

Re: Out of Home

I just got X1 service last week. All of my devices were able to connect via the xtv.comcast.net site without issue until today. All of a sudden, no matter which device I use, it shows Out of Home in purple on top of the page. I've got my computer wired directly into the Comcast modem. I went through 3 different layers of online chat troubleshooting. Frankly, those folks were clueless.

 

I've tried every browser. I've asked them to check the modem to make sure it is still associated with the account. I'm now waiting on someone from a higher technical support group to call me at some undetermined time/date.