Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,805,474

members

52

online now

1,951,913

discussions

Top

My Samsung 10.1 tablet doesn't show up as authorized

Regular Visitor

My Samsung 10.1 tablet doesn't show up as authorized

I have installed the latest TV Go App on my Samsung Note 10.1 with Jellybean and signed in with my name and password. We have Comcast Interned on our own and Comcast Digital HD TV through our community. 

 

The app comes up with all the selections, cover art, etc., but when I try to select something it just keeps loading. When I go to the device page, It shows no devices registered/authorized.

 

The ad copy mentions "eligible channels" ... I thought this meant if you wanted a pay channel, you had to pay for it. That I understand but I'm not getting anything..

 

 

Help please ...

 

New Poster

Re: My Samsung 10.1 tablet doesn't show up as authorized

I had the same problem, with same hardware, etc.  I first installed it while at my Dad's house on his Centurylink network, and got exactly what you did, with no device registration showing in the app or under manage devices via web browser.  I later went home where I have Comcast and tried again, with no difference.  Tried signing out and back in with a friend's account, no difference.  Signed out and back in on my account.  More of the same.  Finally un-and-re-installed, logged in, and this time everything seemed to work.  Downloaded a show and only then did my device get registered.

 

When I got back to my Dad's again, it was back to the old behaviour.  Wouldn't play my downloaded movies either.  Disabled the WiFi and then I could watch the downloaded movies.  Lo and behold, re-enabled the WiFi, and now it works normally again, including watching subscriber-only streaming.

 

Not sure if any of that will help anyone, but that was my experience.

Discussion stats
  • 1 reply
  • 897 views
  • 0 kudos
  • 2 in conversation