Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,810,070

members

48

online now

1,955,251

discussions

Top

My DVR mgr - not working with new STB?

Regular Visitor

My DVR mgr - not working with new STB?

Hi. I had 2 DVRs, 1 Cisco RNG200 and a Sci Atl 8300HD. The SA 8300HD DVR, after several years, finally died - so I swapped it out today.

 

The new box is another Cisco RNG200 - so now I have 2.

 

I am having trouble interfacing the new STB with My DVR on my iphone and computer Xfinity site.

 

On the computer/website: THe new Cisco appears under the list of DVRs, but it does not allow "TV Control" nor can I view/record to it.  I was able to name it: Living Rm DVRNEW - but beyond naming it - I am not able to control it.

 

On my iPhone: only my Master Bedroom DVR appears. The new Cisco does not appear as a DVR at all.

 

How can I get the new Cisco to 'appear'?  The box is installed/activated and I am watching TV on it.  It has been plugged in for several hours.  How long does it usually take to become fully active?

 

I have tried calling Support (India? When did all Comcast support move overseas - it is just terrible service) but they spend 20 minutes verifying who I am and putting me on hold for "2 minutes sir" to 'research' my issue - then can't even get me basic info. 

 

Thanks. Mark

Tags (1)
Silver Problem Solver

Re: My DVR mgr - not working with new STB?

it takes a few days for the new box to be added to your account properly and flow down to the app

Regular Visitor

Re: My DVR mgr - not working with new STB?

rog286713:

 

Thanks for the reply.  Ill keep my eyes on it and report back.  Since the box appears online (PC) version on my list of DVRs, but is not 'usuable' there - I thought maybe there was an issue.  Ill give it 3-4 days and update.

 

Thanks again for the advice.

Discussion stats
  • 2 replies
  • 1083 views
  • 0 kudos
  • 2 in conversation