Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,709,447

members

66

online now

1,872,780

discussions

Back to Top

Live TV Streaming stuck at loading screen

Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 14
1,177 Views

Upon opening the live streaming tv on my browser, it will show blank columns with the loading icon in the middle. It will stuck forever, I tried letting it load in the background but after a few hours it's still like that. I have tried different browsers (Chrome, Edge, and Firefox) and different PCs to no avail. If I try logging in with my mobile app on my phone (Google Pixel), it will give me a Security 3322 error. Any fix?

Since no devices work, I'm guessing it's something with my setup rather than the devices. I'm using an approved ARRIS Surfboard SB6183 modem with Google Wifi routers – according to the specs they should work.

 

13 REPLIES
Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 2 of 14
1,116 Views

And no one answers after 20 hours... :'(

Posted by
Regular Contributor

Message 3 of 14
1,076 Views

It looks like the streaming service is no more.  It has been discontinued.

Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 4 of 14
1,043 Views

Is this confirmed? Is there a source somewhere? Thanks!

Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 5 of 14
1,017 Views

Come on it's been 5 days since I posted this question and still no one from Comcast giving one single response. What a great service we're getting here.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 14
964 Views

Especially with the price they charge...outrageous!

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 7 of 14
947 Views

Actually I had the same problem.  The issue is the latest Windows 10 update they call Creator's Update.  Streaming TV worked up until the upgrade, now it just hangs like you say on the loading the TV guide page.  I've confirmed this as both my computers have done the same things and I've had to back out the update and now it's working again.  Something in the update is screwing things up and I have yet to find out why. 

Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 8 of 14
934 Views
I am indeed on creators update, but my Android devices which uses a dedicated Xfinity Steam app is also not working.
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 9 of 14
906 Views

My iOS devices work fine, but not Windows 10 on laptop. I have done the updates also.

Posted by
Contributor

Message 10 of 14
626 Views

Welcome to Comcast where they take your money and give you nothing but headaches in return. 

Posted by
Contributor

Message 11 of 14
622 Views

I don't have Windows 10 and I have the same issues.

Posted by
New Poster
  • Congratulations on receiving your first Kudos! Thank you for your meaningful contribution to the forum. May this be the first of many kudos.
  • Congrats on Posting your first topic!

Message 12 of 14
608 Views

Having same problem for days on my laptop.  Log in and loads to blank screen.  Tried clearing caches and other suggestions, still not working

Posted by
Contributor

Message 13 of 14
561 Views
Still no response or help from cumcast. Please take more of our money and do less for us!!!
Posted by
Official Employee

Message 14 of 14
331 Views

Hello all, I can assist you with getting this error message cleared up. When you go to the browser does it let you sign in? Do you get this error when only trying to watch content online? 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon