Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,806,617

members

80

online now

1,952,642

discussions

Top

Cannot play videos

New Poster

Cannot play videos

After waiting 4 hours for the website to come back up this morning, I now can not play any video on the entire website. I can see everything there but you can't click on anything to actually play the video. This is not a device issue, I've tried on 3 different computers now. Any idea when this will be working again?

Silver Problem Solver

Re: Cannot play videos

Hello,

Please provide us some more detail information.

New Poster

Re: Cannot play videos

Any episode for any show I try to play, all I can do is hover over it and it gets highlighted. Normally, you can click on it and the play button will show up. Not only can I not click on any episode for play, but there is no play button for any episode, period.

Silver Problem Solver

Re: Cannot play videos

Hello,

Are you getting any error message or anything unusual? Have you tried a different browser and cleared your browser? Has it ever worked before? Have you tried refresh the page?

New Poster

Re: Cannot play videos

I also am having the same issue.  The play button lo longer exists for anything.

I can play any video from the main screen by clicking the play latest button, but if i trying to go into any show and pick an episode it will not let me

Frequent Visitor

Re: Cannot play videos

Discussion stats
  • 5 replies
  • 682 views
  • 0 kudos
  • 4 in conversation