Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,806,687

members

47

online now

1,952,672

discussions

Top

Can't Play TV Show Content..Keeps Saying I Need Current Version of Flash Player.

Contributor

Can't Play TV Show Content..Keeps Saying I Need Current Version of Flash Player.

Running Windows 7, IE on my Desktop PC. I have installed the MOST current version of Flash Player (v. 19.xx) several times. When I try to watch a TV show (not a live one in real time rather an episode I missed) I am prompted every X to Install a version of Flash Player above 15.xx.

 

As stated I have downloaded Flash Player when prompted by Adobe every time.

 

What may be the problem here and any dumbed-down instructions about how to solve it will be appreciated.

 

Thanks.

Discussion stats
  • 0 replies
  • 207 views
  • 0 kudos
  • 1 in conversation