Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,874,972

members

769

online

29,260

topics

Top

x1 says "BOOT" on box, then on screen it says "WELCOME powering up. this may take a few minutes"

Regular Visitor

x1 says "BOOT" on box, then on screen it says "WELCOME powering up. this may take a few minutes"

then it goes black and the "BOOT" message comes back on the box, the power button goes on/off. I've unplugged both tv and box, I pressed and held the power button on the box for 10 seconds. I've turned the box off/on. I can't get anything else on the screen so I'm unable to try any of the other reboot suggestions. ?? help??

Service Expert

Re: x1 says "BOOT" on box, then on screen it says "WELCOME powering up. this may tak


bunnywun wrote:

then it goes black and the "BOOT" message comes back on the box, the power button goes on/off. I've unplugged both tv and box, I pressed and held the power button on the box for 10 seconds. I've turned the box off/on. I can't get anything else on the screen so I'm unable to try any of the other reboot suggestions. ?? help??


do you have another X1 set top box? If so, can you temporarily swap the boxes and see if the problem follows the box?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Official Employee
Moved:

Re: x1 says "BOOT" on box, then on screen it says "WELCOME powering up. this may tak

Official Employee

Re: x1 says "BOOT" on box, then on screen it says "WELCOME powering up. this may take a few minutes"

Hello, bunnywun. I'd like to try sending a refresh signal to your X1 box to see if this resolves the issue. This may cause a brief interruption of service, would now be an okay time to do so?


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Special Events
FIFA World Cup 2018 on Xfinity See More
Discussion stats
  • 3 replies
  • 4160 views
  • 0 kudos
  • 3 in conversation