Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,858,471

members

1,280

online

29,720

topics

Top

menu

New Poster

menu

Lately, i have been having trouble with loading of the menu on X1. When i turn on the TV, it can take upto 5 seconds before i click a scroll arrow button on remote and menu respodning on the Xfinity Guide. This ihas been frustrating. However, this is not the case when i use xfinity app remote on my iphone. Can someone help me sort this out? Thanks

Regular Contributor

Re: menu

Are the batteries in your remote low? Also, if you paired the remote to the box via RF then you may be experiencing RF interference that is causing slow response from the remote.

 

Since the box responds fine by the app, then I suggest you try replacing the remote if that does not work.

 

Also, you can unpair the remote from the box and use the IR to send signals to the box. If that fixes it then it is RF interference.

 

I believe on the XR remote you hold A and D buttons to unpair. 

Service Expert

Re: menu


wrote:

Lately, i have been having trouble with loading of the menu on X1. When i turn on the TV, it can take upto 5 seconds before i click a scroll arrow button on remote and menu respodning on the Xfinity Guide. This ihas been frustrating. However, this is not the case when i use xfinity app remote on my iphone. Can someone help me sort this out? Thanks


when you turn on your TV is the power LED for the X1 set top box also turning on at the same time?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Forums Tips and Tricks:
Tagging Posts... See More
Discussion stats
  • 2 replies
  • 211 views
  • 0 kudos
  • 3 in conversation